# 500: An internal server error

**URL:** <https://discuss.elastic.co/t/500-an-internal-server-error/103543>\
**Category:** Elastic Cloud Enterprise (ECE)\
**Created:** [October 11, 2017, 12:19pm UTC](https://discuss.elastic.co/t/500-an-internal-server-error/103543 "2017-10-11T12:19:45Z")\
**Posts on this page:** 15\
**Page:** 1

<div class="post-metadata">

**Author:** ![annu](https://avatars.discourse-cdn.com/v4/letter/a/5f8ce5/32.png) [@annu](https://discuss.elastic.co/u/annu)\
**Post date:** [October 11, 2017, 12:19pm UTC](https://discuss.elastic.co/t/500-an-internal-server-error/103543/1 "2017-10-11T12:19:45Z")

</div>

I've tried to change the cluster memory from 1GB to 2GB from ECE console. Now no cluster(including logging and metrics cluster) is coming up and showing error "500: An internal server error ". I've enough memory left, about 4GB.

I'm facing downtime.  
how should i proceed for this?

Thanks  
Annu

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [October 11, 2017, 2:48pm UTC](https://discuss.elastic.co/t/500-an-internal-server-error/103543/2 "2017-10-11T14:48:20Z")

</div>

I moved the question to #cloud-enterprise

---

<div class="post-metadata">

**Author:** ![Alex\_Piggott](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/alex_piggott/32/11053_2.png) [@Alex\_Piggott](https://discuss.elastic.co/u/Alex_Piggott)\
**Post date:** [October 11, 2017, 2:56pm UTC](https://discuss.elastic.co/t/500-an-internal-server-error/103543/3 "2017-10-11T14:56:43Z")

</div>

Hi @annu

Can you provide a bit more detail on what happened exactly?

Eg it sounds like ...

- You had an ECE platform (what configuration, eg how many allocators etc, how much RAM etc)?
- It had some additional clusters in it that you'd created (how many/what sizes)
- You increased the size of one of them from 1GB to 2GB

At which point the UI stopped working?

---

<div class="post-metadata">

**Author:** ![Alex\_Piggott](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/alex_piggott/32/11053_2.png) [@Alex\_Piggott](https://discuss.elastic.co/u/Alex_Piggott)\
**Post date:** [October 11, 2017, 2:59pm UTC](https://discuss.elastic.co/t/500-an-internal-server-error/103543/4 "2017-10-11T14:59:14Z")

</div>

@annu

It sounds like the adminconsole cluster (or possibly the whole allocator hosting it) went down, which takes the UI down with it

You can check what's going on without the UI, using the API (docs: [https://www.elastic.co/guide/en/cloud-enterprise/current/ece-api-reference.html](https://www.elastic.co/guide/en/cloud-enterprise/current/ece-api-reference.html))

eg `curl -u root:PASSWORD 'HOST:12400/clusters/elasticsearch'` (use `readonly` and its password to generate a sanitized list) will list the clusters together with some basic health information, `/platform/infrastructure/allocators` will list the health of the allocators etc

---

<div class="post-metadata">

**Author:** ![annu](https://avatars.discourse-cdn.com/v4/letter/a/5f8ce5/32.png) [@annu](https://discuss.elastic.co/u/annu)\
**Post date:** [October 12, 2017, 5:47am UTC](https://discuss.elastic.co/t/500-an-internal-server-error/103543/5 "2017-10-12T05:47:01Z")

</div>

Hi

I was using 32GB disk and 1GB memory for my cluster(i created). Due to the increased memory pressure, i changed the memory from 1GB to 2GB. While that migration was happening, my UI went down and now I'm getting "Fetching clusters failed" and "service unavailable" errors when i login to my ELK.

And i'm getting "{"ok":false,"message":"The requested cluster is currently split"}" when i try to hit my elastic search endpoint.

thanks  
Annu

---

<div class="post-metadata">

**Author:** ![annu](https://avatars.discourse-cdn.com/v4/letter/a/5f8ce5/32.png) [@annu](https://discuss.elastic.co/u/annu)\
**Post date:** [October 12, 2017, 6:46am UTC](https://discuss.elastic.co/t/500-an-internal-server-error/103543/6 "2017-10-12T06:46:58Z")

</div>

![elasticsearch](https://us1.discourse-cdn.com/elastic/original/3X/6/8/68f7af7c10ca5bdd794a76e5c24f956effb4d331.png) ![cluster](https://us1.discourse-cdn.com/elastic/original/3X/c/9/c9d8b5b59da505f6c83cffa7ca6de1bafcaa70c9.png)

---

<div class="post-metadata">

**Author:** ![Alex\_Piggott](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/alex_piggott/32/11053_2.png) [@Alex\_Piggott](https://discuss.elastic.co/u/Alex_Piggott)\
**Post date:** [October 12, 2017, 1:24pm UTC](https://discuss.elastic.co/t/500-an-internal-server-error/103543/7 "2017-10-12T13:24:26Z")

</div>

Thanks for the details, seems like 2 things have happened:

- When updating an overloaded cluster you got a split brain situation - this has started happening with a bit of regularity, and once we get the platform back I will provide some strategies for dealing with it
- The split brain has somehow taken down the administrative cluster that the UI uses to display the clusters ... this I haven't seen before

Can you run a few API commands as the user `readonly` (which ensures you don't leak any secrets)

- `curl -u readonly:PASSWORD "http://HOST:12400/api/v1/clusters/elasticsearch"` - returns a list of all the clusters and their health
- `curl -u readonly:PASSWORD "http://HOST:12400/api/v1/clusters/elasticsearch/XXX"` where XXX is the adminconsole cluster return from the previous call
- `curl -u readonly:PASSWORD "http://HOST:12400/api/v1/clusters/elasticsearch/YYY/plan/activity"` where YYY is the cluster that you upgraded and split brained
- `curl -u readonly:PASSWORD "http://HOST:12400/api/v1/platform/infrastructure/allocators"` - provides information about the health of the allocators that run the clusters

(API reference: [https://www.elastic.co/guide/en/cloud-enterprise/current/ece-api-reference.html](https://www.elastic.co/guide/en/cloud-enterprise/current/ece-api-reference.html))

---

<div class="post-metadata">

**Author:** ![annu](https://avatars.discourse-cdn.com/v4/letter/a/5f8ce5/32.png) [@annu](https://discuss.elastic.co/u/annu)\
**Post date:** [October 12, 2017, 3:44pm UTC](https://discuss.elastic.co/t/500-an-internal-server-error/103543/8 "2017-10-12T15:44:23Z")

</div>

i'm not able to login to Elastic cloud.  
when i tried : **curl -u readonly:PASSWORD "[http://HOST:12400/api/v1/clusters/elasticsearch](http://HOST:12400/api/v1/clusters/elasticsearch)"**  
i'm getting authentication error  
{  
"errors": [{  
"code": "root.unauthenticated",  
"message": "The supplied authentication is invalid"  
}]  
}

---

<div class="post-metadata">

**Author:** ![Alex\_Piggott](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/alex_piggott/32/11053_2.png) [@Alex\_Piggott](https://discuss.elastic.co/u/Alex_Piggott)\
**Post date:** [October 12, 2017, 9:22pm UTC](https://discuss.elastic.co/t/500-an-internal-server-error/103543/9 "2017-10-12T21:22:30Z")

</div>

@annu - sorry the `PASSWORD` i meant was the password corresponding to the user, eg it was displayed when you installed it:

```auto
Admin Console Details
URL : http://HOST:12400
Root username : root
Root password : Cus8qwjzlSI22Tm73a9hITNgWaf304MIACsTSjdzufh
Read-only username : readonly
Read-only password : SwO7kMNCHeUsUGVoouvZbOXt0OgmLEe79NdF9LAYFgc

```

if you didn't take a note of it at the time, not to worry, all the credentials are kept `/mnt/data/elastic/bootstrap-state/bootstrap-secrets.json` (may vary if you installed in a different root directory)

---

<div class="post-metadata">

**Author:** ![annu](https://avatars.discourse-cdn.com/v4/letter/a/5f8ce5/32.png) [@annu](https://discuss.elastic.co/u/annu)\
**Post date:** [October 13, 2017, 5:31am UTC](https://discuss.elastic.co/t/500-an-internal-server-error/103543/10 "2017-10-13T05:31:13Z")

</div>

Hi @Alex_Piggott  
i give the same password on my read-only field.

thanks  
Annu

---

<div class="post-metadata">

**Author:** ![Alex\_Piggott](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/alex_piggott/32/11053_2.png) [@Alex\_Piggott](https://discuss.elastic.co/u/Alex_Piggott)\
**Post date:** [October 13, 2017, 1:33pm UTC](https://discuss.elastic.co/t/500-an-internal-server-error/103543/11 "2017-10-13T13:33:23Z")

</div>

Does it work with `root`?

---

<div class="post-metadata">

**Author:** ![annu](https://avatars.discourse-cdn.com/v4/letter/a/5f8ce5/32.png) [@annu](https://discuss.elastic.co/u/annu)\
**Post date:** [October 13, 2017, 1:49pm UTC](https://discuss.elastic.co/t/500-an-internal-server-error/103543/12 "2017-10-13T13:49:12Z")

</div>

@Alex_Piggott

I'm not getting any output when i run `curl -u readonly:PASSWORD "http://HOST:12400/api/v1/clusters/elasticsearch"` this command.

i tried using with root password also. but no result.

---

<div class="post-metadata">

**Author:** ![Alex\_Piggott](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/alex_piggott/32/11053_2.png) [@Alex\_Piggott](https://discuss.elastic.co/u/Alex_Piggott)\
**Post date:** [October 13, 2017, 2:58pm UTC](https://discuss.elastic.co/t/500-an-internal-server-error/103543/13 "2017-10-13T14:58:19Z")

</div>

> [@annu](#):
>
> curl -u readonly:PASSWORD "[http://HOST:12400/api/v1/clusters/elasticsearch](http://HOST:12400/api/v1/clusters/elasticsearch)

Try adding `-vvv` in there, that will give a lot more details about the failure, eg `curl -vvv- u <etc etc>`

---

<div class="post-metadata">

**Author:** ![Alex\_Piggott](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/alex_piggott/32/11053_2.png) [@Alex\_Piggott](https://discuss.elastic.co/u/Alex_Piggott)\
**Post date:** [October 17, 2017, 8:42am UTC](https://discuss.elastic.co/t/500-an-internal-server-error/103543/14 "2017-10-17T08:42:22Z")

</div>

@annu I believe we have a fix for your issue here [Kibana Instances "Unable to Connect to Server"](https://discuss.elastic.co/t/kibana-instances-unable-to-connect-to-server/104118/2?u=alex_piggott)

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [November 14, 2017, 8:42am UTC](https://discuss.elastic.co/t/500-an-internal-server-error/103543/15 "2017-11-14T08:42:57Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
