# 500 Error when attempting to drill into Marvel cluster

**URL:** <https://discuss.elastic.co/t/500-error-when-attempting-to-drill-into-marvel-cluster/36078>\
**Category:** Elasticsearch\
**Tags:** elastic-stack-monitoring\
**Created:** [December 1, 2015, 4:57pm UTC](https://discuss.elastic.co/t/500-error-when-attempting-to-drill-into-marvel-cluster/36078 "2015-12-01T16:57:29Z")\
**Posts on this page:** 12\
**Page:** 1

<div class="post-metadata">

**Author:** ![Danny830x](https://avatars.discourse-cdn.com/v4/letter/d/b4bc9f/32.png) [@Danny830x](https://discuss.elastic.co/u/Danny830x)\
**Post date:** [December 1, 2015, 4:57pm UTC](https://discuss.elastic.co/t/500-error-when-attempting-to-drill-into-marvel-cluster/36078/1 "2015-12-01T16:57:29Z")

</div>

I'm running an Elasticsearch 2.0 cluster primarily used for Logstash with the latest versions of Marvel and Kibana. All Kibana functionality seems to work as expected. When accessing Marvel, the page loads with the cluster details and state but when I attempt to click on and drill into that cluster I get a 500 error.

That error in the browser is just:

> {"statusCode":500,"error":"Internal Server Error","message":"An internal server error occurred"}

It seems to be attempting to access:

> Request URL:[http://my.kibana.cluster/api/marvel/v1/clusters/Tk-RrFm7TnOocicaq-qjAQ](http://my.kibana.cluster/api/marvel/v1/clusters/Tk-RrFm7TnOocicaq-qjAQ)

On the ES servers I was getting the following error:

> [2015-12-01 00:28:16,290][INFO][rest.suppressed] /.marvel-es-_/\_field\_stats Params: {index=.marvel-es-_, level=indices, ignore\_unavailable=true}  
> java.lang.NullPointerException  
> at org.elasticsearch.action.fieldstats.TransportFieldStatsTransportAction.newResponse(TransportFieldStatsTransportAction.java:122)  
> at org.elasticsearch.action.fieldstats.TransportFieldStatsTransportAction.newResponse(TransportFieldStatsTransportAction.java:54)  
> at org.elasticsearch.action.support.broadcast.TransportBroadcastAction$AsyncBroadcastAction.finishHim(TransportBroadcastAction.java:229)  
> at org.elasticsearch.action.support.broadcast.TransportBroadcastAction$AsyncBroadcastAction.onOperation(TransportBroadcastAction.java:194)  
> at org.elasticsearch.action.support.broadcast.TransportBroadcastAction$AsyncBroadcastAction$1.handleResponse(TransportBroadcastAction.java:174)  
> at org.elasticsearch.action.support.broadcast.TransportBroadcastAction$AsyncBroadcastAction$1.handleResponse(TransportBroadcastAction.java:161)  
> at org.elasticsearch.transport.netty.MessageChannelHandler.handleResponse(MessageChannelHandler.java:185)  
> at org.elasticsearch.transport.netty.MessageChannelHandler.messageReceived(MessageChannelHandler.java:138)  
> at org.jboss.netty.channel.SimpleChannelUpstreamHandler.handleUpstream(SimpleChannelUpstreamHandler.java:70)  
> at org.jboss.netty.channel.DefaultChannelPipeline.sendUpstream(DefaultChannelPipeline.java:564)  
> at org.jboss.netty.channel.DefaultChannelPipeline$DefaultChannelHandlerContext.sendUpstream(DefaultChannelPipeline.java:791)  
> at org.jboss.netty.channel.Channels.fireMessageReceived(Channels.java:296)  
> at org.jboss.netty.handler.codec.frame.FrameDecoder.unfoldAndFireMessageReceived(FrameDecoder.java:462)  
> at org.jboss.netty.handler.codec.frame.FrameDecoder.callDecode(FrameDecoder.java:443)  
> at org.jboss.netty.handler.codec.frame.FrameDecoder.messageReceived(FrameDecoder.java:303)  
> at org.jboss.netty.channel.SimpleChannelUpstreamHandler.handleUpstream(SimpleChannelUpstreamHandler.java:70)  
> at org.jboss.netty.channel.DefaultChannelPipeline.sendUpstream(DefaultChannelPipeline.java:564)  
> at org.jboss.netty.channel.DefaultChannelPipeline.sendUpstream(DefaultChannelPipeline.java:559)  
> at org.jboss.netty.channel.Channels.fireMessageReceived(Channels.java:268)  
> at org.jboss.netty.channel.Channels.fireMessageReceived(Channels.java:255)  
> at org.jboss.netty.channel.socket.nio.NioWorker.read(NioWorker.java:88)  
> at org.jboss.netty.channel.socket.nio.AbstractNioWorker.process(AbstractNioWorker.java:108)  
> at org.jboss.netty.channel.socket.nio.AbstractNioSelector.run(AbstractNioSelector.java:337)  
> at org.jboss.netty.channel.socket.nio.AbstractNioWorker.run(AbstractNioWorker.java:89)  
> at org.jboss.netty.channel.socket.nio.NioWorker.run(NioWorker.java:178)  
> at org.jboss.netty.util.ThreadRenamingRunnable.run(ThreadRenamingRunnable.java:108)  
> at org.jboss.netty.util.internal.DeadLockProofWorker$1.run(DeadLockProofWorker.java:42)  
> at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)  
> at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)  
> at java.lang.Thread.run(Thread.java:745)

Any help would be appreciated.

---

<div class="post-metadata">

**Author:** ![tanguy](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tanguy/32/6030_2.png) [@tanguy](https://discuss.elastic.co/u/tanguy)\
**Post date:** [December 2, 2015, 8:38am UTC](https://discuss.elastic.co/t/500-error-when-attempting-to-drill-into-marvel-cluster/36078/3 "2015-12-02T08:38:17Z")

</div>

Hi,

> [@Danny830x](#):
>
> with the latest versions of Marvel and Kibana.

Which versions exactly?

---

<div class="post-metadata">

**Author:** ![Danny830x](https://avatars.discourse-cdn.com/v4/letter/d/b4bc9f/32.png) [@Danny830x](https://discuss.elastic.co/u/Danny830x)\
**Post date:** [December 2, 2015, 2:32pm UTC](https://discuss.elastic.co/t/500-error-when-attempting-to-drill-into-marvel-cluster/36078/4 "2015-12-02T14:32:35Z")

</div>

Marvel 2.1.0  
Kibana 4.2.0

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [December 3, 2015, 5:05am UTC](https://discuss.elastic.co/t/500-error-when-attempting-to-drill-into-marvel-cluster/36078/5 "2015-12-03T05:05:16Z")

</div>

You need to use KB 4.3 with ES 2.1, see [https://www.elastic.co/support/matrix](https://www.elastic.co/support/matrix)

---

<div class="post-metadata">

**Author:** ![tanguy](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tanguy/32/6030_2.png) [@tanguy](https://discuss.elastic.co/u/tanguy)\
**Post date:** [December 3, 2015, 8:44am UTC](https://discuss.elastic.co/t/500-error-when-attempting-to-drill-into-marvel-cluster/36078/6 "2015-12-03T08:44:15Z")

</div>

You may have the same issue as described here [Problems with apache and marvel plugin](https://discuss.elastic.co/t/problems-with-apache-and-marvel-plugin/35623/8)

---

<div class="post-metadata">

**Author:** ![Danny830x](https://avatars.discourse-cdn.com/v4/letter/d/b4bc9f/32.png) [@Danny830x](https://discuss.elastic.co/u/Danny830x)\
**Post date:** [December 3, 2015, 9:10pm UTC](https://discuss.elastic.co/t/500-error-when-attempting-to-drill-into-marvel-cluster/36078/7 "2015-12-03T21:10:51Z")

</div>

I'm not using ES 2.1. I'm using ES 2.0

---

<div class="post-metadata">

**Author:** ![Danny830x](https://avatars.discourse-cdn.com/v4/letter/d/b4bc9f/32.png) [@Danny830x](https://discuss.elastic.co/u/Danny830x)\
**Post date:** [December 3, 2015, 9:11pm UTC](https://discuss.elastic.co/t/500-error-when-attempting-to-drill-into-marvel-cluster/36078/8 "2015-12-03T21:11:51Z")

</div>

Thanks. Looks like that's it. It seems like there was some success upgrading ES, Kibana and Marvel. I will try that. Thanks.

---

<div class="post-metadata">

**Author:** ![dfr0](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dfr0/32/6433_2.png) [@dfr0](https://discuss.elastic.co/u/dfr0)\
**Post date:** [December 4, 2015, 12:57am UTC](https://discuss.elastic.co/t/500-error-when-attempting-to-drill-into-marvel-cluster/36078/9 "2015-12-04T00:57:58Z")

</div>

Me too, i'm using the 2.0 version.

---

<div class="post-metadata">

**Author:** ![dfr0](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dfr0/32/6433_2.png) [@dfr0](https://discuss.elastic.co/u/dfr0)\
**Post date:** [March 23, 2016, 6:56am UTC](https://discuss.elastic.co/t/500-error-when-attempting-to-drill-into-marvel-cluster/36078/10 "2016-03-23T06:56:21Z")

</div>

i resolved this issue.

---

<div class="post-metadata">

**Author:** ![tanguy](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tanguy/32/6030_2.png) [@tanguy](https://discuss.elastic.co/u/tanguy)\
**Post date:** [March 23, 2016, 8:09am UTC](https://discuss.elastic.co/t/500-error-when-attempting-to-drill-into-marvel-cluster/36078/11 "2016-03-23T08:09:57Z")

</div>

> [@dfr0](#):
>
> i resolved this issue.

Happy to hear that:) By upgrading?

---

<div class="post-metadata">

**Author:** ![dfr0](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dfr0/32/6433_2.png) [@dfr0](https://discuss.elastic.co/u/dfr0)\
**Post date:** [March 24, 2016, 12:20am UTC](https://discuss.elastic.co/t/500-error-when-attempting-to-drill-into-marvel-cluster/36078/12 "2016-03-24T00:20:18Z")

</div>

I had a problem with the new app routes

I resolved time ago with the following apache configuration:

Timeout 3200  
ProxyTimeout 3200

ProxyRequests Off  
ProxyPreserveHost On

Redirect /\*\*\*\*\* /app/kibana

Redirect /\*\*\*\*\* /elasticsearch

ProxyPass /status http://\***_:5601/status  
ProxyPassReverse /status http://_**:5601/status

ProxyPass /api/status http://**_:5601/api/status  
ProxyPassReverse /api/status http://_**:5601/api/status

ProxyPass /app/kibana http://\*\*\*\*\*\*:5601/app/kibana  
ProxyPassReverse /app/kibana http://\*\*\*\*\*\*:5601/app/kibana

ProxyPass /app/marvel http://**_:5601/app/marvel  
ProxyPassReverse /app/marvel http://_**:5601/app/marvel

ProxyPass /api/marvel http://**_:5601/api/marvel  
ProxyPassReverse /api/marvel http://_**\*:5601/api/marvel

ProxyPass /bundles http://**_:5601/bundles  
ProxyPassReverse /bundles http://_**:5601/bundles

ProxyPass /elasticsearch http://**_:9200  
ProxyPassReverse /elasticsearch http://_**:9200

# Proxy options

\<Proxy http://\*\*\*\*\*\*:5601/\>  
Order Deny,Allow  
Deny from all  
Allow from \*\*\*\*  
AuthType Basic  
AuthName \*\*\*\*\*  
AuthUserFile \*\*\*\*  
Require valid-user

\<Proxy http://\*\*\*\*\*\*\*:9200/\>  
Order Deny,Allow  
Deny from all  
Allow from \*\*\*\*\*\*\*  
AuthType Basic  
AuthName \*\*\*\*\*\*\*\*  
AuthUserFile \*\*\*\*\*\*\*  
Require valid-user

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 6, 2017, 1:44pm UTC](https://discuss.elastic.co/t/500-error-when-attempting-to-drill-into-marvel-cluster/36078/13 "2017-07-06T13:44:48Z")

</div>


