# 500 - Internal Server : ErrorRepository\_verification\_exception, nested: RepositoryVerificationException\[\[backup\] a file written by master to the store \[C:\\\\Updates\\\\Backups\\\\ElasticSearch\] cannot be accessed on the node

**URL:** <https://discuss.elastic.co/t/500-internal-server-errorrepository-verification-exception-nested-repositoryverificationexception-backup-a-file-written-by-master-to-the-store-c-updates-backups-elasticsearch-cannot-be-accessed-on-the-node/311106>\
**Category:** Elasticsearch\
**Created:** [August 1, 2022, 10:54am UTC](https://discuss.elastic.co/t/500-internal-server-errorrepository-verification-exception-nested-repositoryverificationexception-backup-a-file-written-by-master-to-the-store-c-updates-backups-elasticsearch-cannot-be-accessed-on-the-node/311106 "2022-08-01T10:54:34Z")\
**Posts on this page:** 11\
**Page:** 1

<div class="post-metadata">

**Author:** ![mujtabah](https://avatars.discourse-cdn.com/v4/letter/m/ecd19e/32.png) [@mujtabah](https://discuss.elastic.co/u/mujtabah)\
**Post date:** [August 1, 2022, 10:54am UTC](https://discuss.elastic.co/t/500-internal-server-errorrepository-verification-exception-nested-repositoryverificationexception-backup-a-file-written-by-master-to-the-store-c-updates-backups-elasticsearch-cannot-be-accessed-on-the-node/311106/1 "2022-08-01T10:54:34Z")

</div>

I have a cluster of 5 nodes(3master,2 data), i have created directory in each node and included its path as path.repo in all of its yml's. then when i take snapshot its giving this error.  
command i used  
PUT \_snapshot/backup  
{  
"type": "fs",  
"settings": {  
"compress" : true,  
"location": "C:\Updates\Backups\ElasticSearch\"  
}  
}

{  
"error" : {  
"root\_cause" : [  
{  
"type" : "repository\_verification\_exception",  
"reason" : "[backup] [[s7sT\_BywRuqjQZVcRKgTRA, 'RemoteTransportException[[ICA-DB4][192.168.100.214:9300][internal:admin/repository/verify]]; nested: RepositoryVerificationException[[backup] a file written by master to the store [C:\Updates\Backups\ElasticSearch] cannot be accessed on the node [{ICA-DB4}{s7sT\_BywRuqjQZVcRKgTRA}{0\_FdA3OlSueQo2QVU81yiw}{192.168.100.214}{192.168.100.214:9300}{cdhilrstw}{ml.machine\_memory=8588910592, xpack.installed=true, transform.node=true, ml.max\_open\_jobs=20}]. This might indicate that the store [C:\Updates\Backups\ElasticSearch] is not shared between this node and the master node or that permissions on the store don't allow reading files written by the master node]; nested: NoSuchFileException[C:\Updates\Backups\ElasticSearch\tests-eYIkJTw1TH6ECKpoynbMZA\master.dat];'], [TBQKi5SeQZ2rkXCflDV0LQ, 'RemoteTransportException[[ICA-DB3][192.168.100.213:9300][internal:admin/repository/verify]]; nested: RepositoryVerificationException[[backup] a file written by master to the store [C:\Updates\Backups\ElasticSearch] cannot be accessed on the node [{ICA-DB3}{TBQKi5SeQZ2rkXCflDV0LQ}{B1J75sCyQq-eQUuahZNCNA}{192.168.100.213}{192.168.100.213:9300}{cdhilmrstw}{ml.machine\_memory=8588910592, xpack.installed=true, transform.node=true, ml.max\_open\_jobs=20}]. This might indicate that the store [C:\Updates\Backups\ElasticSearch] is not shared between this node and the master node or that permissions on the store don't allow reading files written by the master node]; nested: NoSuchFileException[C:\Updates\Backups\ElasticSearch\tests-eYIkJTw1TH6ECKpoynbMZA\master.dat];'], [2J1nm1GcRP6ofx3uYOorcA, 'RemoteTransportException[[ICA-DB5][192.168.100.215:9300][internal:admin/repository/verify]]; nested: RepositoryVerificationException[[backup] a file written by master to the store [C:\Updates\Backups\ElasticSearch] cannot be accessed on the node [{ICA-DB5}{2J1nm1GcRP6ofx3uYOorcA}{T6Sj6FUpQBCxSJGIMf4eow}{192.168.100.215}{192.168.100.215:9300}{cdhilrstw}{ml.machine\_memory=8588910592, xpack.installed=true, transform.node=true, ml.max\_open\_jobs=20}]. This might indicate that the store [C:\Updates\Backups\ElasticSearch] is not shared between this node and the master node or that permissions on the store don't allow reading files written by the master node]; nested: NoSuchFileException[C:\Updates\Backups\ElasticSearch\tests-eYIkJTw1TH6ECKpoynbMZA\master.dat];'], [KYo2-qPbSDCfs9S59sB5Eg, 'RemoteTransportException[[ICA-DB1][192.168.100.211:9300][internal:admin/repository/verify]]; nested: RepositoryVerificationException[[backup] a file written by master to the store [C:\Updates\Backups\ElasticSearch] cannot be accessed on the node [{ICA-DB1}{KYo2-qPbSDCfs9S59sB5Eg}{gRudinalT-GgFD107fSHhQ}{192.168.100.211}{192.168.100.211:9300}{cdhilmrstw}{ml.machine\_memory=8588910592, xpack.installed=true, transform.node=true, ml.max\_open\_jobs=20}]. This might indicate that the store [C:\Updates\Backups\ElasticSearch] is not shared between this node and the master node or that permissions on the store don't allow reading files written by the master node]; nested: NoSuchFileException[C:\Updates\Backups\ElasticSearch\tests-eYIkJTw1TH6ECKpoynbMZA\master.dat];']]"  
}  
],  
"type" : "repository\_verification\_exception",  
"reason" : "[backup] [[s7sT\_BywRuqjQZVcRKgTRA, 'RemoteTransportException[[ICA-DB4][192.168.100.214:9300][internal:admin/repository/verify]]; nested: RepositoryVerificationException[[backup] a file written by master to the store [C:\Updates\Backups\ElasticSearch] cannot be accessed on the node [{ICA-DB4}{s7sT\_BywRuqjQZVcRKgTRA}{0\_FdA3OlSueQo2QVU81yiw}{192.168.100.214}{192.168.100.214:9300}{cdhilrstw}{ml.machine\_memory=8588910592, xpack.installed=true, transform.node=true, ml.max\_open\_jobs=20}]. This might indicate that the store [C:\Updates\Backups\ElasticSearch] is not shared between this node and the master node or that permissions on the store don't allow reading files written by the master node]; nested: NoSuchFileException[C:\Updates\Backups\ElasticSearch\tests-eYIkJTw1TH6ECKpoynbMZA\master.dat];'], [TBQKi5SeQZ2rkXCflDV0LQ, 'RemoteTransportException[[ICA-DB3][192.168.100.213:9300][internal:admin/repository/verify]]; nested: RepositoryVerificationException[[backup] a file written by master to the store [C:\Updates\Backups\ElasticSearch] cannot be accessed on the node [{ICA-DB3}{TBQKi5SeQZ2rkXCflDV0LQ}{B1J75sCyQq-eQUuahZNCNA}{192.168.100.213}{192.168.100.213:9300}{cdhilmrstw}{ml.machine\_memory=8588910592, xpack.installed=true, transform.node=true, ml.max\_open\_jobs=20}]. This might indicate that the store [C:\Updates\Backups\ElasticSearch] is not shared between this node and the master node or that permissions on the store don't allow reading files written by the master node]; nested: NoSuchFileException[C:\Updates\Backups\ElasticSearch\tests-eYIkJTw1TH6ECKpoynbMZA\master.dat];'], [2J1nm1GcRP6ofx3uYOorcA, 'RemoteTransportException[[ICA-DB5][192.168.100.215:9300][internal:admin/repository/verify]]; nested: RepositoryVerificationException[[backup] a file written by master to the store [C:\Updates\Backups\ElasticSearch] cannot be accessed on the node [{ICA-DB5}{2J1nm1GcRP6ofx3uYOorcA}{T6Sj6FUpQBCxSJGIMf4eow}{192.168.100.215}{192.168.100.215:9300}{cdhilrstw}{ml.machine\_memory=8588910592, xpack.installed=true, transform.node=true, ml.max\_open\_jobs=20}]. This might indicate that the store [C:\Updates\Backups\ElasticSearch] is not shared between this node and the master node or that permissions on the store don't allow reading files written by the master node]; nested: NoSuchFileException[C:\Updates\Backups\ElasticSearch\tests-eYIkJTw1TH6ECKpoynbMZA\master.dat];'], [KYo2-qPbSDCfs9S59sB5Eg, 'RemoteTransportException[[ICA-DB1][192.168.100.211:9300][internal:admin/repository/verify]]; nested: RepositoryVerificationException[[backup] a file written by master to the store [C:\Updates\Backups\ElasticSearch] cannot be accessed on the node [{ICA-DB1}{KYo2-qPbSDCfs9S59sB5Eg}{gRudinalT-GgFD107fSHhQ}{192.168.100.211}{192.168.100.211:9300}{cdhilmrstw}{ml.machine\_memory=8588910592, xpack.installed=true, transform.node=true, ml.max\_open\_jobs=20}]. This might indicate that the store [C:\Updates\Backups\ElasticSearch] is not shared between this node and the master node or that permissions on the store don't allow reading files written by the master node]; nested: NoSuchFileException[C:\Updates\Backups\ElasticSearch\tests-eYIkJTw1TH6ECKpoynbMZA\master.dat];']]"  
},  
"status" : 500  
}

---

<div class="post-metadata">

**Author:** ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)\
**Post date:** [August 1, 2022, 12:07pm UTC](https://discuss.elastic.co/t/500-internal-server-errorrepository-verification-exception-nested-repositoryverificationexception-backup-a-file-written-by-master-to-the-store-c-updates-backups-elasticsearch-cannot-be-accessed-on-the-node/311106/2 "2022-08-01T12:07:02Z")

</div>

> [@mujtabah](#):
>
> This might indicate that the store [C:\Updates\Backups\Elasticsearch] is not shared between this node and the master node or that permissions on the store don't allow reading files written by the master node]

If you want to create a [shared filesystem snapshot](https://www.elastic.co/guide/en/elasticsearch/reference/8.2/snapshots-filesystem-repository.html) this requires a shared filesystem, e.g. NFS, mounted on the same path across all nodes in the cluster. You can not back up to individual directores on the nodes even if the path is the same.

---

<div class="post-metadata">

**Author:** ![mujtabah](https://avatars.discourse-cdn.com/v4/letter/m/ecd19e/32.png) [@mujtabah](https://discuss.elastic.co/u/mujtabah)\
**Post date:** [August 24, 2022, 5:29am UTC](https://discuss.elastic.co/t/500-internal-server-errorrepository-verification-exception-nested-repositoryverificationexception-backup-a-file-written-by-master-to-the-store-c-updates-backups-elasticsearch-cannot-be-accessed-on-the-node/311106/3 "2022-08-24T05:29:02Z")

</div>

But when i use shared file system, I am able to run Elasticsearch only by batch file using PowerShell. but when I run Elasticsearch as a service it gets stop suddenly.  
I am confused when we include path.repo in yml and give the path of directory present in shared file system and run Elasticsearch as service it gets stop. but when i run as powershell its working fine

---

<div class="post-metadata">

**Author:** ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)\
**Post date:** [August 24, 2022, 5:30am UTC](https://discuss.elastic.co/t/500-internal-server-errorrepository-verification-exception-nested-repositoryverificationexception-backup-a-file-written-by-master-to-the-store-c-updates-backups-elasticsearch-cannot-be-accessed-on-the-node/311106/4 "2022-08-24T05:30:34Z")

</div>

Why? You use the shared storage for the snapshot repository only, not the data path. I do not see how the type of storage used for the snapshot repository would affect how you start or run Elasticsearch. If it fails to start, please show the logs.

---

<div class="post-metadata">

**Author:** ![mujtabah](https://avatars.discourse-cdn.com/v4/letter/m/ecd19e/32.png) [@mujtabah](https://discuss.elastic.co/u/mujtabah)\
**Post date:** [August 24, 2022, 5:33am UTC](https://discuss.elastic.co/t/500-internal-server-errorrepository-verification-exception-nested-repositoryverificationexception-backup-a-file-written-by-master-to-the-store-c-updates-backups-elasticsearch-cannot-be-accessed-on-the-node/311106/5 "2022-08-24T05:33:55Z")

</div>

yes , I am using share folder only for repository and the data is stored on same local node

---

<div class="post-metadata">

**Author:** ![mujtabah](https://avatars.discourse-cdn.com/v4/letter/m/ecd19e/32.png) [@mujtabah](https://discuss.elastic.co/u/mujtabah)\
**Post date:** [August 24, 2022, 5:34am UTC](https://discuss.elastic.co/t/500-internal-server-errorrepository-verification-exception-nested-repositoryverificationexception-backup-a-file-written-by-master-to-the-store-c-updates-backups-elasticsearch-cannot-be-accessed-on-the-node/311106/6 "2022-08-24T05:34:32Z")

</div>

Thanks for your quick response

---

<div class="post-metadata">

**Author:** ![mujtabah](https://avatars.discourse-cdn.com/v4/letter/m/ecd19e/32.png) [@mujtabah](https://discuss.elastic.co/u/mujtabah)\
**Post date:** [August 24, 2022, 5:37am UTC](https://discuss.elastic.co/t/500-internal-server-errorrepository-verification-exception-nested-repositoryverificationexception-backup-a-file-written-by-master-to-the-store-c-updates-backups-elasticsearch-cannot-be-accessed-on-the-node/311106/7 "2022-08-24T05:37:54Z")

</div>

```auto
this are the logs and i run elastic search as a windows service
[2022-08-12T15:09:22,644][INFO][o.e.n.Node] [A2_MMJ] closed
[2022-08-12T15:09:27,507][ERROR][o.e.b.Bootstrap] [A2_MMJ] Exception
java.lang.IllegalStateException: Unable to access 'path.repo' (X:\Backup)
at org.elasticsearch.bootstrap.FilePermissionUtils.addDirectoryPath(FilePermissionUtils.java:66) ~[elasticsearch-7.16.2.jar:7.16.2]
at org.elasticsearch.bootstrap.Security.addFilePermissions(Security.java:242) ~[elasticsearch-7.16.2.jar:7.16.2]
at org.elasticsearch.bootstrap.Security.createPermissions(Security.java:168) ~[elasticsearch-7.16.2.jar:7.16.2]
at org.elasticsearch.bootstrap.Security.configure(Security.java:115) ~[elasticsearch-7.16.2.jar:7.16.2]
at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:229) ~[elasticsearch-7.16.2.jar:7.16.2]
at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:434) [elasticsearch-7.16.2.jar:7.16.2]
at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:166) [elasticsearch-7.16.2.jar:7.16.2]
at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:157) [elasticsearch-7.16.2.jar:7.16.2]
at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:77) [elasticsearch-7.16.2.jar:7.16.2]
at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:112) [elasticsearch-cli-7.16.2.jar:7.16.2]
at org.elasticsearch.cli.Command.main(Command.java:77) [elasticsearch-cli-7.16.2.jar:7.16.2]
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:122) [elasticsearch-7.16.2.jar:7.16.2]
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:80) [elasticsearch-7.16.2.jar:7.16.2]
Caused by: java.nio.file.FileSystemException: X:\Backup: Unable to determine if root directory exists
at java.nio.file.Files.createDirectories(Files.java:782) ~[?:?]
at org.elasticsearch.bootstrap.Security.ensureDirectoryExists(Security.java:318) ~[elasticsearch-7.16.2.jar:7.16.2]
at org.elasticsearch.bootstrap.FilePermissionUtils.addDirectoryPath(FilePermissionUtils.java:64) ~[elasticsearch-7.16.2.jar:7.16.2]
... 12 more
[2022-08-12T15:09:27,523][WARN][stderr] [A2_MMJ] java.lang.IllegalStateException: Unable to access 'path.repo' (X:\Backup)
[2022-08-12T15:09:27,523][WARN][stderr] [A2_MMJ] Likely root cause: java.nio.file.FileSystemException: X:\Backup: Unable to determine if root directory exists
[2022-08-12T15:09:27,523][WARN][stderr] [A2_MMJ] at java.base/java.nio.file.Files.createDirectories(Files.java:782)
[2022-08-12T15:09:27,523][WARN][stderr] [A2_MMJ] at org.elasticsearch.bootstrap.Security.ensureDirectoryExists(Security.java:318)
[2022-08-12T15:09:27,523][WARN][stderr] [A2_MMJ] at org.elasticsearch.bootstrap.FilePermissionUtils.addDirectoryPath(FilePermissionUtils.java:64)
[2022-08-12T15:09:27,523][WARN][stderr] [A2_MMJ] at org.elasticsearch.bootstrap.Security.addFilePermissions(Security.java:242)
[2022-08-12T15:09:27,523][WARN][stderr] [A2_MMJ] at org.elasticsearch.bootstrap.Security.createPermissions(Security.java:168)
[2022-08-12T15:09:27,523][WARN][stderr] [A2_MMJ] at org.elasticsearch.bootstrap.Security.configure(Security.java:115)
[2022-08-12T15:09:27,523][WARN][stderr] [A2_MMJ] at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:229)
[2022-08-12T15:09:27,523][WARN][stderr] [A2_MMJ] at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:434)
[2022-08-12T15:09:27,523][WARN][stderr] [A2_MMJ] at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:166)
[2022-08-12T15:09:27,523][WARN][stderr] [A2_MMJ] at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:157)
[2022-08-12T15:09:27,523][WARN][stderr] [A2_MMJ] at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:77)
[2022-08-12T15:09:27,523][WARN][stderr] [A2_MMJ] at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:112)
[2022-08-12T15:09:27,523][WARN][stderr] [A2_MMJ] at org.elasticsearch.cli.Command.main(Command.java:77)
[2022-08-12T15:09:27,523][WARN][stderr] [A2_MMJ] at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:122)
[2022-08-12T15:09:27,523][WARN][stderr] [A2_MMJ] at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:80)
[2022-08-12T15:09:27,523][WARN][stderr] [A2_MMJ] For complete error details, refer to the log at C:\Elastic\Elasticsearch\logs\elasticsearch.log

```

---

<div class="post-metadata">

**Author:** ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)\
**Post date:** [August 24, 2022, 5:49am UTC](https://discuss.elastic.co/t/500-internal-server-errorrepository-verification-exception-nested-repositoryverificationexception-backup-a-file-written-by-master-to-the-store-c-updates-backups-elasticsearch-cannot-be-accessed-on-the-node/311106/8 "2022-08-24T05:49:31Z")

</div>

Seems to be a permissions issue on the backup storage.

---

<div class="post-metadata">

**Author:** ![mujtabah](https://avatars.discourse-cdn.com/v4/letter/m/ecd19e/32.png) [@mujtabah](https://discuss.elastic.co/u/mujtabah)\
**Post date:** [August 24, 2022, 5:56am UTC](https://discuss.elastic.co/t/500-internal-server-errorrepository-verification-exception-nested-repositoryverificationexception-backup-a-file-written-by-master-to-the-store-c-updates-backups-elasticsearch-cannot-be-accessed-on-the-node/311106/9 "2022-08-24T05:56:30Z")

</div>

But the thing is, when I run it as elasticsearh.bat file its working fine. This error happens when i run Elasticsearch as a widows service.  
Can you please also suggest how can i take the restore on a new Elasticsearch node from a snapshot that was stored on the shared folder.

---

<div class="post-metadata">

**Author:** ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)\
**Post date:** [August 24, 2022, 6:07am UTC](https://discuss.elastic.co/t/500-internal-server-errorrepository-verification-exception-nested-repositoryverificationexception-backup-a-file-written-by-master-to-the-store-c-updates-backups-elasticsearch-cannot-be-accessed-on-the-node/311106/10 "2022-08-24T06:07:40Z")

</div>

Does it run as different users depending on how you start it? I do not run Elasticsearch on Windows, so will unfortunately not be able to help with this issue.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [September 21, 2022, 6:08am UTC](https://discuss.elastic.co/t/500-internal-server-errorrepository-verification-exception-nested-repositoryverificationexception-backup-a-file-written-by-master-to-the-store-c-updates-backups-elasticsearch-cannot-be-accessed-on-the-node/311106/11 "2022-09-21T06:08:11Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
