# 503 Error encountered during the upgrade of Logstash from version 8.10.4 to 8.12.1

**URL:** https://discuss.elastic.co/t/503-error-encountered-during-the-upgrade-of-logstash-from-version-8-10-4-to-8-12-1/353442
**Category:** Logstash
**Created:** [February 16, 2024, 8:45am UTC](https://discuss.elastic.co/t/503-error-encountered-during-the-upgrade-of-logstash-from-version-8-10-4-to-8-12-1/353442 "2024-02-16T08:45:39Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![Ramya\_Sababathi](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ramya_sababathi/32/131708_2.png) [@Ramya\_Sababathi](https://discuss.elastic.co/u/Ramya_Sababathi)
#### Post date: [February 16, 2024, 8:45am UTC](https://discuss.elastic.co/t/503-error-encountered-during-the-upgrade-of-logstash-from-version-8-10-4-to-8-12-1/353442/1 "2024-02-16T08:45:40Z")

</div>

Hi,

I recently performed the first upgrade of Logstash from version 8.10.4 to 8.12.1 and encountered an error during the process. It's important to note that this error only occurs during the initial upgrade and not during the installation process.

```auto
"log":{"message":"Failed to install template {:message=>"Got response code '503' contacting OpenSearch at URL 'https://opensearch:9200/_template/logstash'", :exception=>LogStash::Outputs::OpenSearch::HttpClient::Pool::BadResponseCodeError, :backtrace=>["/usr/share/logstash/vendor/bundle/jruby/3.1.0/gems/logstash-output-opensearch-2.0.2-java/lib/logstash/outputs/opensearch/http_client/manticore_adapter.rb:181:in `perform_request'", "/usr/share/logstash/vendor/bundle/jruby/3.1.0/gems/logstash-output-opensearch-2.0.2-java/lib/logstash/outputs/opensearch/http_client/pool.rb:272:in `perform_request_to_url'", "/usr/share/logstash/vendor/bundle/jruby/3.1.0/gems/logstash-output-opensearch-2.0.2-java/lib/logstash/outputs/opensearch/http_client/pool.rb:259:in `block in perform_request'", "/usr/share/logstash/vendor/bundle/jruby/3.1.0/gems/logstash-output-opensearch-2.0.2-java/lib/logstash/outputs/opensearch/http_client/pool.rb:348:in `with_connection'", "/usr/share/logstash/vendor/bundle/jruby/3.1.0/gems/logstash-output-opensearch-2.0.2-java/lib/logstash/outputs/opensearch/http_client/pool.rb:258:in `perform_request'", "/usr/share/logstash/vendor/bundle/jruby/3.1.0/gems/logstash-output-opensearch-2.0.2-java/lib/logstash/outputs/opensearch/http_client/pool.rb:266:in `block in Pool'", "/usr/share/logstash/vendor/bundle/jruby/3.1.0/gems/logstash-output-opensearch-2.0.2-java/lib/logstash/outputs/opensearch/http_client.rb:393:in `exists?'", "/usr/share/logstash/vendor/bundle/jruby/3.1.0/gems/logstash-output-opensearch-2.0.2-java/lib/logstash/outputs/opensearch/http_client.rb:398:in `template_exists?'", "/usr/share/logstash/vendor/bundle/jruby/3.1.0/gems/logstash-output-opensearch-2.0.2-java/lib/logstash/outputs/opensearch/http_client.rb:78:in `template_install'", "/usr/share/logstash/vendor/bundle/jruby/3.1.0/gems/logstash-output-opensearch-2.0.2-java/lib/logstash/outputs/opensearch/template_manager.rb:37:in `install'", "/usr/share/logstash/vendor/bundle/jruby/3.1.0/gems/logstash-output-opensearch-2.0.2-java/lib/logstash/outputs/opensearch/template_manager.rb:25:in `install_template'", "/usr/share/logstash/vendor/bundle/jruby/3.1.0/gems/logstash-output-opensearch-2.0.2-java/lib/logstash/outputs/opensearch.rb:419:in `install_template'", "/usr/share/logstash/vendor/bundle/jruby/3.1.0/gems/logstash-output-opensearch-2.0.2-java/lib/logstash/outputs/opensearch.rb:254:in `finish_register'", "/usr/share/logstash/vendor/bundle/jruby/3.1.0/gems/logstash-output-opensearch-2.0.2-java/lib/logstash/outputs/opensearch.rb:231:in `block in register'", "/usr/share/logstash/vendor/bundle/jruby/3.1.0/gems/logstash-output-opensearch-2.0.2-java/lib/logstash/plugin_mixins/opensearch/common.rb:83:in `block in after_successful_connection'"]}"}}

```

**Versions:**

- Logstash: 8.12.1
- OpenSearch: 2.11.0

This error doesn't come up on installation or further upgrades.

```auto
{"cluster_name":"test","status":"yellow","timed_out":false,"number_of_nodes":3,"number_of_data_nodes":1,"discovered_master":true,"discovered_cluster_manager":true,"active_primary_shards":3,"active_shards":3,"relocating_shards":0,"initializing_shards":0,"unassigned_shards":1,"delayed_unassigned_shards":0,"number_of_pending_tasks":0,"number_of_in_flight_fetch":0,"task_max_waiting_in_queue_millis":0,"active_shards_percent_as_number":75.0}

```

```auto
curl -k -u<user>:<password> "http://localhost:9200/_cluster/health"
{
  "name" : "test",
  "cluster_name" : "test",
  "version" : {
    "number" : "7.10.2",
    "build_type" : "rpm",
    "build_snapshot" : false,
    "lucene_version" : "9.7.0",
    "minimum_wire_compatibility_version" : "7.10.0",
    "minimum_index_compatibility_version" : "7.0.0"
  },
  "tagline" : "The OpenSearch Project: https://opensearch.org/"
}

```

Query:

- Has anyone else experienced a similar issue during their first upgrade from Logstash 8.10.4 to 8.12.1?
- Are there any specific steps or configurations recommended for handling the first upgrade process?
- Could there be a compatibility issue between Logstash 8.12.1 and OpenSearch 2.11.0 that manifests uniquely during the initial upgrade?

Any guidance or insights on resolving this issue would be greatly appreciated.

Thank you!

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [February 16, 2024, 8:45am UTC](https://discuss.elastic.co/t/503-error-encountered-during-the-upgrade-of-logstash-from-version-8-10-4-to-8-12-1/353442/2 "2024-02-16T08:45:40Z")

</div>

OpenSearch/OpenDistro are AWS run products and differ from the original Elasticsearch and Kibana products that Elastic builds and maintains. You may need to contact them directly for further assistance.

(This is an automated response from your friendly Elastic bot. Please report this post if you have any suggestions or concerns :elasticheart: )

---

<div class="post-metadata">

### Author: ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)
#### Post date: [February 16, 2024, 10:15am UTC](https://discuss.elastic.co/t/503-error-encountered-during-the-upgrade-of-logstash-from-version-8-10-4-to-8-12-1/353442/3 "2024-02-16T10:15:57Z")

</div>

I think you need to ask the authors of this output plugin as we are not developing it.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [March 15, 2024, 10:16am UTC](https://discuss.elastic.co/t/503-error-encountered-during-the-upgrade-of-logstash-from-version-8-10-4-to-8-12-1/353442/4 "2024-03-15T10:16:54Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
