# 6.2.2 after X-pack timeout errors at start

**URL:** <https://discuss.elastic.co/t/6-2-2-after-x-pack-timeout-errors-at-start/126694>\
**Category:** Kibana\
**Created:** [April 4, 2018, 8:22am UTC](https://discuss.elastic.co/t/6-2-2-after-x-pack-timeout-errors-at-start/126694 "2018-04-04T08:22:36Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![Ongun](https://avatars.discourse-cdn.com/v4/letter/o/b19c9b/32.png) [@Ongun](https://discuss.elastic.co/u/Ongun)\
**Post date:** [April 4, 2018, 8:22am UTC](https://discuss.elastic.co/t/6-2-2-after-x-pack-timeout-errors-at-start/126694/1 "2018-04-04T08:22:36Z")

</div>

Hello,

I am a new ELK stack user and I just installed `X-pack` on Elasticsearch and Kibana. After installation during Kibana startup (at the same time with Elasticsearch or independent of it) I always get timeout errors, you can see the command prompt standard output below. How can I get rid of them and what might me the reason?

I can actually access the web interface, but this really bugs me.

```
  log [08:10:44.497] [info][status][plugin:kibana@6.2.2] Status changed from uninitialized to green - Ready
  log [08:10:44.685] [info][status][plugin:elasticsearch@6.2.2] Status changed from uninitialized to yellow - Waiting for Elasticsearch
  log [08:10:44.700] [info][status][plugin:xpack_main@6.2.2] Status changed from uninitialized to yellow - Waiting for Elasticsearch
  log [08:10:44.716] [info][status][plugin:searchprofiler@6.2.2] Status changed from uninitialized to yellow - Waiting for Elasticsearch
  log [08:10:44.732] [info][status][plugin:ml@6.2.2] Status changed from uninitialized to yellow - Waiting for Elasticsearch
  log [08:10:44.841] [info][status][plugin:tilemap@6.2.2] Status changed from uninitialized to yellow - Waiting for Elasticsearch
  log [08:10:44.841] [info][status][plugin:watcher@6.2.2] Status changed from uninitialized to yellow - Waiting for Elasticsearch
  log [08:10:44.903] [info][status][plugin:license_management@6.2.2] Status changed from uninitialized to green - Ready
  log [08:10:47.583] [info][status][plugin:timelion@6.2.2] Status changed from uninitialized to green - Ready
  log [08:10:47.583] [info][status][plugin:graph@6.2.2] Status changed from uninitialized to yellow - Waiting for Elasticsearch
  log [08:10:47.599] [info][status][plugin:monitoring@6.2.2] Status changed from uninitialized to green - Ready
  log [08:11:29.539] [warning][reporting] Generating a random key for xpack.reporting.encryptionKey. To prevent pending reports from failing on restart, please set xpack.reporting.encryptionKey in kibana.yml
  log [08:11:29.554] [info][status][plugin:reporting@6.2.2] Status changed from uninitialized to yellow - Waiting for Elasticsearch
  log [08:11:29.711] [info][status][plugin:security@6.2.2] Status changed from uninitialized to yellow - Waiting for Elasticsearch
  log [08:11:29.711] [warning][security] Generating a random key for xpack.security.encryptionKey. To prevent sessions from being invalidated on restart, please set xpack.security.encryptionKey in kibana.yml
  log [08:11:29.726] [warning][security] Session cookies will be transmitted over insecure connections. This is not recommended.
  log [08:11:29.851] [info][status][plugin:grokdebugger@6.2.2] Status changed from uninitialized to green - Ready
  log [08:11:29.914] [info][status][plugin:dashboard_mode@6.2.2] Status changed from uninitialized to green - Ready
  log [08:11:29.929] [info][status][plugin:logstash@6.2.2] Status changed from uninitialized to yellow - Waiting for Elasticsearch
  log [08:11:30.017] [info][status][plugin:apm@6.2.2] Status changed from uninitialized to green - Ready
  log [08:11:30.047] [info][status][plugin:console@6.2.2] Status changed from uninitialized to green - Ready
  log [08:11:30.063] [info][status][plugin:metrics@6.2.2] Status changed from uninitialized to green - Ready
  log [08:11:30.125] [error][status][plugin:xpack_main@6.2.2] Status changed from yellow to red - Request Timeout after 3000ms
  log [08:11:30.125] [error][status][plugin:searchprofiler@6.2.2] Status changed from yellow to red - Request Timeout after 3000ms
  log [08:11:30.141] [error][status][plugin:ml@6.2.2] Status changed from yellow to red - Request Timeout after 3000ms
  log [08:11:30.141] [error][status][plugin:tilemap@6.2.2] Status changed from yellow to red - Request Timeout after 3000ms
  log [08:11:30.141] [error][status][plugin:watcher@6.2.2] Status changed from yellow to red - Request Timeout after 3000ms
  log [08:11:30.156] [error][status][plugin:graph@6.2.2] Status changed from yellow to red - Request Timeout after 3000ms
  log [08:11:30.156] [error][status][plugin:reporting@6.2.2] Status changed from yellow to red - Request Timeout after 3000ms
  log [08:11:30.156] [error][status][plugin:security@6.2.2] Status changed from yellow to red - Request Timeout after 3000ms
  log [08:11:30.156] [error][status][plugin:logstash@6.2.2] Status changed from yellow to red - Request Timeout after 3000ms
  log [08:11:30.172] [error][status][plugin:elasticsearch@6.2.2] Status changed from yellow to red - Request Timeout after 3000ms
  log [08:11:30.172] [info][listening] Server running at http://localhost:5601
  log [08:11:30.235] [info][license][xpack] Imported license information from Elasticsearch for the [data] cluster: mode: trial | status: active | expiry date: 2018-05-02T14:17:21+03:00
  log [08:11:30.266] [info][status][plugin:xpack_main@6.2.2] Status changed from red to green - Ready
  log [08:11:30.281] [info][status][plugin:searchprofiler@6.2.2] Status changed from red to green - Ready
  log [08:11:30.281] [info][status][plugin:ml@6.2.2] Status changed from red to green - Ready
  log [08:11:30.281] [info][status][plugin:tilemap@6.2.2] Status changed from red to green - Ready
  log [08:11:30.297] [info][status][plugin:watcher@6.2.2] Status changed from red to green - Ready
  log [08:11:30.297] [info][status][plugin:graph@6.2.2] Status changed from red to green - Ready
  log [08:11:30.297] [info][status][plugin:reporting@6.2.2] Status changed from red to green - Ready
  log [08:11:30.297] [info][status][plugin:security@6.2.2] Status changed from red to green - Ready
  log [08:11:30.313] [info][status][plugin:logstash@6.2.2] Status changed from red to green - Ready
  log [08:11:30.375] [info][kibana-monitoring][monitoring-ui] Stopping all Kibana monitoring collectors
  log [08:11:30.406] [info][license][xpack] Imported license information from Elasticsearch for the [monitoring] cluster: mode: trial | status: active | expiry date: 2018-05-02T14:17:21+03:00
  log [08:11:46.492] [info][kibana-monitoring][monitoring-ui] Starting all Kibana monitoring collectors
  log [08:11:46.507] [info][status][plugin:elasticsearch@6.2.2] Status changed from red to green - Ready
```

---

<div class="post-metadata">

**Author:** ![rashmi](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/rashmi/32/16391_2.png) [@rashmi](https://discuss.elastic.co/u/rashmi)\
**Post date:** [April 4, 2018, 4:34pm UTC](https://discuss.elastic.co/t/6-2-2-after-x-pack-timeout-errors-at-start/126694/2 "2018-04-04T16:34:51Z")

</div>

We ping every 2.5 seconds, so it's going to keep showing up. Your best bet would be to turn logging off. More info: [https://github.com/elastic/kibana/issues/2855](https://github.com/elastic/kibana/issues/2855)

Cheers  
Rashmi

---

<div class="post-metadata">

**Author:** ![Ongun](https://avatars.discourse-cdn.com/v4/letter/o/b19c9b/32.png) [@Ongun](https://discuss.elastic.co/u/Ongun)\
**Post date:** [April 4, 2018, 9:29pm UTC](https://discuss.elastic.co/t/6-2-2-after-x-pack-timeout-errors-at-start/126694/3 "2018-04-04T21:29:36Z")

</div>

Thanks for the answer, by the way the time-out occurs in 3000 ms (3 s) is this adjustable? Is the ping interval adjustable? I do not want to turn logging off entirely (even the error messages will be disabled). Kibana did not use to give these errors, they began to occur only after installation of X-pack. May it have something to do?

---

<div class="post-metadata">

**Author:** ![rashmi](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/rashmi/32/16391_2.png) [@rashmi](https://discuss.elastic.co/u/rashmi)\
**Post date:** [April 9, 2018, 6:58pm UTC](https://discuss.elastic.co/t/6-2-2-after-x-pack-timeout-errors-at-start/126694/4 "2018-04-09T18:58:39Z")

</div>

I think there is an open issue on this : Linking it here:

> <https://github.com/elastic/elasticsearch-js/issues/547>

I would suggest you to subscribe to the issue and get more updates on it .

cc / @jbudz

Cheers  
Rashmi

---

<div class="post-metadata">

**Author:** ![Ongun](https://avatars.discourse-cdn.com/v4/letter/o/b19c9b/32.png) [@Ongun](https://discuss.elastic.co/u/Ongun)\
**Post date:** [April 9, 2018, 8:33pm UTC](https://discuss.elastic.co/t/6-2-2-after-x-pack-timeout-errors-at-start/126694/5 "2018-04-09T20:33:12Z")

</div>

Yes it is kind of hard-coded. So far I have tried adding `xpack.security.enabled: false` into Logstash configuration file and increasing the JVM heap values to 4 GB each - they were 2 GB before.  
`

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [May 7, 2018, 8:33pm UTC](https://discuss.elastic.co/t/6-2-2-after-x-pack-timeout-errors-at-start/126694/6 "2018-05-07T20:33:40Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
