# 6.7.1: JRuby temp directory problem?

**URL:** <https://discuss.elastic.co/t/6-7-1-jruby-temp-directory-problem/176348>\
**Category:** Logstash\
**Created:** [April 11, 2019, 8:08am UTC](https://discuss.elastic.co/t/6-7-1-jruby-temp-directory-problem/176348 "2019-04-11T08:08:29Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![Bergante](https://avatars.discourse-cdn.com/v4/letter/b/8797f3/32.png) [@Bergante](https://discuss.elastic.co/u/Bergante)\
**Post date:** [April 11, 2019, 8:08am UTC](https://discuss.elastic.co/t/6-7-1-jruby-temp-directory-problem/176348/1 "2019-04-11T08:08:29Z")

</div>

Hi,

I was running 6.6.1 on FreeBSD without problems. When updating to 6.7.1 I was unable to start logstash as the logstash user (I never start it as root). I tried as root out of curiosity and it worked.

The complaint was the failure to find a temporary directory. Suspecting some Java temporary directory issue I added this to jvm.options

# set the I/O temp directory

-Djava.io.tmpdir=/var/db/logstash/temp

But it still didn't work.

Investigating the issue with ktrace I found that during startup it tried to access a directory called /nonexistent. Creating it and changing owner to logstash (the unprivileged user I use for it) it begun working.

Any clues of what could be causing this behavior? I looked over the documentation searching for some new setting and I didn't find anything.

Looks like a JRuby bug?

Thanks!

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [May 9, 2019, 8:08am UTC](https://discuss.elastic.co/t/6-7-1-jruby-temp-directory-problem/176348/2 "2019-05-09T08:08:41Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
