# \[7.0 Error\] CANNOT start after changing IP in 7.0 (code=exited, status=78)

**URL:** <https://discuss.elastic.co/t/7-0-error-cannot-start-after-changing-ip-in-7-0-code-exited-status-78/178455>\
**Category:** Elasticsearch\
**Created:** [April 25, 2019, 12:30pm UTC](https://discuss.elastic.co/t/7-0-error-cannot-start-after-changing-ip-in-7-0-code-exited-status-78/178455 "2019-04-25T12:30:39Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![cosloli](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/cosloli/32/51115_2.png) [@cosloli](https://discuss.elastic.co/u/cosloli)\
**Post date:** [April 25, 2019, 12:30pm UTC](https://discuss.elastic.co/t/7-0-error-cannot-start-after-changing-ip-in-7-0-code-exited-status-78/178455/1 "2019-04-25T12:30:39Z")

</div>

At first I used the default setting, and everything works fine.

But when I change the host IP in `elasticsearch.yml`, it just can't launch:

 ![360%E6%88%AA%E5%9B%BE20190425202611833](https://us1.discourse-cdn.com/elastic/original/3X/6/2/62cf25bba9af7583b65e358d2f28b90f8888474d.jpeg)  
The config I changed:  
 ![360%E6%88%AA%E5%9B%BE20190425202214890](https://us1.discourse-cdn.com/elastic/original/3X/8/a/8a20c4c0661f3151ec7ea128d43ba22cbb403211.jpeg)

I can launch ES succesfully in 1.7.3 version with changed IP, so I don't think it's a firewall problem. Does anyone know why?

Here's the log:

```
307 [2019-04-25T20:11:46,642][INFO][o.e.p.PluginsService] [bigiron] no plugins loaded
308 [2019-04-25T20:11:55,179][INFO][o.e.x.s.a.s.FileRolesStore] [bigiron] parsed [0] roles from file [/etc/elasticsearch/roles.yml]
309 [2019-04-25T20:11:56,477][INFO][o.e.x.m.p.l.CppLogMessageHandler] [bigiron] [controller/1796] [Main.cc@109] controller (64 bit): Version 7.0.0 (Build cdaa022645f38d) Copyright (c) 2019 Elasticsearch BV
310 [2019-04-25T20:11:57,240][DEBUG][o.e.a.ActionModule] [bigiron] Using REST wrapper from plugin org.elasticsearch.xpack.security.Security
311 [2019-04-25T20:11:57,750][INFO][o.e.d.DiscoveryModule] [bigiron] using discovery type [zen] and seed hosts providers [settings]
312 [2019-04-25T20:11:59,260][INFO][o.e.n.Node] [bigiron] initialized
313 [2019-04-25T20:11:59,261][INFO][o.e.n.Node] [bigiron] starting ...
314 [2019-04-25T20:11:59,497][INFO][o.e.t.TransportService] [bigiron] publish_address {172.17.211.51:9300}, bound_addresses {172.17.211.51:9300}
315 [2019-04-25T20:11:59,512][INFO][o.e.b.BootstrapChecks] [bigiron] bound or publishing to a non-loopback address, enforcing bootstrap checks
316 [2019-04-25T20:11:59,555][ERROR][o.e.b.Bootstrap] [bigiron] node validation exception
317 [1] bootstrap checks failed
318 [1]: the default discovery settings are unsuitable for production use; at least one of [discovery.seed_hosts, discovery.seed_providers, cluster.initial_master_nodes] must be configured
319 [2019-04-25T20:11:59,573][INFO][o.e.n.Node] [bigiron] stopping ...
320 [2019-04-25T20:11:59,599][INFO][o.e.n.Node] [bigiron] stopped
321 [2019-04-25T20:11:59,599][INFO][o.e.n.Node] [bigiron] closing ...
322 [2019-04-25T20:11:59,622][INFO][o.e.n.Node] [bigiron] closed
323 [2019-04-25T20:11:59,623][INFO][o.e.x.m.p.NativeController] [bigiron] Native controller process has stopped - no new native processes can be started
```

---

<div class="post-metadata">

**Author:** ![DavidTurner](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/davidturner/32/22453_2.png) [@DavidTurner](https://discuss.elastic.co/u/DavidTurner)\
**Post date:** [April 25, 2019, 1:07pm UTC](https://discuss.elastic.co/t/7-0-error-cannot-start-after-changing-ip-in-7-0-code-exited-status-78/178455/2 "2019-04-25T13:07:04Z")

</div>

You are not binding to localhost so you are subject to bootstrap checks:

> [@cosloli](#):
>
> `bound or publishing to a non-loopback address, enforcing bootstrap checks`

However one of the bootstrap checks is failing:

> [@cosloli](#):
>
> `the default discovery settings are unsuitable for production use; at least one of [discovery.seed_hosts, discovery.seed_providers, cluster.initial_master_nodes] must be configured`

To resolve this, configure at least one of the settings given, or disable the bootstrap checks by setting `discovery.type: single-node`.

---

<div class="post-metadata">

**Author:** ![cosloli](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/cosloli/32/51115_2.png) [@cosloli](https://discuss.elastic.co/u/cosloli)\
**Post date:** [April 25, 2019, 2:14pm UTC](https://discuss.elastic.co/t/7-0-error-cannot-start-after-changing-ip-in-7-0-code-exited-status-78/178455/3 "2019-04-25T14:14:52Z")

</div>

thanks a lot! I'll try it now.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [May 23, 2019, 2:17pm UTC](https://discuss.elastic.co/t/7-0-error-cannot-start-after-changing-ip-in-7-0-code-exited-status-78/178455/4 "2019-05-23T14:17:34Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
