# \[7.5\] There was an error retrieving the index pattern

**URL:** https://discuss.elastic.co/t/7-5-there-was-an-error-retrieving-the-index-pattern/210742
**Category:** Synthetics
**Created:** [December 5, 2019, 4:24pm UTC](https://discuss.elastic.co/t/7-5-there-was-an-error-retrieving-the-index-pattern/210742 "2019-12-05T16:24:17Z")
**Posts on this page:** 12
**Page:** 1

<div class="post-metadata">

### Author: ![robrotheram](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/robrotheram/32/27262_2.png) [@robrotheram](https://discuss.elastic.co/u/robrotheram)
#### Post date: [December 5, 2019, 4:24pm UTC](https://discuss.elastic.co/t/7-5-there-was-an-error-retrieving-the-index-pattern/210742/1 "2019-12-05T16:24:17Z")

</div>

I just updated to 7.4.0 -\> 7.5.0 and in uptime I now see below the query bar the warning

> There was an error retrieving the index pattern

But I can see all 100+ monitors and can filter on location. But the query bar is grey out and is disabled.  
I have made sure that the 2 heartbeats are updated to 7.5 and rerun the setup just to make sure.  
I also tried to delete all kibana indexes and restart kibana no such luck

Of note is that this is running in a air gaped environment and so I disabled newsfeed and telemetry

---

<div class="post-metadata">

### Author: ![Andrew\_Cholakian1](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/andrew_cholakian1/32/3612_2.png) [@Andrew\_Cholakian1](https://discuss.elastic.co/u/Andrew_Cholakian1)
#### Post date: [December 10, 2019, 3:05am UTC](https://discuss.elastic.co/t/7-5-there-was-an-error-retrieving-the-index-pattern/210742/2 "2019-12-10T03:05:11Z")

</div>

Is this error persisting? This is certainly an odd error that we haven't seen before. The air gapped nature of your environment shouldn't be causing issues here, so I'm a bit surprised.

Can you open the browser debug and add any detail that may be present in the browser console if possible? If possible a peek into the network debugger in your browser may also yield some interesting error messages.

---

<div class="post-metadata">

### Author: ![robrotheram](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/robrotheram/32/27262_2.png) [@robrotheram](https://discuss.elastic.co/u/robrotheram)
#### Post date: [December 10, 2019, 10:31am UTC](https://discuss.elastic.co/t/7-5-there-was-an-error-retrieving-the-index-pattern/210742/3 "2019-12-10T10:31:08Z")

</div>

Nothing in the console execpt when it tries to get the data  
POST https:///kibana/api/uptime/logOverview 400  
POST https:///kibana/api/uptime/index\_pattern 400

Network log:  
Both requests come back as  
{statusCode: 400, error: "Bad Request", message: "Bad Request"}

Saw nothing strange in the server log

---

<div class="post-metadata">

### Author: ![seb0](https://avatars.discourse-cdn.com/v4/letter/s/ecccb3/32.png) [@seb0](https://discuss.elastic.co/u/seb0)
#### Post date: [December 11, 2019, 2:39pm UTC](https://discuss.elastic.co/t/7-5-there-was-an-error-retrieving-the-index-pattern/210742/4 "2019-12-11T14:39:32Z")

</div>

same here.

Nothing in the console execpt when it tries to get the data  
POST https:///kibana/api/uptime/logOverview 400  
POST https:///kibana/api/uptime/index\_pattern 400

Network log:  
Both requests come back as  
{statusCode: 400, error: "Bad Request", message: "Bad Request"}

---

<div class="post-metadata">

### Author: ![Andrew\_Cholakian1](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/andrew_cholakian1/32/3612_2.png) [@Andrew\_Cholakian1](https://discuss.elastic.co/u/Andrew_Cholakian1)
#### Post date: [December 11, 2019, 11:41pm UTC](https://discuss.elastic.co/t/7-5-there-was-an-error-retrieving-the-index-pattern/210742/5 "2019-12-11T23:41:21Z")

</div>

I've tried to replicate this, but have been unable to do so using version 7.5.0.

Is there any more detail in the kibana server debug logs? My hunch is that whatever is driving this issue is being logged there.

That aside, are there any unusual security settings you've applied? Those shouldn't come back as 400 errors, but I'm trying to cover all the bases here.

---

<div class="post-metadata">

### Author: ![robrotheram](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/robrotheram/32/27262_2.png) [@robrotheram](https://discuss.elastic.co/u/robrotheram)
#### Post date: [December 13, 2019, 2:53pm UTC](https://discuss.elastic.co/t/7-5-there-was-an-error-retrieving-the-index-pattern/210742/6 "2019-12-13T14:53:43Z")

</div>

No security the only thing we had heartbeat index with 2 weeks of data  
I could not see any errors in the log.

I tested a fresh copy of 7.5 on my local macheine with no data and had no problems looks like uptime correctly created the index pattern.

---

<div class="post-metadata">

### Author: ![zakirpcs](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/zakirpcs/32/59974_2.png) [@zakirpcs](https://discuss.elastic.co/u/zakirpcs)
#### Post date: [December 26, 2019, 10:14am UTC](https://discuss.elastic.co/t/7-5-there-was-an-error-retrieving-the-index-pattern/210742/7 "2019-12-26T10:14:16Z")

</div>

To resolve the above issue please follow the below steps:

vim /etc/kibana/kibana.yml

#xpack.security.enabled:

Save and restart the kibana service.

---

<div class="post-metadata">

### Author: ![seb0](https://avatars.discourse-cdn.com/v4/letter/s/ecccb3/32.png) [@seb0](https://discuss.elastic.co/u/seb0)
#### Post date: [January 2, 2020, 10:21am UTC](https://discuss.elastic.co/t/7-5-there-was-an-error-retrieving-the-index-pattern/210742/8 "2020-01-02T10:21:29Z")

</div>

thanks for the tip it works uptime does not give an error anymore. Merci

---

<div class="post-metadata">

### Author: ![Andrew\_Cholakian1](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/andrew_cholakian1/32/3612_2.png) [@Andrew\_Cholakian1](https://discuss.elastic.co/u/Andrew_Cholakian1)
#### Post date: [January 2, 2020, 1:47pm UTC](https://discuss.elastic.co/t/7-5-there-was-an-error-retrieving-the-index-pattern/210742/9 "2020-01-02T13:47:09Z")

</div>

To make sure I understand, disabling security worked here? I assume then that you had security enabled on Kibana, but not enabled on Elasticsearch and that was the source of the problem. Is that correct?

---

<div class="post-metadata">

### Author: ![seb0](https://avatars.discourse-cdn.com/v4/letter/s/ecccb3/32.png) [@seb0](https://discuss.elastic.co/u/seb0)
#### Post date: [January 2, 2020, 3:23pm UTC](https://discuss.elastic.co/t/7-5-there-was-an-error-retrieving-the-index-pattern/210742/10 "2020-01-02T15:23:12Z")

</div>

Yes, i changed  
vim /etc/kibana/kibana.yml  
xpack.security.enabled: false to #xpack.security.enabled:

that worked for me.

But i had both kibana.yml and elasticsearch.yml with:  
xpack.security.enabled: false

---

<div class="post-metadata">

### Author: ![Andrew\_Cholakian1](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/andrew_cholakian1/32/3612_2.png) [@Andrew\_Cholakian1](https://discuss.elastic.co/u/Andrew_Cholakian1)
#### Post date: [January 7, 2020, 9:37pm UTC](https://discuss.elastic.co/t/7-5-there-was-an-error-retrieving-the-index-pattern/210742/11 "2020-01-07T21:37:08Z")

</div>

Interesting, thanks for the report!

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [January 31, 2020, 9:37pm UTC](https://discuss.elastic.co/t/7-5-there-was-an-error-retrieving-the-index-pattern/210742/12 "2020-01-31T21:37:10Z")

</div>

This topic was automatically closed 24 days after the last reply. New replies are no longer allowed.
