# 8.5.2 won't start

**URL:** <https://discuss.elastic.co/t/8-5-2-wont-start/320516>\
**Category:** Elasticsearch\
**Tags:** docker\
**Created:** [December 6, 2022, 3:23am UTC](https://discuss.elastic.co/t/8-5-2-wont-start/320516 "2022-12-06T03:23:36Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![elasticforme](https://avatars.discourse-cdn.com/v4/letter/e/f05b48/32.png) [@elasticforme](https://discuss.elastic.co/u/elasticforme)\
**Post date:** [December 6, 2022, 3:23am UTC](https://discuss.elastic.co/t/8-5-2-wont-start/320516/1 "2022-12-06T03:23:36Z")

</div>

I have try to upgrade one of the cluster to 8.5.2 and it won't start  
I found this which is exact error I am getting. this is not on docker though. running on centos8.x

[https://github.com/elastic/elasticsearch/pull/91704](https://github.com/elastic/elasticsearch/pull/91704)

is this means I am stuck until I Elastic release 8.5.4 ?

is there any workaround to bring this cluster backup.

```auto
[2022-12-06T07:07:37,718][WARN][stderr] [elkd01] The system environment variables are not available to Log4j due to security restrictions: java.security.AccessControlException: access denied ("java.lang.RuntimePermission" "getenv.*")The system environment variables are not available to Log4j due to security restrictions: java.security.AccessControlException: access denied ("java.lang.RuntimePermission" "getenv.*")
[2022-12-06T07:07:37,790][WARN][stderr] [elkd01] java.security.AccessControlException: access denied ("java.lang.RuntimePermission" "getenv.*")
[2022-12-06T07:07:37,718][WARN][stderr] [elkd01] The system environment variables are not available to Log4j due to security restrictions: java.security.AccessControlException: access denied ("java.lang.RuntimePermission" "getenv.*")
[2022-12-06T07:07:37,716][ERROR][o.e.b.ElasticsearchUncaughtExceptionHandler] [elkd01] uncaught exception in thread [process reaper (pid 3599)]

```

```auto
[2022-12-06T07:28:41,294][ERROR][o.e.b.ElasticsearchUncaughtExceptionHandler] [elkd01] uncaught exception in thread [process reaper (pid 3905)]
java.security.AccessControlException: access denied ("java.lang.RuntimePermission" "modifyThread")

```

security part is same as it was working in 7.17.1

```auto
xpack.security.enabled: true
xpack.security.transport.ssl.enabled: true
xpack.security.transport.ssl.verification_mode: certificate
xpack.security.transport.ssl.keystore.path: /etc/elasticsearch/config/elastic-certificates.p12
xpack.security.transport.ssl.truststore.path: /etc/elasticsearch/config/elastic-certificates.p12

```

---

<div class="post-metadata">

**Author:** ![elasticforme](https://avatars.discourse-cdn.com/v4/letter/e/f05b48/32.png) [@elasticforme](https://discuss.elastic.co/u/elasticforme)\
**Post date:** [December 6, 2022, 3:16pm UTC](https://discuss.elastic.co/t/8-5-2-wont-start/320516/2 "2022-12-06T15:16:58Z")

</div>

Finally after many hour fix this.  
this thread help me  
[https://discuss.elastic.co/t/update-errors-to-version-8-3-1/308808](https://discuss.elastic.co/t/update-errors-to-version-8-3-1/308808)

added  
NotifyAccess=all in to [service] section in file "/etc/systemd/system/multi-user.target.wants/elasticsearch.service"

```auto
[Service]
Type=notify
NotifyAccess=all

```

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [January 3, 2023, 3:17pm UTC](https://discuss.elastic.co/t/8-5-2-wont-start/320516/3 "2023-01-03T15:17:10Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
