# 8.5 Elastic Deployment on ECK results in error validation data

**URL:** <https://discuss.elastic.co/t/8-5-elastic-deployment-on-eck-results-in-error-validation-data/318483>\
**Category:** Elastic Cloud on Kubernetes (ECK)\
**Created:** [November 9, 2022, 12:07am UTC](https://discuss.elastic.co/t/8-5-elastic-deployment-on-eck-results-in-error-validation-data/318483 "2022-11-09T00:07:14Z")\
**Posts on this page:** 1\
**Page:** 1

<div class="post-metadata">

**Author:** ![dataRunner](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/datarunner/32/113119_2.png) [@dataRunner](https://discuss.elastic.co/u/dataRunner)\
**Post date:** [November 9, 2022, 12:07am UTC](https://discuss.elastic.co/t/8-5-elastic-deployment-on-eck-results-in-error-validation-data/318483/1 "2022-11-09T00:07:14Z")

</div>

Hi - following the ECK on k8s guide for 8.5 on Azure, I performed the following steps:

1. Created AKS via Azr portal
2. Using the azure command interface, ran the kubectl command to apply the crds.yaml
3. Downloaded the operator.yaml file and changed the namespace name to my namespace (per the instructions to not use "elastic-search" or "default"); ran kubectl command to apply the operator.yaml; verified logs worked.
4. created a "deploy-elastic.yaml" file with the contents shown on this page [Deploy an Elasticsearch cluster | Elastic Cloud on Kubernetes [2.5] | Elastic](https://www.elastic.co/guide/en/cloud-on-k8s/current/k8s-deploy-elasticsearch.html); applied that file  
then got this error:

```auto
 error: error validating "elastic_depoly.yaml": error validating data: [ValidationError(Elasticsearch): unknown field "allowVolumeExpansion" in co.elastic.k8s.elasticsearch.v1.Elasticsearch, ValidationError(Elasticsearch): unknown field "mountOptions" in co.elastic.k8s.elasticsearch.v1.Elasticsearch, ValidationError(Elasticsearch): unknown field "parameters" in co.elastic.k8s.elasticsearch.v1.Elasticsearch, ValidationError(Elasticsearch): unknown field "reclaimPolicy" in co.elastic.k8s.elasticsearch.v1.Elasticsearch]; if you choose to ignore these errors, turn validation off with --validate=false

```

I've sorted out that it does have something to do with the webhooks config. Any ideas on what I need to do to resolve this?
