# A plugin error

**URL:** <https://discuss.elastic.co/t/a-plugin-error/107488>\
**Category:** Logstash\
**Created:** [November 14, 2017, 5:32am UTC](https://discuss.elastic.co/t/a-plugin-error/107488 "2017-11-14T05:32:56Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![Shaswata\_Bisi](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/shaswata_bisi/32/23222_2.png) [@Shaswata\_Bisi](https://discuss.elastic.co/u/Shaswata_Bisi)\
**Post date:** [November 14, 2017, 5:32am UTC](https://discuss.elastic.co/t/a-plugin-error/107488/1 "2017-11-14T05:32:57Z")

</div>

I have ES 5.6.3 and logstash 5.4 installed on my local system whereas I have filebeat 5.4 installed in another system. Whenever I am trying to run logstash, I get the following error

**[[main]\<beats] ERROR logstash.pipeline - A plugin had an unrecoverable error. Will restart this plugin.**  
\*\* Plugin: \<LogStash::Inputs::Beats host=\>"171.16.203.122", port=\>5044, id=\>"0071afb40104d17543db821bb2ad85d9dd89778e-1", enable\_metric=\>true, codec=\>\<LogStash::Codecs::Plain id=\>"plain\_503f23f3-5557-4dfc-967b-2fe14cf3bc93", enable\_metric=\>true, charset=\>"UTF-8"\>, ssl=\>false, ssl\_verify\_mode=\>"none", include\_codec\_tag=\>true, ssl\_handshake\_timeout=\>10000, congestion\_threshold=\>5, target\_field\_for\_codec=\>"message", tls\_min\_version=\>1, tls\_max\_version=\>1.2, cipher\_suites=\>["TLS\_ECDHE\_ECDSA\_WITH\_AES\_256\_GCM\_SHA384", "TLS\_ECDHE\_RSA\_WITH\_AES\_256\_GCM\_SHA384", "TLS\_ECDHE\_ECDSA\_WITH\_AES\_128\_GCM\_SHA256", "TLS\_ECDHE\_RSA\_WITH\_AES\_128\_GCM\_SHA256", "TLS\_ECDHE\_ECDSA\_WITH\_AES\_256\_CBC\_SHA384", "TLS\_ECDHE\_RSA\_WITH\_AES\_256\_CBC\_SHA384", "TLS\_ECDHE\_ECDSA\_WITH\_AES\_128\_CBC\_SHA256"], client\_inactivity\_timeout=\>60\>\*\*  
\*\* Error: Cannot assign requested address: bind\*\*  
**10:48:44.028 [[main]\<beats] ERROR logstash.pipeline - A plugin had an unrecoverable error. Will restart this plugin.**  
\*\* Plugin: \<LogStash::Inputs::Beats host=\>`client ip`, port=\>5044, id=\>"0071afb40104d17543db821bb2ad85d9dd89778e-1", enable\_metric=\>true, codec=\>\<LogStash::Codecs::Plain id=\>"plain\_503f23f3-5557-4dfc-967b-2fe14cf3bc93", enable\_metric=\>true, charset=\>"UTF-8"\>, ssl=\>false, ssl\_verify\_mode=\>"none", include\_codec\_tag=\>true, ssl\_handshake\_timeout=\>10000, congestion\_threshold=\>5, target\_field\_for\_codec=\>"message", tls\_min\_version=\>1, tls\_max\_version=\>1.2, cipher\_suites=\>["TLS\_ECDHE\_ECDSA\_WITH\_AES\_256\_GCM\_SHA384", "TLS\_ECDHE\_RSA\_WITH\_AES\_256\_GCM\_SHA384", "TLS\_ECDHE\_ECDSA\_WITH\_AES\_128\_GCM\_SHA256", "TLS\_ECDHE\_RSA\_WITH\_AES\_128\_GCM\_SHA256", "TLS\_ECDHE\_ECDSA\_WITH\_AES\_256\_CBC\_SHA384", "TLS\_ECDHE\_RSA\_WITH\_AES\_256\_CBC\_SHA384", "TLS\_ECDHE\_ECDSA\_WITH\_AES\_128\_CBC\_SHA256"], client\_inactivity\_timeout=\>60\>\*\*  
**Error: event executor terminated**

The following is my configuration file  
**input { \*\*  
\*\* beats {**  
\*\* host =\> "client ip"\*\*  
\*\* port =\> "5044"\*\*  
\*\* #ssl =\> true\*\*  
\*\* #ssl\_certificate =\> "D:\ELK\OpenSSL\bin\server.csr"\*\*  
\*\* #ssl\_key =\> "D:\ELK\OpenSSL\bin\server.key"\*\*  
\*\* }\*\*  
**}**  
**filter {**

\*\* csv {\*\*  
\*\* separator =\> ","\*\*  
\*\* columns =\> ["Timestamp",\*\*  
**"Memory-% Committed Bytes In Use",**  
**"Memory-Available Bytes",**  
**"Memory-Available KBytes",**  
**"Memory-Available MBytes",**  
**"Memory-Page Faults/sec",**  
**"Memory-Free System Page Table Entries",**  
**"PhysicalDisk(\_Total)-Avg. Disk Bytes/Read",**  
**"PhysicalDisk(\_Total)-Avg. Disk Bytes/Write",**  
**"PhysicalDisk(\_Total)-Current Disk Queue Length",**  
**"PhysicalDisk(\_Total)-Disk Read Bytes/sec",**  
**"PhysicalDisk(\_Total)-Disk Write Bytes/sec",**  
**"Process(\_Total)-% Processor Time",**  
**"Process(\_Total)-% User Time",**  
**"Process(\_Total)-ID Process",**  
**"Process(\_Total)-Thread Count",**  
**"Process(\_Total)-Working Set",**  
**"Process(\_Total)-IO Read Bytes/sec",**  
**"Process(\_Total)-IO Write Bytes/sec",**  
**"Processor(\_Total)-% Idle Time",**  
**"Processor(\_Total)-% Processor Time",**  
**"Processor(\_Total)-% User Time"]**  
\*\* }\*\*  
**}**  
**output { \*\*  
\*\* elasticsearch {**  
\*\* hosts =\> ["server ip:9200"]\*\*  
\*\* index =\> systemosmetricsindex\*\*  
\*\* }\*\*  
\*\* stdout{codec =\> rubydebug }\*\*

elasticsearch.yml file  
**# ---------------------------------- Network -----------------------------------**  
**network.host: server ip**  
**http.port: 9200**

logstash.yml file  
**# ------------ Node identity ------------**  
**[node.name](http://node.name): server ip**

**# ------------ Metrics Settings --------------**  
**http.host: server ip**  
**http.port: 9600**

filebeat.yml  
**filebeat.prospectors:**

**- input\_type: log**  
\*\* paths:\*\*  
\*\* - D:\Development\Shaswata\Perfmon\INHYICBIVM004\_20171112-000001\*.csv\*\*  
**#----------------------------- Logstash output --------------------------------**  
**output.logstash:**  
\*\* # The Logstash hosts\*\*  
\*\* hosts: ["server ip:5044"]\*\*

\*\* # Optional SSL. By default is off.\*\*  
\*\* # List of root certificates for HTTPS server verifications\*\*  
\*\* #ssl.certificate\_authorities: ["/etc/pki/root/ca.pem"]\*\*

\*\* # Certificate for SSL client authentication\*\*  
\*\* #ssl.certificate: "/etc/pki/client/cert.pem"\*\*

\*\* # Client Certificate Key\*\*  
\*\* #ssl.key: ["D:\Development\Shaswata\server.key"]\*\*

---

<div class="post-metadata">

**Author:** ![magnusbaeck](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/magnusbaeck/32/44943_2.png) [@magnusbaeck](https://discuss.elastic.co/u/magnusbaeck)\
**Post date:** [November 14, 2017, 6:13am UTC](https://discuss.elastic.co/t/a-plugin-error/107488/2 "2017-11-14T06:13:34Z")

</div>

> \*\* host =\> "client ip"\*\*

What's up with all the asterisks?

Client IP as in the address of the host running Filebeat? No, you've misunderstood what the `host` option does. Remove it.

---

<div class="post-metadata">

**Author:** ![Shaswata\_Bisi](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/shaswata_bisi/32/23222_2.png) [@Shaswata\_Bisi](https://discuss.elastic.co/u/Shaswata_Bisi)\
**Post date:** [November 14, 2017, 11:28am UTC](https://discuss.elastic.co/t/a-plugin-error/107488/3 "2017-11-14T11:28:48Z")

</div>

The asteriks just came in when i was trying tomake the statement bold. you can ignore the asteriks part.  
Ya removing the host worked. thanks a lot.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [December 12, 2017, 11:28am UTC](https://discuss.elastic.co/t/a-plugin-error/107488/4 "2017-12-12T11:28:54Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
