# A plugin had an unrecoverable error. Will restart this plugin

**URL:** <https://discuss.elastic.co/t/a-plugin-had-an-unrecoverable-error-will-restart-this-plugin/251913>\
**Category:** Logstash\
**Created:** [October 13, 2020, 1:59pm UTC](https://discuss.elastic.co/t/a-plugin-had-an-unrecoverable-error-will-restart-this-plugin/251913 "2020-10-13T13:59:19Z")\
**Posts on this page:** 14\
**Page:** 1

<div class="post-metadata">

**Author:** ![sukumar.koganti](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/sukumar.koganti/32/74111_2.png) [@sukumar.koganti](https://discuss.elastic.co/u/sukumar.koganti)\
**Post date:** [October 13, 2020, 1:59pm UTC](https://discuss.elastic.co/t/a-plugin-had-an-unrecoverable-error-will-restart-this-plugin/251913/1 "2020-10-13T13:59:19Z")

</div>

Hi Team,

I am trying to read my Sql Server table from the DB and here is my .conf file,  
when i am trying to read the table through logstash i am getting the below error.

* * *

input {

jdbc {

```
jdbc_driver_library => "C:/Program Files/Java/sqljdbc_8.4.1.0_enu/sqljdbc_8.4/enu"

jdbc_driver_class => "com.microsoft.sqlserver.jdbc.SQLServerDriver"

jdbc_connection_string => "jdbc:sqlserver://Provider=SQLOLEDB.1;Integrated Security=SSPI;Persist Security Info=False;Initial Catalog=B2BWebService;Data Source=TOUCHDB05;"

jdbc_user => "xxxxxxxxxx"

jdbc_password => "xxxxx"

statement => "SELECT count(*) from ediGuidExtracted"

```

}

}

output {

elasticsearch {

```
hosts => "localhost:9200"

index => "montreal"

```

}

}

---

<div class="post-metadata">

**Author:** ![Badger](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/badger/32/25190_2.png) [@Badger](https://discuss.elastic.co/u/Badger)\
**Post date:** [October 13, 2020, 3:31pm UTC](https://discuss.elastic.co/t/a-plugin-had-an-unrecoverable-error-will-restart-this-plugin/251913/2 "2020-10-13T15:31:57Z")

</div>

> [@sukumar.koganti](#):
>
> i am getting the below error.

You did not show the error

---

<div class="post-metadata">

**Author:** ![sukumar.koganti](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/sukumar.koganti/32/74111_2.png) [@sukumar.koganti](https://discuss.elastic.co/u/sukumar.koganti)\
**Post date:** [October 13, 2020, 3:48pm UTC](https://discuss.elastic.co/t/a-plugin-had-an-unrecoverable-error-will-restart-this-plugin/251913/3 "2020-10-13T15:48:07Z")

</div>

Hi Badger,  
here it is.

[ERROR][logstash.javapipeline][main][10243dd96cbc3a21d2105c489922606e379ce63693dc4526f78e24b1ee195258] A plugin had an unrecoverable error. Will restart this plugin.  
Pipeline\_id:main  
Plugin: \<LogStash::Inputs::Jdbc jdbc\_user=\>"b2bdev", jdbc\_password=\>, statement=\>"SELECT count(\*) from ediGuidExtracted", jdbc\_driver\_library=\>"C:\Program Files\Java\sqljdbc\_8.4.1.0\_enu\sqljdbc\_8.4\enu", jdbc\_connection\_string=\>"jdbc:sqlserver://Provider=SQLOLEDB.1;Integrated Security=SSPI;Persist Security Info=False;Initial Catalog=B2BWebService;Data Source=TOUCHDB05;", id=\>"10243dd96cbc3a21d2105c489922606e379ce63693dc4526f78e24b1ee195258", jdbc\_driver\_class=\>"com.microsoft.sqlserver.jdbc.SQLServerDriver", enable\_metric=\>true, codec=\>\<LogStash::Codecs::Plain id=\>"plain\_c950034b-7696-4351-9c19-e45fba45f791", enable\_metric=\>true, charset=\>"UTF-8"\>, jdbc\_paging\_enabled=\>false, jdbc\_page\_size=\>100000, jdbc\_validate\_connection=\>false, jdbc\_validation\_timeout=\>3600, jdbc\_pool\_timeout=\>5, sql\_log\_level=\>"info", connection\_retry\_attempts=\>1, connection\_retry\_attempts\_wait\_time=\>0.5, plugin\_timezone=\>"utc", last\_run\_metadata\_path=\>"C:\Users\skkoganti/.logstash\_jdbc\_last\_run", use\_column\_value=\>false, tracking\_column\_type=\>"numeric", clean\_run=\>false, record\_last\_run=\>true, lowercase\_column\_names=\>true, use\_prepared\_statements=\>false\>  
Error: unable to load C:\Program Files\Java\sqljdbc\_8.4.1.0\_enu\sqljdbc\_8.4\enu from :jdbc\_driver\_library, no such file to load -- C:/Program Files/Java/sqljdbc\_8.4.1.0\_enu/sqljdbc\_8.4/enu  
Exception: LogStash::PluginLoadingError  
Stack: C:/ELK/logstash-7.9.1/logstash-7.9.1/vendor/bundle/jruby/2.5.0/gems/logstash-integration-jdbc-5.0.6/lib/logstash/plugin\_mixins/jdbc/common.rb:53:in `block in load_driver_jars' org/jruby/RubyArray.java:1809:in `each'  
C:/ELK/logstash-7.9.1/logstash-7.9.1/vendor/bundle/jruby/2.5.0/gems/logstash-integration-jdbc-5.0.6/lib/logstash/plugin\_mixins/jdbc/common.rb:42:in `load_driver_jars' C:/ELK/logstash-7.9.1/logstash-7.9.1/vendor/bundle/jruby/2.5.0/gems/logstash-integration-jdbc-5.0.6/lib/logstash/plugin_mixins/jdbc/common.rb:25:in `load\_driver'  
C:/ELK/logstash-7.9.1/logstash-7.9.1/vendor/bundle/jruby/2.5.0/gems/logstash-integration-jdbc-5.0.6/lib/logstash/inputs/jdbc.rb:275:in `run' C:/ELK/logstash-7.9.1/logstash-7.9.1/logstash-core/lib/logstash/java_pipeline.rb:378:in `inputworker'  
C:/ELK/logstash-7.9.1/logstash-7.9.1/logstash-core/lib/logstash/java\_pipeline.rb:369:in `block in start\_input'

---

<div class="post-metadata">

**Author:** ![Badger](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/badger/32/25190_2.png) [@Badger](https://discuss.elastic.co/u/Badger)\
**Post date:** [October 13, 2020, 4:02pm UTC](https://discuss.elastic.co/t/a-plugin-had-an-unrecoverable-error-will-restart-this-plugin/251913/4 "2020-10-13T16:02:49Z")

</div>

> [@sukumar.koganti](#):
>
> Error: unable to load C:\Program Files\Java\sqljdbc\_8.4.1.0\_enu\sqljdbc\_8.4\enu from :jdbc\_driver\_library, no such file to load -- C:/Program Files/Java/sqljdbc\_8.4.1.0\_enu/sqljdbc\_8.4/enu

It is saying that file does not exist.

---

<div class="post-metadata">

**Author:** ![sukumar.koganti](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/sukumar.koganti/32/74111_2.png) [@sukumar.koganti](https://discuss.elastic.co/u/sukumar.koganti)\
**Post date:** [October 13, 2020, 4:07pm UTC](https://discuss.elastic.co/t/a-plugin-had-an-unrecoverable-error-will-restart-this-plugin/251913/5 "2020-10-13T16:07:23Z")

</div>

It's exist badger for some reason it is quitting. Please find the screen shot for your reference.

 ![image](https://us1.discourse-cdn.com/elastic/original/3X/1/f/1ff1db03d66e48eba1580738c669df0391ada8db.png)

---

<div class="post-metadata">

**Author:** ![Badger](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/badger/32/25190_2.png) [@Badger](https://discuss.elastic.co/u/Badger)\
**Post date:** [October 13, 2020, 4:11pm UTC](https://discuss.elastic.co/t/a-plugin-had-an-unrecoverable-error-will-restart-this-plugin/251913/6 "2020-10-13T16:11:26Z")

</div>

jdbc\_driver\_library should point to the jar file, not the directory that contains it.

---

<div class="post-metadata">

**Author:** ![sukumar.koganti](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/sukumar.koganti/32/74111_2.png) [@sukumar.koganti](https://discuss.elastic.co/u/sukumar.koganti)\
**Post date:** [October 13, 2020, 4:14pm UTC](https://discuss.elastic.co/t/a-plugin-had-an-unrecoverable-error-will-restart-this-plugin/251913/7 "2020-10-13T16:14:16Z")

</div>

like below?

jdbc\_driver\_library =\> "C:\Program Files\Java\sqljdbc\_8.4.1.0\_enu\sqljdbc\_8.4\enu\mssql-jdbc-8.4.1.jre11.jar"

---

<div class="post-metadata">

**Author:** ![Badger](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/badger/32/25190_2.png) [@Badger](https://discuss.elastic.co/u/Badger)\
**Post date:** [October 13, 2020, 4:18pm UTC](https://discuss.elastic.co/t/a-plugin-had-an-unrecoverable-error-will-restart-this-plugin/251913/8 "2020-10-13T16:18:30Z")

</div>

Yes.

---

<div class="post-metadata">

**Author:** ![sukumar.koganti](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/sukumar.koganti/32/74111_2.png) [@sukumar.koganti](https://discuss.elastic.co/u/sukumar.koganti)\
**Post date:** [October 13, 2020, 4:27pm UTC](https://discuss.elastic.co/t/a-plugin-had-an-unrecoverable-error-will-restart-this-plugin/251913/9 "2020-10-13T16:27:03Z")

</div>

Error: Java::ComMicrosoftSqlserverJdbc::SQLServerException: The TCP/IP connection to the host Provider=SQLOLEDB.1, port 1433 has failed. Error: "Provider=SQLOLEDB.1. Verify the connection properties. Make sure that an instance of SQL Server is running on the host and accepting TCP/IP connections at the port. Make sure that TCP connections to the port are not blocked by a firewall.".  
Exception: Sequel::DatabaseConnectionError

---

<div class="post-metadata">

**Author:** ![sukumar.koganti](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/sukumar.koganti/32/74111_2.png) [@sukumar.koganti](https://discuss.elastic.co/u/sukumar.koganti)\
**Post date:** [October 13, 2020, 6:16pm UTC](https://discuss.elastic.co/t/a-plugin-had-an-unrecoverable-error-will-restart-this-plugin/251913/10 "2020-10-13T18:16:38Z")

</div>

I think there is problem with firewall isuee badger :), I will try to find it.

---

<div class="post-metadata">

**Author:** ![sukumar.koganti](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/sukumar.koganti/32/74111_2.png) [@sukumar.koganti](https://discuss.elastic.co/u/sukumar.koganti)\
**Post date:** [October 14, 2020, 1:39pm UTC](https://discuss.elastic.co/t/a-plugin-had-an-unrecoverable-error-will-restart-this-plugin/251913/11 "2020-10-14T13:39:43Z")

</div>

Hi Badger, Good Morning,

I tried to resolve the issue but unfortunately no luck. when i try to connect the database normally i can connect but through logstash i could not able to connect.

can you help me to resolve this issue.

---

<div class="post-metadata">

**Author:** ![Badger](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/badger/32/25190_2.png) [@Badger](https://discuss.elastic.co/u/Badger)\
**Post date:** [October 14, 2020, 2:57pm UTC](https://discuss.elastic.co/t/a-plugin-had-an-unrecoverable-error-will-restart-this-plugin/251913/12 "2020-10-14T14:57:08Z")

</div>

> [@sukumar.koganti](#):
>
> can you help me to resolve this issue.

I cannot. What you have now is not a logstash question. It is either an SQLserver question or a general networking question.

---

<div class="post-metadata">

**Author:** ![sukumar.koganti](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/sukumar.koganti/32/74111_2.png) [@sukumar.koganti](https://discuss.elastic.co/u/sukumar.koganti)\
**Post date:** [October 14, 2020, 5:20pm UTC](https://discuss.elastic.co/t/a-plugin-had-an-unrecoverable-error-will-restart-this-plugin/251913/13 "2020-10-14T17:20:08Z")

</div>

Yeah Badger, Something related to network.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [November 11, 2020, 5:20pm UTC](https://discuss.elastic.co/t/a-plugin-had-an-unrecoverable-error-will-restart-this-plugin/251913/14 "2020-11-11T17:20:18Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
