# A plugin had an unrecoverable error. Will restart this plugin

**URL:** <https://discuss.elastic.co/t/a-plugin-had-an-unrecoverable-error-will-restart-this-plugin/271946>\
**Category:** Logstash\
**Created:** [May 3, 2021, 8:37am UTC](https://discuss.elastic.co/t/a-plugin-had-an-unrecoverable-error-will-restart-this-plugin/271946 "2021-05-03T08:37:09Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![Safir](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/safir/32/88114_2.png) [@Safir](https://discuss.elastic.co/u/Safir)\
**Post date:** [May 3, 2021, 8:37am UTC](https://discuss.elastic.co/t/a-plugin-had-an-unrecoverable-error-will-restart-this-plugin/271946/1 "2021-05-03T08:37:09Z")

</div>

/Users/lab/Desktop/logstash/logstash-core/lib/logstash/java\_pipeline.rb:396:in `block in start_input' [2021-05-03T11:31:51,605][ERROR][logstash.javapipeline][main][6a3d8ecc5c72c85e305635d46ccbd177399eb255a591231ec278b8784b6854dd] A plugin had an unrecoverable error. Will restart this plugin. Pipeline_id:main Plugin: <LogStash::Inputs::Jdbc jdbc_user=>"postgres", jdbc_password=><password>, statement=>"SELECT * from postgres.\\\"employees\\\"", jdbc_driver_library=>"~/Desktop/postgresql-42.2.20.jre7.jar", jdbc_connection_string=>"jdbc:postgresql://localhost:5232/postgres", id=>"6a3d8ecc5c72c85e305635d46ccbd177399eb255a591231ec278b8784b6854dd", jdbc_driver_class=>"org.postgresql.Driver", enable_metric=>true, codec=><LogStash::Codecs::Plain id=>"plain_dd4f60ec-6078-4a13-8f32-a19cffdb22a4", enable_metric=>true, charset=>"UTF-8">, jdbc_paging_enabled=>false, jdbc_page_size=>100000, jdbc_validate_connection=>false, jdbc_validation_timeout=>3600, jdbc_pool_timeout=>5, sql_log_level=>"info", connection_retry_attempts=>1, connection_retry_attempts_wait_time=>0.5, plugin_timezone=>"utc", last_run_metadata_path=>"/Users/lab/.logstash_jdbc_last_run", use_column_value=>false, tracking_column_type=>"numeric", clean_run=>false, record_last_run=>true, lowercase_column_names=>true, use_prepared_statements=>false> Error: unable to load ~/Desktop/postgresql-42.2.20.jre7.jar from :jdbc_driver_library, file not readable (please check user and group permissions for the path) Exception: LogStash::PluginLoadingError Stack: /Users/lab/Desktop/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-integration-jdbc-5.0.6/lib/logstash/plugin_mixins/jdbc/common.rb:47:in `block in load\_driver\_jars'  
org/jruby/RubyArray.java:1809:in `each' /Users/lab/Desktop/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-integration-jdbc-5.0.6/lib/logstash/plugin_mixins/jdbc/common.rb:42:in `load\_driver\_jars'  
/Users/lab/Desktop/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-integration-jdbc-5.0.6/lib/logstash/plugin\_mixins/jdbc/common.rb:25:in `load_driver' /Users/lab/Desktop/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-integration-jdbc-5.0.6/lib/logstash/inputs/jdbc.rb:275:in `run'  
/Users/lab/Desktop/logstash/logstash-core/lib/logstash/java\_pipeline.rb:405:in `inputworker' /Users/lab/Desktop/logstash/logstash-core/lib/logstash/java_pipeline.rb:396:in `block in start\_input'  
[2021-05-03T11:31:52,611][ERROR][logstash.javapipeline][main][6a3d8ecc5c72c85e305635d46ccbd177399eb255a591231ec278b8784b6854dd] A plugin had an unrecoverable error. Will restart this plugin.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [May 31, 2021, 8:37am UTC](https://discuss.elastic.co/t/a-plugin-had-an-unrecoverable-error-will-restart-this-plugin/271946/2 "2021-05-31T08:37:27Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
