# Aborting enrolling to cluster. Could not communicate with the node on any of the addresses from the enrolment token

**URL:** https://discuss.elastic.co/t/aborting-enrolling-to-cluster-could-not-communicate-with-the-node-on-any-of-the-addresses-from-the-enrolment-token/346174
**Category:** Elasticsearch
**Tags:** elastic-stack-security
**Created:** [November 1, 2023, 6:10am UTC](https://discuss.elastic.co/t/aborting-enrolling-to-cluster-could-not-communicate-with-the-node-on-any-of-the-addresses-from-the-enrolment-token/346174 "2023-11-01T06:10:10Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![Vyshak\_Sekhar](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/vyshak_sekhar/32/124452_2.png) [@Vyshak\_Sekhar](https://discuss.elastic.co/u/Vyshak_Sekhar)
#### Post date: [November 1, 2023, 6:10am UTC](https://discuss.elastic.co/t/aborting-enrolling-to-cluster-could-not-communicate-with-the-node-on-any-of-the-addresses-from-the-enrolment-token/346174/1 "2023-11-01T06:10:10Z")

</div>

I am trying to install a 2 node Elasticsearch cluster , i installed and my Elasticsearch that node is running fine and while im trying to connect the next node to the using enrollment token im getting this borting enrolling to cluster. **Could not communicate with the node on any of the addresses from the enrollment token. All of [10.20.1.36:9200] were attempted., with exit code 69** error  
this my configuration of node 1

root@ip-10-20-1-36:/home/ubuntu# cat /etc/elasticsearch/elasticsearch.yml  
cluster.name: lg-es  
node.name: es-node01  
node.roles: [master, data]  
path.data: /ebs/elasticsearch  
path.logs: /var/log/elasticsearch  
bootstrap.memory\_lock: true  
network.host: 10.20.1.36  
http.port: 9200  
xpack.security.enabled: true  
xpack.security.enrollment.enabled: true  
xpack.security.http.ssl:  
enabled: true  
keystore.path: certs/http.p12  
xpack.security.transport.ssl:  
enabled: true  
verification\_mode: certificate  
keystore.path: certs/transport.p12  
truststore.path: certs/transport.p12  
cluster.initial\_master\_nodes: ["es-node01"]

i have added the basic config in node 2

root@ip-10-20-1-115:/home/ubuntu# grep -Ev '^#|^$' /etc/elasticsearch/elasticsearch.yml  
cluster.name: lg-es  
node.name: es-node02  
path.data: /ebs/elasticsearch  
path.logs: /var/log/elasticsearch  
network.host: 10.20.1.115  
http.port: 9200

i have not started the Elasticsearch , but whenever im trying to connect to the node 1 im getting this error  
i have also open the respective port in security group of the server also

 ![Screenshot from 2023-10-31 16-58-54](https://us1.discourse-cdn.com/elastic/original/3X/6/5/65950cab2bd2b290e51d477cf352b3f716fca48b.png)

I also installed it using DEB package still getting the issue

~~how~~~~ to ~~~~solve~~~~ this~~

---

<div class="post-metadata">

### Author: ![TimV](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/timv/32/13162_2.png) [@TimV](https://discuss.elastic.co/u/TimV)
#### Post date: [November 2, 2023, 3:47am UTC](https://discuss.elastic.co/t/aborting-enrolling-to-cluster-could-not-communicate-with-the-node-on-any-of-the-addresses-from-the-enrolment-token/346174/2 "2023-11-02T03:47:16Z")

</div>

On 10.20.1.115 (host for node 2) try

```bash
curl https://10.20.1.36:9200/

```

based on the error above, I expect this to fail with some sort of network problem (timeout, or similar).  
If that's the case then this isn't an Elasticsearch problem, it's something that prevents connectivity between those hosts (on that port).

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [November 30, 2023, 3:48am UTC](https://discuss.elastic.co/t/aborting-enrolling-to-cluster-could-not-communicate-with-the-node-on-any-of-the-addresses-from-the-enrolment-token/346174/3 "2023-11-30T03:48:00Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
