# About org.elasticsearch.indices.recovery.RecoveryFailedException error

**URL:** https://discuss.elastic.co/t/about-org-elasticsearch-indices-recovery-recoveryfailedexception-error/23341
**Category:** Elasticsearch
**Created:** [April 21, 2015, 10:39am UTC](https://discuss.elastic.co/t/about-org-elasticsearch-indices-recovery-recoveryfailedexception-error/23341 "2015-04-21T10:39:32Z")
**Posts on this page:** 2
**Page:** 1

<div class="post-metadata">

### Author: ![guoyiqincn](https://avatars.discourse-cdn.com/v4/letter/g/ccd318/32.png) [@guoyiqincn](https://discuss.elastic.co/u/guoyiqincn)
#### Post date: [April 21, 2015, 10:39am UTC](https://discuss.elastic.co/t/about-org-elasticsearch-indices-recovery-recoveryfailedexception-error/23341/1 "2015-04-21T10:39:32Z")

</div>

_Hi All,_

\*I have a 5 nodes cluster. \*

\*now my cluster eror \*

[2015-04-21 18:32:26,032][WARN][indices.cluster] [i-bxtszyhz]  
[blacklist][1] failed to start shard  
org.elasticsearch.indices.recovery.RecoveryFailedException: [blacklist][1]:  
Recovery failed from  
[i-5tar85fu][9ofd50CbQmiYwcdppvAYVw][i-5tar85fu][inet[/192.168.101.53:9300]]  
into  
[i-bxtszyhz][AF98fGO3RCG0gta1LKrd-A][i-bxtszyhz][inet[/192.168.101.54:9300]]  
at  
org.elasticsearch.indices.recovery.RecoveryTarget.doRecovery(RecoveryTarget.java:308)  
at  
org.elasticsearch.indices.recovery.RecoveryTarget.access$200(RecoveryTarget.java:65)  
at  
org.elasticsearch.indices.recovery.RecoveryTarget$2.run(RecoveryTarget.java:177)  
at  
java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)  
at  
java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)  
at java.lang.Thread.run(Thread.java:744)  
Caused by: org.elasticsearch.transport.RemoteTransportException:  
[i-5tar85fu][inet[/192.168.101.53:9300]][internal:index/shard/recovery/start\_recovery]  
Caused by: org.elasticsearch.index.engine.RecoveryEngineException:  
[blacklist][1] Phase[1] Execution failed  
at  
org.elasticsearch.index.engine.internal.InternalEngine.recover(InternalEngine.java:1120)  
at  
org.elasticsearch.index.shard.service.InternalIndexShard.recover(InternalIndexShard.java:654)  
at  
org.elasticsearch.indices.recovery.RecoverySource.recover(RecoverySource.java:137)  
at  
org.elasticsearch.indices.recovery.RecoverySource.access$2600(RecoverySource.java:74)  
at  
org.elasticsearch.indices.recovery.RecoverySource$StartRecoveryTransportRequestHandler.messageReceived(RecoverySource.java:464)  
at  
org.elasticsearch.indices.recovery.RecoverySource$StartRecoveryTransportRequestHandler.messageReceived(RecoverySource.java:450)  
at  
org.elasticsearch.transport.netty.MessageChannelHandler$RequestHandler.run(MessageChannelHandler.java:275)  
at  
java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)  
at  
java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)  
at java.lang.Thread.run(Thread.java:744)  
Caused by:  
org.elasticsearch.indices.recovery.RecoverFilesRecoveryException:  
[blacklist][1] Failed to transfer [1] files with total size of [2mb]  
at  
org.elasticsearch.indices.recovery.RecoverySource$1.phase1(RecoverySource.java:276)  
at  
org.elasticsearch.index.engine.internal.InternalEngine.recover(InternalEngine.java:1116)  
... 9 more  
Caused by: org.elasticsearch.transport.RemoteTransportException:  
[i-bxtszyhz][inet[/192.168.101.54:9300]][internal:index/shard/recovery/file\_chunk]  
Caused by: java.io.FileNotFoundException:  
/var/data/elasticsearch/9FbankCloud/nodes/0/indices/blacklist/1/index/recovery.1429612346025.segments\_5  
(Permission denied)  
at java.io.FileOutputStream.open(Native Method)  
at java.io.FileOutputStream.(FileOutputStream.java:221)  
at java.io.FileOutputStream.(FileOutputStream.java:171)  
at  
org.apache.lucene.store.FSDirectory$FSIndexOutput.(FSDirectory.java:389)  
at  
org.apache.lucene.store.FSDirectory.createOutput(FSDirectory.java:282)  
at  
org.apache.lucene.store.FileSwitchDirectory.createOutput(FileSwitchDirectory.java:152)  
at  
org.apache.lucene.store.RateLimitedFSDirectory.createOutput(RateLimitedFSDirectory.java:40)  
at  
org.elasticsearch.index.store.DistributorDirectory.createOutput(DistributorDirectory.java:118)  
at  
org.apache.lucene.store.FilterDirectory.createOutput(FilterDirectory.java:69)  
at  
org.elasticsearch.index.store.Store.createVerifyingOutput(Store.java:336)  
at  
org.elasticsearch.indices.recovery.RecoveryStatus.openAndPutIndexOutput(RecoveryStatus.java:120)  
at  
org.elasticsearch.indices.recovery.RecoveryTarget$FileChunkTransportRequestHandler.messageReceived(RecoveryTarget.java:573)  
at  
org.elasticsearch.indices.recovery.RecoveryTarget$FileChunkTransportRequestHandler.messageReceived(RecoveryTarget.java:535)  
at  
org.elasticsearch.transport.netty.MessageChannelHandler$RequestHandler.run(MessageChannelHandler.java:275)  
at  
java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)  
at  
java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)  
at java.lang.Thread.run(Thread.java:744)

I really hope to get help

_Thanks !!!_

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/1694480e-1017-4986-b7fb-cb756cccf73e%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/1694480e-1017-4986-b7fb-cb756cccf73e%40googlegroups.com).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [July 6, 2017, 12:18am UTC](https://discuss.elastic.co/t/about-org-elasticsearch-indices-recovery-recoveryfailedexception-error/23341/2 "2017-07-06T00:18:34Z")

</div>


