# \[action.admin.indices.stats\] failed to execute operation for shard

**URL:** https://discuss.elastic.co/t/action-admin-indices-stats-failed-to-execute-operation-for-shard/36010
**Category:** Elasticsearch
**Created:** [December 1, 2015, 9:31am UTC](https://discuss.elastic.co/t/action-admin-indices-stats-failed-to-execute-operation-for-shard/36010 "2015-12-01T09:31:23Z")
**Posts on this page:** 6
**Page:** 1

<div class="post-metadata">

### Author: ![Enniu\_51](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/enniu_51/32/5310_2.png) [@Enniu\_51](https://discuss.elastic.co/u/Enniu_51)
#### Post date: [December 1, 2015, 9:31am UTC](https://discuss.elastic.co/t/action-admin-indices-stats-failed-to-execute-operation-for-shard/36010/1 "2015-12-01T09:31:23Z")

</div>

I saw a lot of that error on my Elasticsearch logs:

```
[2015-12-01 17:27:03,663][DEBUG][action.admin.indices.stats] [crawler_service_001] [indices:monitor/stats] failed to execute operation for shard [[carrier-2015.12.01][2], node[rCqrCf10SGuAVqW_YYiDng], [P], v[7], s[INITIALIZING], a[id=qHbJSlmPRhCLRc7lrpO_Nw], unassigned_info[[reason=ALLOCATION_FAILED], at[2015-12-01T09:25:09.830Z], details[engine failure, reason [refresh failed], failure NullPointerException[null]]]]
[carrier-2015.12.01][[carrier-2015.12.01][2]] BroadcastShardOperationFailedException[operation indices:monitor/stats failed]; nested: IllegalIndexShardStateException[CurrentState[RECOVERING] operations only allowed when shard state is one of [POST_RECOVERY, STARTED, RELOCATED]];
	at org.elasticsearch.action.support.broadcast.node.TransportBroadcastByNodeAction$BroadcastByNodeTransportRequestHandler.onShardOperation(TransportBroadcastByNodeAction.java:405)
	at org.elasticsearch.action.support.broadcast.node.TransportBroadcastByNodeAction$BroadcastByNodeTransportRequestHandler.messageReceived(TransportBroadcastByNodeAction.java:382)
	at org.elasticsearch.action.support.broadcast.node.TransportBroadcastByNodeAction$BroadcastByNodeTransportRequestHandler.messageReceived(TransportBroadcastByNodeAction.java:371)
	at org.elasticsearch.transport.TransportService$4.doRun(TransportService.java:350)
	at org.elasticsearch.common.util.concurrent.AbstractRunnable.run(AbstractRunnable.java:37)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
	at java.lang.Thread.run(Thread.java:745)
Caused by: [carrier-2015.12.01][[carrier-2015.12.01][2]] IllegalIndexShardStateException[CurrentState[RECOVERING] operations only allowed when shard state is one of [POST_RECOVERY, STARTED, RELOCATED]]
	at org.elasticsearch.index.shard.IndexShard.readAllowed(IndexShard.java:974)
	at org.elasticsearch.index.shard.IndexShard.acquireSearcher(IndexShard.java:808)
	at org.elasticsearch.index.shard.IndexShard.docStats(IndexShard.java:628)
	at org.elasticsearch.action.admin.indices.stats.CommonStats.<init>(CommonStats.java:131)
	at org.elasticsearch.action.admin.indices.stats.TransportIndicesStatsAction.shardOperation(TransportIndicesStatsAction.java:165)
	at org.elasticsearch.action.admin.indices.stats.TransportIndicesStatsAction.shardOperation(TransportIndicesStatsAction.java:47)
	at org.elasticsearch.action.support.broadcast.node.TransportBroadcastByNodeAction$BroadcastByNodeTransportRequestHandler.onShardOperation(TransportBroadcastByNodeAction.java:401)
	... 7 more

```

Then I `curl -XGET http://localhost:9200/_cat/shards | grep carrier`:

```
carrier-2015.12.01 4 p STARTED 215337 120.8mb 127.0.0.1 crawler_service_001 
carrier-2015.12.01 4 r UNASSIGNED                                                
carrier-2015.12.01 2 p INITIALIZING 127.0.0.1 crawler_service_001 
carrier-2015.12.01 2 r UNASSIGNED                                                
carrier-2015.12.01 1 p STARTED 215626 120.8mb 127.0.0.1 crawler_service_001 
carrier-2015.12.01 1 r UNASSIGNED                                                
carrier-2015.12.01 3 p STARTED 212904 97.1mb 127.0.0.1 crawler_service_001 
carrier-2015.12.01 3 r UNASSIGNED                                                
carrier-2015.12.01 0 p STARTED 214469 120.8mb 127.0.0.1 crawler_service_001 
carrier-2015.12.01 0 r UNASSIGNED                       

```

So, what should I do now?

---

<div class="post-metadata">

### Author: ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)
#### Post date: [December 1, 2015, 9:44am UTC](https://discuss.elastic.co/t/action-admin-indices-stats-failed-to-execute-operation-for-shard/36010/2 "2015-12-01T09:44:09Z")

</div>

I guess you have to wait.  
Here we can see that shard 2 of your index is still `INITIALIZING`. So wait until it goes to `STARTED`.

You can have a look at pending tasks with the `_cat` API.

---

<div class="post-metadata">

### Author: ![niharvarma](https://avatars.discourse-cdn.com/v4/letter/n/3bc359/32.png) [@niharvarma](https://discuss.elastic.co/u/niharvarma)
#### Post date: [July 13, 2016, 6:06am UTC](https://discuss.elastic.co/t/action-admin-indices-stats-failed-to-execute-operation-for-shard/36010/3 "2016-07-13T06:06:38Z")

</div>

Hey hi i too ran into same issue and my output for  
curl -XGET [http://localhost:9200/\_cat/shards](http://localhost:9200/_cat/shards) | grep carrier:  
is as below.

{  
"cluster\_name" : "elasticsearch",  
"status" : "yellow",  
"timed\_out" : false,  
"number\_of\_nodes" : 1,  
"number\_of\_data\_nodes" : 1,  
"active\_primary\_shards" : 11,  
"active\_shards" : 11,  
"relocating\_shards" : 0,  
"initializing\_shards" : 0,  
"unassigned\_shards" : 11,  
"delayed\_unassigned\_shards" : 0,  
"number\_of\_pending\_tasks" : 0,  
"number\_of\_in\_flight\_fetch" : 0,  
"task\_max\_waiting\_in\_queue\_millis" : 0,  
"active\_shards\_percent\_as\_number" : 50.0  
}

---

<div class="post-metadata">

### Author: ![niharvarma](https://avatars.discourse-cdn.com/v4/letter/n/3bc359/32.png) [@niharvarma](https://discuss.elastic.co/u/niharvarma)
#### Post date: [July 13, 2016, 6:09am UTC](https://discuss.elastic.co/t/action-admin-indices-stats-failed-to-execute-operation-for-shard/36010/4 "2016-07-13T06:09:24Z")

</div>

And output for UNASSIGNED resulted me as below  
curl -XGET [http://localhost:9200/\_cat/shards](http://localhost:9200/_cat/shards) | grep UNASSIGNED | awk '{print $2}'  
% Total % Received % Xferd Average Speed Time Time Time Current  
Dload Upload Total Spent Left Speed  
100 1628 100 1628 0 0 63828 0 --:--:-- --:--:-- --:--:-- 65120  
0  
1  
3  
2  
4  
0  
1  
3  
2  
4  
0

---

<div class="post-metadata">

### Author: ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)
#### Post date: [July 13, 2016, 6:53am UTC](https://discuss.elastic.co/t/action-admin-indices-stats-failed-to-execute-operation-for-shard/36010/5 "2016-07-13T06:53:09Z")

</div>

You'd better open a new question.  
This thread is old.

Nothing looks bad here. What is your problem?

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [July 5, 2017, 10:36pm UTC](https://discuss.elastic.co/t/action-admin-indices-stats-failed-to-execute-operation-for-shard/36010/6 "2017-07-05T22:36:10Z")

</div>


