# "Action.search.shard\_count.limit exceeded" error in kibana

**URL:** <https://discuss.elastic.co/t/action-search-shard-count-limit-exceeded-error-in-kibana/72268>\
**Category:** Kibana\
**Created:** [January 20, 2017, 6:50am UTC](https://discuss.elastic.co/t/action-search-shard-count-limit-exceeded-error-in-kibana/72268 "2017-01-20T06:50:32Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![bini](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/bini/32/18360_2.png) [@bini](https://discuss.elastic.co/u/bini)\
**Post date:** [January 20, 2017, 6:50am UTC](https://discuss.elastic.co/t/action-search-shard-count-limit-exceeded-error-in-kibana/72268/1 "2017-01-20T06:50:32Z")

</div>

Hi,  
I am getting "Action.search.shard\_count.limit exceeded" whenever i am trying to load dashboard in kibana 5.1.1 . Kindly suggest the reason and solution for this. Thanks in advance. 🙂

---

<div class="post-metadata">

**Author:** ![tsullivan](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tsullivan/32/31077_2.png) [@tsullivan](https://discuss.elastic.co/u/tsullivan)\
**Post date:** [January 20, 2017, 10:09pm UTC](https://discuss.elastic.co/t/action-search-shard-count-limit-exceeded-error-in-kibana/72268/2 "2017-01-20T22:09:12Z")

</div>

This is mentioned in the changes doc for 5.0:

> Search shard limitedit  
> In 5.0, Elasticsearch rejects requests that would query more than 1000 shard copies (primaries or replicas). The reason is that such large numbers of shards make the job of the coordinating node very CPU and memory intensive. It is usually a better idea to organize data in such a way that there are fewer larger shards. In case you would like to bypass this limit, which is discouraged, you can update the action.search.shard\_count.limit cluster setting to a greater value.

[https://www.elastic.co/guide/en/elasticsearch/reference/current/breaking\_50\_search\_changes.html#\_search\_shard\_limit](https://www.elastic.co/guide/en/elasticsearch/reference/current/breaking_50_search_changes.html#_search_shard_limit)

---

<div class="post-metadata">

**Author:** ![bini](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/bini/32/18360_2.png) [@bini](https://discuss.elastic.co/u/bini)\
**Post date:** [January 25, 2017, 12:02pm UTC](https://discuss.elastic.co/t/action-search-shard-count-limit-exceeded-error-in-kibana/72268/3 "2017-01-25T12:02:33Z")

</div>

@tsullivan Thanks for the input. 🙂

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [February 22, 2017, 12:03pm UTC](https://discuss.elastic.co/t/action-search-shard-count-limit-exceeded-error-in-kibana/72268/4 "2017-02-22T12:03:30Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
