# Adding S3 bucket for snapshot

**URL:** <https://discuss.elastic.co/t/adding-s3-bucket-for-snapshot/110643>\
**Category:** Elasticsearch\
**Created:** [December 7, 2017, 9:38am UTC](https://discuss.elastic.co/t/adding-s3-bucket-for-snapshot/110643 "2017-12-07T09:38:28Z")\
**Posts on this page:** 20\
**Page:** 1

<div class="post-metadata">

**Author:** ![mudgilgaurav](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mudgilgaurav/32/25163_2.png) [@mudgilgaurav](https://discuss.elastic.co/u/mudgilgaurav)\
**Post date:** [December 7, 2017, 9:38am UTC](https://discuss.elastic.co/t/adding-s3-bucket-for-snapshot/110643/1 "2017-12-07T09:38:28Z")

</div>

I am trying to add S3 bucket for taking snapshot of my elastic cluster. I am running Elasticsearch 2.3.3 and installed plugin cloud-aws. Following is syntax of my request

curl -X POST "[http://XXX.XXX.XXX.XXX:9200/\_snapshot/s3\_repository](http://XXX.XXX.XXX.XXX:9200/_snapshot/s3_repository)" -d '{"type": "s3","settings":{"bucket":"bucketname","region":"ap-south-1","access\_key":"accesskey","secret\_key":"secretkey","endpoint":"[s3.ap-south-1.amazonaws.com](http://s3.ap-south-1.amazonaws.com)","compress":true}}'

it gives me following error

{"error":{"root\_cause":[{"type":"repository\_exception","reason":"[s3\_repository] failed to create repository"}],"type":"repository\_exception","reason":"[s3\_repository] failed to create repository","caused\_by":{"type":"creation\_exception","reason":"Guice creation errors:\n\n1) Error injecting constructor, com.amazonaws.AmazonClientException: Unable to execute HTTP request: [bucketname.s3.ap-south-1.amazonaws.com](http://bucketname.s3.ap-south-1.amazonaws.com)\n at org.elasticsearch.repositories.s3.S3Repository.(Unknown Source)\n while locating org.elasticsearch.repositories.s3.S3Repository\n while locating org.elasticsearch.repositories.Repository\n\n1 error","caused\_by":{"type":"amazon\_client\_exception","reason":"Unable to execute HTTP request: [bucketname.s3.ap-south-1.amazonaws.com](http://bucketname.s3.ap-south-1.amazonaws.com)","caused\_by":{"type":"unknown\_host\_exception","reason":"[bucketname.s3.ap-south-1.amazonaws.com](http://bucketname.s3.ap-south-1.amazonaws.com)"}}}},"status":500}

---

<div class="post-metadata">

**Author:** ![mujtabahussain](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mujtabahussain/32/17514_2.png) [@mujtabahussain](https://discuss.elastic.co/u/mujtabahussain)\
**Post date:** [December 7, 2017, 11:49am UTC](https://discuss.elastic.co/t/adding-s3-bucket-for-snapshot/110643/2 "2017-12-07T11:49:21Z")

</div>

If you are registering a snapshot, then it's a `PUT`, not a `POST`. I think  
[this document](https://www.elastic.co/guide/en/elasticsearch/reference/2.3/modules-snapshots.html) explains it well.

---

<div class="post-metadata">

**Author:** ![mudgilgaurav](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mudgilgaurav/32/25163_2.png) [@mudgilgaurav](https://discuss.elastic.co/u/mudgilgaurav)\
**Post date:** [December 7, 2017, 12:19pm UTC](https://discuss.elastic.co/t/adding-s3-bucket-for-snapshot/110643/3 "2017-12-07T12:19:10Z")

</div>

Thanks for response , tried with PUT but getting same exception/error.

---

<div class="post-metadata">

**Author:** ![venkat545](https://avatars.discourse-cdn.com/v4/letter/v/f1d935/32.png) [@venkat545](https://discuss.elastic.co/u/venkat545)\
**Post date:** [December 7, 2017, 12:26pm UTC](https://discuss.elastic.co/t/adding-s3-bucket-for-snapshot/110643/4 "2017-12-07T12:26:50Z")

</div>

Hi gaurav...i am new to kibana..plz can u provide links about aggregations..i dont understand where should i load json file..i dont know how to generate the charts by passing the aggregations i am looking this url but i dont understand how to implement..[https://www.elastic.co/guide/en/elasticsearch/guide/current/\_returning\_empty\_buckets.html](https://www.elastic.co/guide/en/elasticsearch/guide/current/_returning_empty_buckets.html) ..can u help me

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [December 7, 2017, 12:42pm UTC](https://discuss.elastic.co/t/adding-s3-bucket-for-snapshot/110643/5 "2017-12-07T12:42:48Z")

</div>

@venkat545 don’t hijack threads like this and open your own questions. Your answer is totally unrelated.

---

<div class="post-metadata">

**Author:** ![mudgilgaurav](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mudgilgaurav/32/25163_2.png) [@mudgilgaurav](https://discuss.elastic.co/u/mudgilgaurav)\
**Post date:** [December 7, 2017, 1:07pm UTC](https://discuss.elastic.co/t/adding-s3-bucket-for-snapshot/110643/6 "2017-12-07T13:07:29Z")

</div>

@dadoonet Please help to resolve the issue , have gone through documentation and did not found any solution to my problem.

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [December 7, 2017, 4:09pm UTC](https://discuss.elastic.co/t/adding-s3-bucket-for-snapshot/110643/7 "2017-12-07T16:09:45Z")

</div>

@mudgilgaurav please read [this](https://discuss.elastic.co/t/about-the-elasticsearch-category/21) and specifically the "Also be patient" part.

Do you have a more detailed stack-trace in your logs?

Judging from the error it seems that `http://bucketname.s3.ap-south-1.amazonaws.com/` does not exist. Did you create it?

Also, in this old version, if you define the `region` you don't need to define the `endpoint`.  
In 6.0 you need to define the `endpoint` only as region has been removed.

Any chance you can also upgrade? At least to latest 2.4?

---

<div class="post-metadata">

**Author:** ![mujtabahussain](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mujtabahussain/32/17514_2.png) [@mujtabahussain](https://discuss.elastic.co/u/mujtabahussain)\
**Post date:** [December 8, 2017, 1:06am UTC](https://discuss.elastic.co/t/adding-s3-bucket-for-snapshot/110643/8 "2017-12-08T01:06:57Z")

</div>

- Does the bucket exist?
- Does the machine from where you are running the snapshot have adequate permissions to write to the bucket?

---

<div class="post-metadata">

**Author:** ![mudgilgaurav](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mudgilgaurav/32/25163_2.png) [@mudgilgaurav](https://discuss.elastic.co/u/mudgilgaurav)\
**Post date:** [December 8, 2017, 5:16am UTC](https://discuss.elastic.co/t/adding-s3-bucket-for-snapshot/110643/9 "2017-12-08T05:16:13Z")

</div>

@dadoonet Yes this bucket exists. I created the bucket and did not modified any permission on it by default bucket admin can perform any operation. Access key and secret used for admin user only.

I tried with region only but got following error

{"error":{"root\_cause":[{"type":"repository\_exception","reason":"[s3\_repository] failed to create repository"}],"type":"repository\_exception","reason":"[s3\_repository] failed to create repository","caused\_by":{"type":"creation\_exception","reason":"Guice creation errors:\n\n1) Error injecting constructor, java.lang.IllegalArgumentException: No automatic endpoint could be derived from region [ap-south-1]\n at org.elasticsearch.repositories.s3.S3Repository.(Unknown Source)\n while locating org.elasticsearch.repositories.s3.S3Repository\n while locating org.elasticsearch.repositories.Repository\n\n1 error","caused\_by":{"type":"illegal\_argument\_exception","reason":"No automatic endpoint could be derived from region [ap-south-1]"}}},"status":500}

Currently we are migration our application to AWS so wants to do only lift and shift , version upgrade can be done once we are migrated to AWS.

---

<div class="post-metadata">

**Author:** ![mujtabahussain](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mujtabahussain/32/17514_2.png) [@mujtabahussain](https://discuss.elastic.co/u/mujtabahussain)\
**Post date:** [December 8, 2017, 5:24am UTC](https://discuss.elastic.co/t/adding-s3-bucket-for-snapshot/110643/10 "2017-12-08T05:24:03Z")

</div>

@[mudgilgaurav](https://discuss.elastic.co/u/mudgilgaurav)

> [@](#):
>
> ap-south-1

I don't think thats a region. Its either `ap-southeast-1` or `ap-southeast-2` ...

---

<div class="post-metadata">

**Author:** ![mujtabahussain](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mujtabahussain/32/17514_2.png) [@mujtabahussain](https://discuss.elastic.co/u/mujtabahussain)\
**Post date:** [December 8, 2017, 5:30am UTC](https://discuss.elastic.co/t/adding-s3-bucket-for-snapshot/110643/11 "2017-12-08T05:30:27Z")

</div>

Actually, my bad. That is a region! ☹ Mumbai!

---

<div class="post-metadata">

**Author:** ![mudgilgaurav](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mudgilgaurav/32/25163_2.png) [@mudgilgaurav](https://discuss.elastic.co/u/mudgilgaurav)\
**Post date:** [December 8, 2017, 6:21am UTC](https://discuss.elastic.co/t/adding-s3-bucket-for-snapshot/110643/12 "2017-12-08T06:21:09Z")

</div>

@dadoonet I configured aws-cli on my local server and configured my credentials. I am able to list all buckets created by me. While during adding s3 repository to elasticsearch still getting same error what is posted initially.

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [December 8, 2017, 8:32am UTC](https://discuss.elastic.co/t/adding-s3-bucket-for-snapshot/110643/13 "2017-12-08T08:32:08Z")

</div>

This error `No automatic endpoint could be derived from region [ap-south-1]` is because you are using an old version.  
But anyway, remove the `region` field entirely and only use the `endpoint`.

> I configured aws-cli on my local server and configured my credentials. I am able to list all buckets created by me.

Great. Can you do the same thing from the server where elasticsearch is running?

> Currently we are migration our application to AWS so wants to do only lift and shift , version upgrade can be done once we are migrated to AWS.

Just a note about this in case you'd like to simplify your management of your elastic platform, just use [cloud.elastic.co](http://cloud.elastic.co). You'll get so many included features like X-Pack, Kibana, Automatic backups, Network Bandwidth usage included...

---

<div class="post-metadata">

**Author:** ![mudgilgaurav](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mudgilgaurav/32/25163_2.png) [@mudgilgaurav](https://discuss.elastic.co/u/mudgilgaurav)\
**Post date:** [December 8, 2017, 9:00am UTC](https://discuss.elastic.co/t/adding-s3-bucket-for-snapshot/110643/14 "2017-12-08T09:00:35Z")

</div>

> [@dadoonet](#):
>
> Can you do the same thing from the server where elasticsearch is running?

Yes I can do it from server where elasticsearch is running.

Yes [cloud.elastic.co](http://cloud.elastic.co) could be good option , we will explore AWS elasticsearch vs [cloud.elastic.co](http://cloud.elastic.co) post migration to AWS.

Is my endpoint correct i.e [bucketname.s3.ap-south-1.amazonaws.com](http://bucketname.s3.ap-south-1.amazonaws.com)??

Is my endpoint correct i.e .s3.ap-south-1.amazonaws.com??

If i am able to access my bucket from elasticsearch server then I do not know why still getting unknown host error.

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [December 8, 2017, 12:16pm UTC](https://discuss.elastic.co/t/adding-s3-bucket-for-snapshot/110643/15 "2017-12-08T12:16:57Z")

</div>

> Is my endpoint correct i.e .s3.ap-south-1.amazonaws.com

The correct endpoint should be `s3.ap-south-1.amazonaws.com`.

> If i am able to access my bucket from elasticsearch server then I do not know why still getting unknown host error.

Could you change the log level for `org.elasticsearch.cloud.aws` to `DEBUG`?

---

<div class="post-metadata">

**Author:** ![mudgilgaurav](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mudgilgaurav/32/25163_2.png) [@mudgilgaurav](https://discuss.elastic.co/u/mudgilgaurav)\
**Post date:** [December 8, 2017, 1:21pm UTC](https://discuss.elastic.co/t/adding-s3-bucket-for-snapshot/110643/16 "2017-12-08T13:21:58Z")

</div>

> [@dadoonet](#):
>
> org.elasticsearch.cloud.aws

My endpoint is correct.

For changing the log level of org.elasticsearch.cloud.aws to debug do i need to update and redeploy plugins/cloud-aws/commons-logging-1.1.3.jar or I can do it through elasticsearch.yml?

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [December 8, 2017, 1:44pm UTC](https://discuss.elastic.co/t/adding-s3-bucket-for-snapshot/110643/17 "2017-12-08T13:44:58Z")

</div>

You can change it live. See [https://www.elastic.co/guide/en/elasticsearch/reference/2.3/misc-cluster.html#cluster-logger](https://www.elastic.co/guide/en/elasticsearch/reference/2.3/misc-cluster.html#cluster-logger)

---

<div class="post-metadata">

**Author:** ![mudgilgaurav](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mudgilgaurav/32/25163_2.png) [@mudgilgaurav](https://discuss.elastic.co/u/mudgilgaurav)\
**Post date:** [December 9, 2017, 2:31pm UTC](https://discuss.elastic.co/t/adding-s3-bucket-for-snapshot/110643/18 "2017-12-09T14:31:20Z")

</div>

> [@dadoonet](#):
>
> org.elasticsearch.cloud.aws

@dadoonet I enabled the suggested log level , please fine elasticsearch log below

[2017-12-09 19:57:57,474][WARN][rest.suppressed] /\_snapshot/s3\_repository Params: {repository=s3\_repository}

RepositoryException[[s3\_repository] failed to create repository]; nested: CreationException[Guice creation errors:

1. Error injecting constructor, com.amazonaws.AmazonClientException: Unable to execute HTTP request: [bucketname-snapshot.s3.ap-south-1.amazonaws.com](http://bucketname-snapshot.s3.ap-south-1.amazonaws.com)

at org.elasticsearch.repositories.s3.S3Repository.(Unknown Source)

while locating org.elasticsearch.repositories.s3.S3Repository

while locating org.elasticsearch.repositories.Repository

1 error]; nested: AmazonClientException[Unable to execute HTTP request: [bucketname-snapshot.s3.ap-south-1.amazonaws.com](http://bucketname-snapshot.s3.ap-south-1.amazonaws.com)]; nested: UnknownHostException[[bucketname-snapshot.s3.ap-south-1.amazonaws.com](http://bucketname-snapshot.s3.ap-south-1.amazonaws.com)];

```
at org.elasticsearch.repositories.RepositoriesService.createRepositoryHolder(RepositoriesService.java:411)

```

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [December 9, 2017, 2:58pm UTC](https://discuss.elastic.co/t/adding-s3-bucket-for-snapshot/110643/19 "2017-12-09T14:58:21Z")

</div>

I'm expecting more logs than that. Could you share all the logs?  
How many nodes do you have? If more than one, could you check in the other machines?

And please format your logs with the `</>`. The preview window will tell you when it's correct or not.

---

<div class="post-metadata">

**Author:** ![mudgilgaurav](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mudgilgaurav/32/25163_2.png) [@mudgilgaurav](https://discuss.elastic.co/u/mudgilgaurav)\
**Post date:** [December 9, 2017, 5:03pm UTC](https://discuss.elastic.co/t/adding-s3-bucket-for-snapshot/110643/20 "2017-12-09T17:03:17Z")

</div>

1. Error injecting constructor, com.amazonaws.AmazonClientException: Unable to execute  
HTTP request: [b-snapshot.s3.ap-south-1.amazonaws.com](http://b-snapshot.s3.ap-south-1.amazonaws.com)  
at org.elasticsearch.repositories.s3.S3Repository.(Unknown Source)  
while locating org.elasticsearch.repositories.s3.S3Repository  
while locating org.elasticsearch.repositories.Repository  
1 error]; nested: AmazonClientException[Unable to execute HTTP request: b-  
[snapshot.s3.ap-south-1.amazonaws.com](http://snapshot.s3.ap-south-1.amazonaws.com)]; nested: UnknownHostException[b- [snapshot.s3.ap-south-1.amazonaws.com](http://snapshot.s3.ap-south-1.amazonaws.com)]; at  
org.elasticsearch.repositories.RepositoriesService.createRepositoryHolder(RepositoriesService.java:411)  
atorg.elasticsearch.repositories.RepositoriesService.registerRepository(RepositoriesService.java:368)  
at org.elasticsearch.repositories.RepositoriesService.access$100(RepositoriesService.java:55)  
at org.elasticsearch.repositories.RepositoriesService$1.execute(RepositoriesService.java:110)  
atorg.elasticsearch.cluster.ClusterStateUpdateTask.execute(ClusterStateUpdateTask.java:45) at org.elasticsearch.cluster.service.InternalClusterService.runTasksForExecutor(InternalClusterService.java:468) at org.elasticsearch.cluster.service.InternalClusterService$UpdateTask.run(InternalClusterService.java:772)at org.elasticsearch.common.util.concurrent.PrioritizedEsThreadPoolExecutor$TieBreakingPrioritizedRunnable.runAndClean(PrioritizedEsThreadPoolExecutor.java:231) at org.elas ticsearch.common.util.concurrent.PrioritizedEsThreadPoolExecutor$TieBreakingPrioritizedRunnable.run(PrioritizedEsThreadPoolExecutor.java:194)  
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)  
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)  
at java.lang.Thread.run(Thread.java:748) Caused by: org.elasticsearch.common.inject.CreationException: Guice creation errors:
  1. Error injecting constructor, com.amazonaws.AmazonClientException: Unable to execute HTTP request: [b-snapshot.s3.ap-south-1.amazonaws.com](http://b-snapshot.s3.ap-south-1.amazonaws.com) at org.elasticsearch.repositories.s3.S3Repository.(Unknown Source)  
while locating org.elasticsearch.repositories.s3.S3Repository  
while locating org.elasticsearch.repositories.Repository  
1 error at org.elasticsearch.common.inject.internal.Errors.throwCreationExceptionIfErrorsExist(Errors.java:360) at org.elasticsearch.common.inject.InjectorBuilder.injectDynamically(InjectorBuilder.java:178)  
at org.elasticsearch.common.inject.InjectorBuilder.build(InjectorBuilder.java:110)  
at org.elasticsearch.common.inject.InjectorImpl.createChildInjector(InjectorImpl.java:157)  
at org.elasticsearch.common.inject.ModulesBuilder.createChildInjector(ModulesBuilder.java:55)  
at org.elasticsearch.repositories.RepositoriesService.createRepositoryHolder(RepositoriesService.java:404)  
... 11 more  
Caused by: com.amazonaws.AmazonClientException: Unable to execute HTTP request: [91review-snapshot.s3.ap-south-1.amazonaws.com](http://91review-snapshot.s3.ap-south-1.amazonaws.com)  
at com.amazonaws.http.AmazonHttpClient.executeHelper(AmazonHttpClient.java:517)  
at com.amazonaws.http.AmazonHttpClient.execute(AmazonHttpClient.java:318)  
at com.amazonaws.services.s3.AmazonS3Client.invoke(AmazonS3Client.java:3595)  
at com.amazonaws.services.s3.AmazonS3Client.headBucket(AmazonS3Client.java:1041)  
at com.amazonaws.services.s3.AmazonS3Client.doesBucketExist(AmazonS3Client.java:1013)  
at org.elasticsearch.cloud.aws.blobstore.S3BlobStore.(S3BlobStore.java:84)  
at org.elasticsearch.repositories.s3.S3Repository.(S3Repository.java:132)  
at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)  
at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:62)  
at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)  
at java.lang.reflect.Constructor.newInstance(Constructor.java:423)  
at org.elasticsearch.common.inject.DefaultConstructionProxyFactory$1.newInstance(DefaultConstructionProxyFactory.java:50)  
at org.elasticsearch.common.inject.ConstructorInjector.construct(ConstructorInjector.java:86)  
at org.elasticsearch.common.inject.ConstructorBindingImpl$Factory.get(ConstructorBindingImpl.java:104)  
at org.elasticsearch.common.inject.FactoryProxy.get(FactoryProxy.java:54)  
at org.elasticsearch.common.inject.ProviderToInternalFactoryAdapter$1.call(ProviderToInternalFactoryAdapter.java:47)  
at org.elasticsearch.common.inject.InjectorImpl.callInContext(InjectorImpl.java:886)  
at org.elasticsearch.common.inject.ProviderToInternalFactoryAdapter.get(ProviderToInternalFactoryAdapter.java:43)  
at org.elasticsearch.common.inject.Scopes$1$1.get(Scopes.java:59)  
at org.elasticsearch.common.inject.InternalFactoryToProviderAdapter.get(InternalFactoryToProviderAdapter.java:46)  
at org.elasticsearch.common.inject.InjectorBuilder$1.call(InjectorBuilder.java:201)  
at org.elasticsearch.common.inject.InjectorBuilder$1.call(InjectorBuilder.java:193)  
at org.elasticsearch.common.inject.InjectorImpl.callInContext(InjectorImpl.java:879)  
at org.elasticsearch.common.inject.InjectorBuilder.loadEagerSingletons(InjectorBuilder.java:193) at org.elasticsearch.common.inject.InjectorBuilder.injectDynamically(InjectorBuilder.java:175)  
... 15 more  
Caused by: java.net.UnknownHostException: 91review-snapshot.s3.ap-south-  
[1.amazonaws.com](http://1.amazonaws.com)  
at java.net.InetAddress.getAllByName0(InetAddress.java:1280)  
at java.net.InetAddress.getAllByName(InetAddress.java:1192)  
at java.net.InetAddress.getAllByName(InetAddress.java:1126)  
at com.amazonaws.SystemDefaultDnsResolver.resolve(SystemDefaultDnsResolver.java:27)  
at com.amazonaws.http.DelegatingDnsResolver.resolve(DelegatingDnsResolver.java:38) atorg.apache.http.impl.conn.DefaultClientConnectionOperator.resolveHostname(DefaultClientConnectionOperator.java:259) at org.apache.http.impl.conn.DefaultClientConnectionOperator.openConnection(DefaultClientConnectionOperator.java:159) at org.apache.http.impl.conn.ManagedClientConnectionImpl.open(ManagedClientConnectionImpl.java:304) at org.apache.http.impl.client.DefaultRequestDirector.tryConnect(DefaultRequestDirector.java:611) at org.apache.http.impl.client.DefaultRequestDirector.execute(DefaultRequestDirector.java:446) . at org.apache.http.impl.client.AbstractHttpClient.doExecute(AbstractHttpClient.java:863)  
at org.apache.http.impl.client.CloseableHttpClient.execute(CloseableHttpClient.java:82)  
at org.apache.http.impl.client.CloseableHttpClient.execute(CloseableHttpClient.java:57)  
at com.amazonaws.http.AmazonHttpClient.executeOneRequest(AmazonHttpClient.java:769)  
at com.amazonaws.http.AmazonHttpClient.executeHelper(AmazonHttpClient.java:506)  
... 39 more

[Next page](https://discuss.elastic.co/t/adding-s3-bucket-for-snapshot/110643.md?page=2)
