# After changing port number in Elasticsearch.yml file its get Failed to start Elasticsearch

**URL:** <https://discuss.elastic.co/t/after-changing-port-number-in-elasticsearch-yml-file-its-get-failed-to-start-elasticsearch/227115>\
**Category:** Elasticsearch\
**Created:** [April 8, 2020, 11:42am UTC](https://discuss.elastic.co/t/after-changing-port-number-in-elasticsearch-yml-file-its-get-failed-to-start-elasticsearch/227115 "2020-04-08T11:42:53Z")\
**Posts on this page:** 1\
**Showing post:** 15

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [April 14, 2020, 3:57pm UTC](https://discuss.elastic.co/t/after-changing-port-number-in-elasticsearch-yml-file-its-get-failed-to-start-elasticsearch/227115/15 "2020-04-14T15:57:37Z")

</div>

Sounds like you changed the transport port to 9400.  
So you might have to change this

```
spring.data.elasticsearch.cluster-nodes=${ELASTICSEARCH_HOST}:9300

```

to

```
spring.data.elasticsearch.cluster-nodes=${ELASTICSEARCH_HOST}:9400
```

---

_[View the full topic](https://discuss.elastic.co/t/after-changing-port-number-in-elasticsearch-yml-file-its-get-failed-to-start-elasticsearch/227115)._
