# After changing the server ip address , Kibana does not work

**URL:** <https://discuss.elastic.co/t/after-changing-the-server-ip-address-kibana-does-not-work/265840>\
**Category:** Kibana\
**Created:** [March 1, 2021, 6:24pm UTC](https://discuss.elastic.co/t/after-changing-the-server-ip-address-kibana-does-not-work/265840 "2021-03-01T18:24:29Z")\
**Posts on this page:** 11\
**Page:** 1

<div class="post-metadata">

**Author:** ![John\_biryon](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/john_biryon/32/84747_2.png) [@John\_biryon](https://discuss.elastic.co/u/John_biryon)\
**Post date:** [March 1, 2021, 6:24pm UTC](https://discuss.elastic.co/t/after-changing-the-server-ip-address-kibana-does-not-work/265840/1 "2021-03-01T18:24:29Z")

</div>

Where do i go about to update the Kibana for the new IP address ?  
the ip address of the server had to be changed .  
Microsoft Windows 2012 r2, was working nicly before the change.

many thanks  
John

---

<div class="post-metadata">

**Author:** ![aaron-nimocks](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/aaron-nimocks/32/73965_2.png) [@aaron-nimocks](https://discuss.elastic.co/u/aaron-nimocks)\
**Post date:** [March 1, 2021, 7:49pm UTC](https://discuss.elastic.co/t/after-changing-the-server-ip-address-kibana-does-not-work/265840/2 "2021-03-01T19:49:27Z")

</div>

The `server.host` setting in [kibana.yml](https://www.elastic.co/guide/en/kibana/current/settings.html) should do the trick.

---

<div class="post-metadata">

**Author:** ![John\_biryon](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/john_biryon/32/84747_2.png) [@John\_biryon](https://discuss.elastic.co/u/John_biryon)\
**Post date:** [March 2, 2021, 5:31am UTC](https://discuss.elastic.co/t/after-changing-the-server-ip-address-kibana-does-not-work/265840/3 "2021-03-02T05:31:48Z")

</div>

where else do i need to check ,  
i still get lots of No living connections warnings messages and Not Ready yet from the web server. i also have restarted the machine.  
any help will be greatly appriciated.

---

<div class="post-metadata">

**Author:** ![aaron-nimocks](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/aaron-nimocks/32/73965_2.png) [@aaron-nimocks](https://discuss.elastic.co/u/aaron-nimocks)\
**Post date:** [March 2, 2021, 11:15am UTC](https://discuss.elastic.co/t/after-changing-the-server-ip-address-kibana-does-not-work/265840/4 "2021-03-02T11:15:55Z")

</div>

Might need to see your kibana.yml and your logs in order to see what else could be going on.

---

<div class="post-metadata">

**Author:** ![John\_biryon](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/john_biryon/32/84747_2.png) [@John\_biryon](https://discuss.elastic.co/u/John_biryon)\
**Post date:** [March 2, 2021, 1:14pm UTC](https://discuss.elastic.co/t/after-changing-the-server-ip-address-kibana-does-not-work/265840/5 "2021-03-02T13:14:31Z")

</div>

Where would be the default location for the logs , thanks

בתאריך יום ג׳, 2 במרץ 2021, 13:25, מאת Aaron Nimocks via Discuss the Elastic Stack ‏\<[elastic@discoursemail.com](mailto:elastic@discoursemail.com)\>:

---

<div class="post-metadata">

**Author:** ![aaron-nimocks](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/aaron-nimocks/32/73965_2.png) [@aaron-nimocks](https://discuss.elastic.co/u/aaron-nimocks)\
**Post date:** [March 2, 2021, 2:01pm UTC](https://discuss.elastic.co/t/after-changing-the-server-ip-address-kibana-does-not-work/265840/6 "2021-03-02T14:01:15Z")

</div>

It depends on OS and config so the easiest way is just start Kibana via command line and copy the output.

---

<div class="post-metadata">

**Author:** ![John\_biryon](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/john_biryon/32/84747_2.png) [@John\_biryon](https://discuss.elastic.co/u/John_biryon)\
**Post date:** [March 15, 2021, 8:48am UTC](https://discuss.elastic.co/t/after-changing-the-server-ip-address-kibana-does-not-work/265840/7 "2021-03-15T08:48:35Z")

</div>

here is the execution log ,  
sorry for the delay in my answer

i think its has got to do something with wrongly looking for 127.0.0.1 rather then the binded new IP address , but i don't know where to look for this.

> Blockquote  
> log [05:45:15.126] [info][plugins-service] Plugin "case" is disabled.  
> log [05:45:25.698] [warning][config][deprecation] Setting [elasticsearch.use  
> rname] to "elastic" is deprecated. You should use the "kibana" user instead.  
> log [05:45:25.700] [warning][config][deprecation] Setting [xpack.monitoring.  
> elasticsearch.username] to "elastic" is deprecated. You should use the "kibana"  
> user instead.  
> log [05:45:25.818] [info][plugins-system] Setting up [37] plugins: [taskMana  
> ger,siem,licensing,infra,encryptedSavedObjects,code,usageCollection,metrics,canv  
> as,timelion,features,security,apm\_oss,translations,reporting,uiActions,data,navi  
> gation,status\_page,newsfeed,share,inspector,expressions,visualizations,embeddabl  
> e,advancedUiActions,dashboard\_embeddable\_container,home,spaces,cloud,apm,graph,k  
> ibana\_legacy,management,dev\_tools,eui\_utils,bfetch]  
> log [05:45:25.820] [info][plugins][taskManager] Setting up plugin  
> log [05:45:25.845] [info][plugins][siem] Setting up plugin  
> log [05:45:25.847] [info][licensing][plugins] Setting up plugin  
> log [05:45:25.852] [info][infra][plugins] Setting up plugin  
> log [05:45:25.854] [info][encryptedSavedObjects][plugins] Setting up plugin  
> log [05:45:25.855] [warning][config][encryptedSavedObjects][plugins] Generat  
> ing a random key for xpack.encryptedSavedObjects.encryptionKey. To be able to de  
> crypt encrypted saved objects attributes after restart, please set xpack.encrypt  
> edSavedObjects.encryptionKey in kibana.yml  
> log [05:45:25.864] [info][code][plugins] Setting up plugin  
> log [05:45:25.866] [info][plugins][usageCollection] Setting up plugin  
> log [05:45:25.869] [info][metrics][plugins] Setting up plugin  
> log [05:45:25.871] [info][canvas][plugins] Setting up plugin  
> log [05:45:25.882] [info][plugins][timelion] Setting up plugin  
> log [05:45:25.885] [info][features][plugins] Setting up plugin  
> log [05:45:25.887] [info][plugins][security] Setting up plugin  
> log [05:45:25.890] [warning][config][plugins][security] Generating a random  
> key for xpack.security.encryptionKey. To prevent sessions from being invalidated  
> on restart, please set xpack.security.encryptionKey in kibana.yml  
> log [05:45:25.892] [warning][config][plugins][security] Session cookies will  
> be transmitted over insecure connections. This is not recommended.  
> log [05:45:25.930] [info][apm\_oss][plugins] Setting up plugin  
> log [05:45:25.931] [info][plugins][translations] Setting up plugin  
> log [05:45:25.933] [info][data][plugins] Setting up plugin  
> log [05:45:25.941] [info][plugins][share] Setting up plugin  
> log [05:45:25.944] [info][home][plugins] Setting up plugin  
> log [05:45:25.956] [info][plugins][spaces] Setting up plugin  
> log [05:45:25.965] [info][cloud][plugins] Setting up plugin  
> log [05:45:25.968] [info][apm][plugins] Setting up plugin  
> log [05:45:25.977] [info][graph][plugins] Setting up plugin  
> log [05:45:25.983] [info][bfetch][plugins] Setting up plugin  
> log [05:45:25.992] [info][savedobjects-service] Waiting until all Elasticsea  
> rch nodes are compatible with Kibana before starting saved objects migrations...

log [05:45:27.036] [error][data][elasticsearch] Request error, retrying  
HEAD [http://localhost:9200/.apm-agent-configuration](http://localhost:9200/.apm-agent-configuration) =\> connect ECONNREFUSED 127.  
0.0.1:9200  
log [05:45:27.042] [error][admin][elasticsearch] Request error, retrying  
GET [http://localhost:9200/\_nodes?filter\_path=nodes.\*.version%2Cnodes.\*.http.publ](http://localhost:9200/_nodes?filter_path=nodes.*.version%2Cnodes.*.http.publ)  
ish\_address%2Cnodes.\*.ip =\> connect ECONNREFUSED 127.0.0.1:9200  
log [05:45:27.046] [error][data][elasticsearch] Request error, retrying  
GET [http://localhost:9200/\_xpack](http://localhost:9200/_xpack) =\> connect ECONNREFUSED 127.0.0.1:9200  
log [05:45:28.078] [warning][data][elasticsearch] Unable to revive connectio  
n: [http://localhost:9200/](http://localhost:9200/)  
log [05:45:28.080] [warning][data][elasticsearch] No living connections  
Could not create APM Agent configuration: No Living connections  
log [05:45:28.083] [warning][admin][elasticsearch] Unable to revive connecti  
on: [http://localhost:9200/](http://localhost:9200/)  
log [05:45:28.085] [warning][admin][elasticsearch] No living connections  
log [05:45:28.087] [error][elasticsearch-service] Unable to retrieve version  
information from Elasticsearch nodes.  
log [05:45:28.089] [warning][data][elasticsearch] Unable to revive connectio  
n: [http://localhost:9200/](http://localhost:9200/)  
log [05:45:28.091] [warning][data][elasticsearch] No living connections  
log [05:45:28.092] [warning][licensing][plugins] License information could n  
ot be obtained from Elasticsearch due to Error: No Living connections error  
log [05:45:29.546] [warning][admin][elasticsearch] Unable to revive connecti  
on: [http://localhost:9200/](http://localhost:9200/)  
log [05:45:29.547] [warning][admin][elasticsearch] No living connections  
log [05:45:32.059] [warning][admin][elasticsearch] Unable to revive connecti  
on: [http://localhost:9200/](http://localhost:9200/)  
log [05:45:32.061] [warning][admin][elasticsearch] No living connections  
log [05:45:34.531] [warning][admin][elasticsearch] Unable to revive connecti  
on: [http://localhost:9200/](http://localhost:9200/)  
log [05:45:34.533] [warning][admin][elasticsearch] No living connections  
log [05:45:37.062] [warning][admin][elasticsearch] Unable to revive connecti  
on: [http://localhost:9200/](http://localhost:9200/)  
log [05:45:37.064] [warning][admin][elasticsearch] No living connections  
log [05:45:39.561] [warning][admin][elasticsearch] Unable to revive connecti  
on: [http://localhost:9200/](http://localhost:9200/)  
log [05:45:39.562] [warning][admin][elasticsearch] No living connections  
log [05:45:42.063] [warning][admin][elasticsearch] Unable to revive connecti  
on: [http://localhost:9200/](http://localhost:9200/)  
log [05:45:42.065] [warning][admin][elasticsearch] No living connections  
log [05:45:44.547] [warning][admin][elasticsearch] Unable to revive connecti  
on: [http://localhost:9200/](http://localhost:9200/)  
log [05:45:44.549] [warning][admin][elasticsearch] No living connections  
log [05:45:47.081] [warning][admin][elasticsearch] Unable to revive connecti  
on: [http://localhost:9200/](http://localhost:9200/)  
log [05:45:47.082] [warning][admin][elasticsearch] No living connections  
log [05:45:49.573] [warning][admin][elasticsearch] Unable to revive connecti  
on: [http://localhost:9200/](http://localhost:9200/)  
log [05:45:49.574] [warning][admin][elasticsearch] No living connections  
log [05:45:52.104] [warning][admin][elasticsearch] Unable to revive connecti  
on: [http://localhost:9200/](http://localhost:9200/)  
log [05:45:52.106] [warning][admin][elasticsearch] No living connections  
log [05:45:54.588] [warning][admin][elasticsearch] Unable to revive connecti  
on: [http://localhost:9200/](http://localhost:9200/)  
log [05:45:54.590] [warning][admin][elasticsearch] No living connections  
log [05:45:57.134] [warning][data][elasticsearch] Unable to revive connectio  
n: [http://localhost:9200/](http://localhost:9200/)  
log [05:45:57.136] [warning][data][elasticsearch] No living connections  
log [05:45:57.137] [warning][licensing][plugins] License information could n  
ot be obtained from Elasticsearch due to Error: No Living connections error  
log [05:45:57.138] [warning][admin][elasticsearch] Unable to revive connecti  
on: [http://localhost:9200/](http://localhost:9200/)  
log [05:45:57.139] [warning][admin][elasticsearch] No living connections  
log [05:45:59.635] [warning][admin][elasticsearch] Unable to revive connecti  
on: [http://localhost:9200/](http://localhost:9200/)  
log [05:45:59.640] [warning][admin][elasticsearch] No living connections  
log [05:46:02.120] [warning][admin][elasticsearch] Unable to revive connecti  
on: [http://localhost:9200/](http://localhost:9200/)  
log [05:46:02.126] [warning][admin][elasticsearch] No living connections  
log [05:46:04.644] [warning][admin][elasticsearch] Unable to revive connecti  
on: [http://localhost:9200/](http://localhost:9200/)  
log [05:46:04.647] [warning][admin][elasticsearch] No living connections  
log [05:46:07.144] [warning][admin][elasticsearch] Unable to revive connecti  
on: [http://localhost:9200/](http://localhost:9200/)  
log [05:46:07.146] [warning][admin][elasticsearch] No living connections  
log [05:46:09.648] [warning][admin][elasticsearch] Unable to revive connecti  
on: [http://localhost:9200/](http://localhost:9200/)  
log [05:46:09.650] [warning][admin][elasticsearch] No living connections  
log [05:46:12.164] [warning][admin][elasticsearch] Unable to revive connecti  
on: [http://localhost:9200/](http://localhost:9200/)  
log [05:46:12.166] [warning][admin][elasticsearch] No living connections  
log [05:46:14.649] [warning][admin][elasticsearch] Unable to revive connecti  
on: [http://localhost:9200/](http://localhost:9200/)  
log [05:46:14.651] [warning][admin][elasticsearch] No living connections  
log [05:46:17.211] [warning][admin][elasticsearch] Unable to revive connecti  
on: [http://localhost:9200/](http://localhost:9200/)  
log [05:46:17.213] [warning][admin][elasticsearch] No living connections  
log [05:46:19.678] [warning][admin][elasticsearch] Unable to revive connecti  
on: [http://localhost:9200/](http://localhost:9200/)  
log [05:46:19.680] [warning][admin][elasticsearch] No living connections  
log [05:46:22.164] [warning][admin][elasticsearch] Unable to revive connecti  
on: [http://localhost:9200/](http://localhost:9200/)  
log [05:46:22.166] [warning][admin][elasticsearch] No living connections  
log [05:46:24.680] [warning][admin][elasticsearch] Unable to revive connecti  
on: [http://localhost:9200/](http://localhost:9200/)  
log [05:46:24.682] [warning][admin][elasticsearch] No living connections  
log [05:46:27.055] [warning][data][elasticsearch] Unable to revive connectio  
n: [http://localhost:9200/](http://localhost:9200/)  
log [05:46:27.057] [warning][data][elasticsearch] No living connections  
log [05:46:27.058] [warning][licensing][plugins] License information could n  
ot be obtained from Elasticsearch due to Error: No Living connections error  
log [05:46:27.195] [warning][admin][elasticsearch] Unable to revive connecti  
on: [http://localhost:9200/](http://localhost:9200/)  
log [05:46:27.197] [warning][admin][elasticsearch] No living connections  
log [05:46:29.680] [warning][admin][elasticsearch] Unable to revive connecti  
on: [http://localhost:9200/](http://localhost:9200/)  
log [05:46:29.682] [warning][admin][elasticsearch] No living connections  
log [05:46:32.195] [warning][admin][elasticsearch] Unable to revive connecti  
on: [http://localhost:9200/](http://localhost:9200/)  
log [05:46:32.199] [warning][admin][elasticsearch] No living connections  
log [05:46:34.711] [warning][admin][elasticsearch] Unable to revive connecti  
on: [http://localhost:9200/](http://localhost:9200/)  
log [05:46:34.713] [warning][admin][elasticsearch] No living connections  
log [05:46:37.196] [warning][admin][elasticsearch] Unable to revive connecti  
on: [http://localhost:9200/](http://localhost:9200/)  
log [05:46:37.199] [warning][admin][elasticsearch] No living connections  
log [05:46:39.695] [warning][admin][elasticsearch] Unable to revive connecti  
on: [http://localhost:9200/](http://localhost:9200/)  
log [05:46:39.697] [warning][admin][elasticsearch] No living connections  
log [05:46:43.933] [info][savedobjects-service] Starting saved objects migra  
tions  
log [05:46:44.060] [warning][savedobjects-service] Unable to connect to Elas  
ticsearch. Error: [search\_phase\_execution\_exception] all shards failed

> Blockquote  
> many thanks for any hints

---

<div class="post-metadata">

**Author:** ![aaron-nimocks](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/aaron-nimocks/32/73965_2.png) [@aaron-nimocks](https://discuss.elastic.co/u/aaron-nimocks)\
**Post date:** [March 15, 2021, 10:18am UTC](https://discuss.elastic.co/t/after-changing-the-server-ip-address-kibana-does-not-work/265840/8 "2021-03-15T10:18:14Z")

</div>

In kibana.yml, do you have localhost anywhere in that config?

---

<div class="post-metadata">

**Author:** ![John\_biryon](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/john_biryon/32/84747_2.png) [@John\_biryon](https://discuss.elastic.co/u/John_biryon)\
**Post date:** [March 15, 2021, 12:06pm UTC](https://discuss.elastic.co/t/after-changing-the-server-ip-address-kibana-does-not-work/265840/9 "2021-03-15T12:06:00Z")

</div>

no there is not

Do i have to setup all the values here on the yml file  
or is it okto leave it as its without much change

בתאריך יום ב׳, 15 במרץ 2021, 12:28, מאת Aaron Nimocks via Discuss the Elastic Stack ‏\<[elastic@discoursemail.com](mailto:elastic@discoursemail.com)\>:

---

<div class="post-metadata">

**Author:** ![aaron-nimocks](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/aaron-nimocks/32/73965_2.png) [@aaron-nimocks](https://discuss.elastic.co/u/aaron-nimocks)\
**Post date:** [March 15, 2021, 7:15pm UTC](https://discuss.elastic.co/t/after-changing-the-server-ip-address-kibana-does-not-work/265840/10 "2021-03-15T19:15:47Z")

</div>

Yes, I would go through everything you have in [kibana.yml](https://www.elastic.co/guide/en/kibana/current/settings.html).

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [April 12, 2021, 7:16pm UTC](https://discuss.elastic.co/t/after-changing-the-server-ip-address-kibana-does-not-work/265840/11 "2021-04-12T19:16:20Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
