# After I uncomment xpack.security.enabled: true line in elasticsearch.service Failed to start Elasticsearch

**URL:** <https://discuss.elastic.co/t/after-i-uncomment-xpack-security-enabled-true-line-in-elasticsearch-service-failed-to-start-elasticsearch/339661>\
**Category:** Kibana\
**Tags:** elastic-stack-security\
**Created:** [July 31, 2023, 8:02am UTC](https://discuss.elastic.co/t/after-i-uncomment-xpack-security-enabled-true-line-in-elasticsearch-service-failed-to-start-elasticsearch/339661 "2023-07-31T08:02:44Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![janitha\_ilangage](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/janitha_ilangage/32/122289_2.png) [@janitha\_ilangage](https://discuss.elastic.co/u/janitha_ilangage)\
**Post date:** [July 31, 2023, 8:02am UTC](https://discuss.elastic.co/t/after-i-uncomment-xpack-security-enabled-true-line-in-elasticsearch-service-failed-to-start-elasticsearch/339661/1 "2023-07-31T08:02:44Z")

</div>

After I uncomment xpack.security.enabled: true line in elasticsearch.service Failed to start Elasticsearch.

 ![image](https://us1.discourse-cdn.com/elastic/original/3X/a/d/add7cc0d2f4201c7dba3f4cbceb222899623ce63.png)

root@kibana:~# systemctl status elasticsearch.service  
● elasticsearch.service - Elasticsearch  
Loaded: loaded (/lib/systemd/system/elasticsearch.service; enabled; vendor preset: enabled)  
Active: failed (Result: exit-code) since Mon 2023-07-31 07:59:44 UTC; 7min ago  
Docs: [https://www.elastic.co](https://www.elastic.co)  
Process: 1468812 ExecStart=/usr/share/elasticsearch/bin/systemd-entrypoint -p ${PID\_DIR}/elasticsearch.pid --quiet \>  
Main PID: 1468812 (code=exited, status=78)

Jul 31 07:59:28 kibana systemd[1]: Starting Elasticsearch...  
Jul 31 07:59:44 kibana systemd-entrypoint[1468812]: ERROR: [1] bootstrap checks failed. You must address the points des\>  
Jul 31 07:59:44 kibana systemd-entrypoint[1468812]: bootstrap check failure [1] of [1]: Transport SSL must be enabled i\>  
Jul 31 07:59:44 kibana systemd-entrypoint[1468812]: ERROR: Elasticsearch did not exit normally - check the logs at /var\>  
Jul 31 07:59:44 kibana systemd[1]: elasticsearch.service: Main process exited, code=exited, status=78/CONFIG  
Jul 31 07:59:44 kibana systemd[1]: elasticsearch.service: Failed with result 'exit-code'.  
Jul 31 07:59:44 kibana systemd[1]: Failed to start Elasticsearch.

---

<div class="post-metadata">

**Author:** ![Yang\_Wang](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/yang_wang/32/48857_2.png) [@Yang\_Wang](https://discuss.elastic.co/u/Yang_Wang)\
**Post date:** [August 1, 2023, 12:30am UTC](https://discuss.elastic.co/t/after-i-uncomment-xpack-security-enabled-true-line-in-elasticsearch-service-failed-to-start-elasticsearch/339661/2 "2023-08-01T00:30:31Z")

</div>

> [@janitha\_ilangage](#):
>
> Jul 31 07:59:44 kibana systemd-entrypoint[1468812]: bootstrap check failure [1] of [1]: **Transport SSL must be enabled** i\>

In production mode, when security is enabled, Elasticsearch requires Transport SSL to be enabled as well. Otherwise, it will fail to start due to bootstrap check failure as shown above. Please refer to the [docs](https://www.elastic.co/guide/en/elasticsearch/reference/current/security-basic-setup.html) to configure security including Transport SSL.

---

<div class="post-metadata">

**Author:** ![janitha\_ilangage](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/janitha_ilangage/32/122289_2.png) [@janitha\_ilangage](https://discuss.elastic.co/u/janitha_ilangage)\
**Post date:** [August 10, 2023, 3:43am UTC](https://discuss.elastic.co/t/after-i-uncomment-xpack-security-enabled-true-line-in-elasticsearch-service-failed-to-start-elasticsearch/339661/3 "2023-08-10T03:43:16Z")

</div>

Thanks, I will try and let you know

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [September 7, 2023, 3:43am UTC](https://discuss.elastic.co/t/after-i-uncomment-xpack-security-enabled-true-line-in-elasticsearch-service-failed-to-start-elasticsearch/339661/4 "2023-09-07T03:43:51Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
