# After installing a filter plugin with BouncyCastleFipsProvider, Logstash fails to start

**URL:** <https://discuss.elastic.co/t/after-installing-a-filter-plugin-with-bouncycastlefipsprovider-logstash-fails-to-start/293115>\
**Category:** Logstash\
**Created:** [December 29, 2021, 12:41pm UTC](https://discuss.elastic.co/t/after-installing-a-filter-plugin-with-bouncycastlefipsprovider-logstash-fails-to-start/293115 "2021-12-29T12:41:46Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![yon\_y](https://avatars.discourse-cdn.com/v4/letter/y/65b543/32.png) [@yon\_y](https://discuss.elastic.co/u/yon_y)\
**Post date:** [December 29, 2021, 12:41pm UTC](https://discuss.elastic.co/t/after-installing-a-filter-plugin-with-bouncycastlefipsprovider-logstash-fails-to-start/293115/1 "2021-12-29T12:41:46Z")

</div>

I wrote a Java filter plugin, compiled it into a gem (after successfully unit-tests), installed it successfully to Logstash, but then Logstash fails to start. The problem is caused by a single line (when the line is removed, everything works perfectly), but I need it.

Here is the line:

`Provider bc = new BouncyCastleFipsProvider();`

Logstash gives the following error:

```auto
[ERROR][logstash.agent] Failed to execute action {:action=>LogStash::PipelineAction::Create/pipeline_id:main, :exception=>"Java::JavaLang::IllegalStateException", :message=>"Unable to configure plugins: java.lang.ExceptionInInitializerError", :backtrace=>["org.logstash.config.ir.CompiledPipeline.<init>(CompiledPipeline.java:119)", "org.logstash.execution.JavaBasePipelineExt.initialize(JavaBasePipelineExt.java:86)", "org.logstash.execution.JavaBasePipelineExt$INVOKER$i$1$0$initialize.call(JavaBasePipelineExt$INVOKER$i$1$0$initialize.gen)", "org.jruby.internal.runtime.methods.JavaMethod$JavaMethodN.call(JavaMethod.java:837)", "org.jruby.ir.runtime.IRRuntimeHelpers.instanceSuper(IRRuntimeHelpers.java:1169)", "org.jruby.ir.runtime.IRRuntimeHelpers.instanceSuperSplatArgs(IRRuntimeHelpers.java:1156)", "org.jruby.ir.targets.InstanceSuperInvokeSite.invoke(InstanceSuperInvokeSite.java:39)", "C_3a_.dev.logstash_minus_7_dot_16_dot_2.logstash_minus_core.lib.logstash.java_pipeline.RUBY$method$initialize$0(C:/dev/logstash-7.16.2/logstash-core/lib/logstash/java_pipeline.rb:47)", "org.jruby.internal.runtime.methods.CompiledIRMethod.call(CompiledIRMethod.java:80)", "org.jruby.internal.runtime.methods.MixedModeIRMethod.call(MixedModeIRMethod.java:70)", "org.jruby.runtime.callsite.CachingCallSite.cacheAndCall(CachingCallSite.java:333)", "org.jruby.runtime.callsite.CachingCallSite.call(CachingCallSite.java:87)", "org.jruby.RubyClass.newInstance(RubyClass.java:939)", "org.jruby.RubyClass$INVOKER$i$newInstance.call(RubyClass$INVOKER$i$newInstance.gen)", "org.jruby.ir.targets.InvokeSite.invoke(InvokeSite.java:207)", "C_3a_.dev.logstash_minus_7_dot_16_dot_2.logstash_minus_core.lib.logstash.pipeline_action.create.RUBY$method$execute$0(C:/dev/logstash-7.16.2/logstash-core/lib/logstash/pipeline_action/create.rb:52)", "C_3a_.dev.logstash_minus_7_dot_16_dot_2.logstash_minus_core.lib.logstash.pipeline_action.create.RUBY$method$execute$0$ __VARARGS__ (C:/dev/logstash-7.16.2/logstash-core/lib/logstash/pipeline_action/create.rb:50)", "org.jruby.internal.runtime.methods.CompiledIRMethod.call(CompiledIRMethod.java:80)", "org.jruby.internal.runtime.methods.MixedModeIRMethod.call(MixedModeIRMethod.java:70)", "org.jruby.ir.targets.InvokeSite.invoke(InvokeSite.java:207)", "C_3a_.dev.logstash_minus_7_dot_16_dot_2.logstash_minus_core.lib.logstash.agent.RUBY$block$converge_state$2(C:/dev/logstash-7.16.2/logstash-core/lib/logstash/agent.rb:383)", "org.jruby.runtime.CompiledIRBlockBody.callDirect(CompiledIRBlockBody.java:138)", "org.jruby.runtime.IRBlockBody.call(IRBlockBody.java:58)", "org.jruby.runtime.IRBlockBody.call(IRBlockBody.java:52)", "org.jruby.runtime.Block.call(Block.java:139)", "org.jruby.RubyProc.call(RubyProc.java:318)", "org.jruby.internal.runtime.RubyRunnable.run(RubyRunnable.java:105)", "java.base/java.lang.Thread.run(Thread.java:829)"]}
warning: thread "Converge PipelineAction::Create<main>" terminated with exception (report_on_exception is true):
LogStash::Error: Don't know how to handle `Java::JavaLang::IllegalStateException` for `PipelineAction::Create<main>`
          create at org/logstash/execution/ConvergeResultExt.java:135
             add at org/logstash/execution/ConvergeResultExt.java:60
  converge_state at C:/dev/logstash-7.16.2/logstash-core/lib/logstash/agent.rb:396

```

Logstash version - 7.16.2  
Java version - 11

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [January 26, 2022, 12:42pm UTC](https://discuss.elastic.co/t/after-installing-a-filter-plugin-with-bouncycastlefipsprovider-logstash-fails-to-start/293115/2 "2022-01-26T12:42:43Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
