# After upgrade Elastic+ Kibana 7.2.0 to 7.7.1 - Another Kibana instance appears to be migrating the index

**URL:** https://discuss.elastic.co/t/after-upgrade-elastic-kibana-7-2-0-to-7-7-1-another-kibana-instance-appears-to-be-migrating-the-index/267431
**Category:** Kibana
**Created:** [March 17, 2021, 12:56am UTC](https://discuss.elastic.co/t/after-upgrade-elastic-kibana-7-2-0-to-7-7-1-another-kibana-instance-appears-to-be-migrating-the-index/267431 "2021-03-17T00:56:25Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![zuser](https://avatars.discourse-cdn.com/v4/letter/z/f17d59/32.png) [@zuser](https://discuss.elastic.co/u/zuser)
#### Post date: [March 17, 2021, 12:56am UTC](https://discuss.elastic.co/t/after-upgrade-elastic-kibana-7-2-0-to-7-7-1-another-kibana-instance-appears-to-be-migrating-the-index/267431/1 "2021-03-17T00:56:25Z")

</div>

Reason, after updating, kibana creates new indexes?  
Then I tried to remove .kibana\_task\_manager\_2, and .kibana\_2., i'll get new fresh kibana without my dasbords, spaces etc.

```auto
    kibana_1 | {"type":"log","@timestamp":"2021-03-17T00:05:54Z","tags":["warning","savedobjects-service"],"pid":8,"message":"Another Kibana instance appears to be migrating the index. Waiting for that migration to complete. If no other Kibana instance is attempting migrations, you can get past this message by deleting index .kibana_2 and restarting Kibana."}
    kibana_1 | {"type":"log","@timestamp":"2021-03-17T00:05:54Z","tags":["info","savedobjects-service"],"pid":8,"message":"Creating index .kibana_task_manager_2."}
    kibana_1 | {"type":"log","@timestamp":"2021-03-17T00:05:54Z","tags":["warning","savedobjects-service"],"pid":8,"message":"Unable to connect to Elasticsearch. Error: [resource_already_exists_exception] index [.kibana_task_manager_2/1iPF5fjfSg6K__2IM3QSJw] already exists, with { index_uuid=\"1iPF5fjfSg6K__2IM3QSJw\" & index=\".kibana_task_manager_2\" }"}
    kibana_1 | {"type":"log","@timestamp":"2021-03-17T00:05:54Z","tags":["warning","savedobjects-service"],"pid":8,"message":"Another Kibana instance appears to be migrating the index. Waiting for that migration to complete. If no other Kibana instance is attempting migrations, you can get past this message by deleting index .kibana_task_manager_2 and restarting Kibana."}

```

```auto
    GET /_cat/indices/.kibana*?v
    green open .kibana_task_manager w2yLj54JRd6-8_bzNyX70g 1 0 2 0 47.2kb 47.2kb
    green open .kibana_task_manager_2 1iPF5fjfSg6K__2IM3QSJw 1 0 0 0 208b 208b
    green open .kibana_task_manager_1 FF2jj96lTuasSOcp0P-eag 1 0 0 0 208b 208b
    green open .kibana_2 b8z4-4miQriNi8YetSFkbA 1 0 415 0 130.5kb 130.5kb
    green open .kibana_1 ej7zN6GgQJSFKOQDglj-xg 1 0 4307 433 4.4mb 4.4mb

```

Tell me please can i start new Kibana with my old data?  
What i need to do, before upgrade Kibana (unless baclup)?

---

<div class="post-metadata">

### Author: ![tylersmalley](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tylersmalley/32/8833_2.png) [@tylersmalley](https://discuss.elastic.co/u/tylersmalley)
#### Post date: [March 17, 2021, 11:33pm UTC](https://discuss.elastic.co/t/after-upgrade-elastic-kibana-7-2-0-to-7-7-1-another-kibana-instance-appears-to-be-migrating-the-index/267431/2 "2021-03-17T23:33:57Z")

</div>

When upgrading, the migrations should be handled automatically and this error usually only happens when there was an issue. The logs should contain information as to the cause.

We have information on this process here: [Upgrade migrations | Kibana Guide [7.11] | Elastic](https://www.elastic.co/guide/en/kibana/current/upgrade-migrations.html)

Specifically, [this](https://www.elastic.co/guide/en/kibana/current/upgrade-migrations.html#resolve-migrations-failures) section on resolving migration failures.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [April 14, 2021, 11:34pm UTC](https://discuss.elastic.co/t/after-upgrade-elastic-kibana-7-2-0-to-7-7-1-another-kibana-instance-appears-to-be-migrating-the-index/267431/3 "2021-04-14T23:34:22Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
