# After Upgrade from 6.7 to Kibana 7.0 Service cannot Up

**URL:** <https://discuss.elastic.co/t/after-upgrade-from-6-7-to-kibana-7-0-service-cannot-up/176868>\
**Category:** Kibana\
**Created:** [April 15, 2019, 9:37am UTC](https://discuss.elastic.co/t/after-upgrade-from-6-7-to-kibana-7-0-service-cannot-up/176868 "2019-04-15T09:37:02Z")\
**Posts on this page:** 18\
**Page:** 1

<div class="post-metadata">

**Author:** ![wcpoon](https://avatars.discourse-cdn.com/v4/letter/w/da6949/32.png) [@wcpoon](https://discuss.elastic.co/u/wcpoon)\
**Post date:** [April 15, 2019, 9:37am UTC](https://discuss.elastic.co/t/after-upgrade-from-6-7-to-kibana-7-0-service-cannot-up/176868/1 "2019-04-15T09:37:02Z")

</div>

Hi Guys,

After upgrade from 6.7 to 7.0, my Kibana cannot up and haven't the error message below,  
I got one master node and one data node.

Apr 15 17:33:25 z3aries-n10 systemd: Starting Kibana...  
Apr 15 17:33:27 z3aries-n10 logstash: warning: thread "Ruby-0-Thread-5: :1" terminated with exception (report\_on\_exception is true):  
Apr 15 17:33:27 z3aries-n10 logstash: LogStash::Outputs::ElasticSearch::HttpClient::Pool::BadResponseCodeError: Got response code '503' contacting Elasticsearch at URL '[http://10.3.3.30:9200/logstash](http://10.3.3.30:9200/logstash)'  
Apr 15 17:33:27 z3aries-n10 logstash: perform\_request at /usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-output-elasticsearch-10.0.1-java/lib/logstash/outputs/elasticsearch/http\_client/manticore\_adapter.rb:80  
Apr 15 17:33:27 z3aries-n10 logstash: perform\_request\_to\_url at /usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-output-elasticsearch-10.0.1-java/lib/logstash/outputs/elasticsearch/http\_client/pool.rb:291  
Apr 15 17:33:27 z3aries-n10 logstash: perform\_request at /usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-output-elasticsearch-10.0.1-java/lib/logstash/outputs/elasticsearch/http\_client/pool.rb:278  
Apr 15 17:33:27 z3aries-n10 logstash: with\_connection at /usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-output-elasticsearch-10.0.1-java/lib/logstash/outputs/elasticsearch/http\_client/pool.rb:373  
Apr 15 17:33:27 z3aries-n10 logstash: perform\_request at /usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-output-elasticsearch-10.0.1-java/lib/logstash/outputs/elasticsearch/http\_client/pool.rb:277  
Apr 15 17:33:27 z3aries-n10 logstash: Pool at /usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-output-elasticsearch-10.0.1-java/lib/logstash/outputs/elasticsearch/http\_client/pool.rb:285  
Apr 15 17:33:27 z3aries-n10 logstash: exists? at /usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-output-elasticsearch-10.0.1-java/lib/logstash/outputs/elasticsearch/http\_client.rb:341  
Apr 15 17:33:27 z3aries-n10 logstash: rollover\_alias\_exists? at /usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-output-elasticsearch-10.0.1-java/lib/logstash/outputs/elasticsearch/http\_client.rb:359  
Apr 15 17:33:27 z3aries-n10 logstash: maybe\_create\_rollover\_alias at /usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-output-elasticsearch-10.0.1-java/lib/logstash/outputs/elasticsearch/ilm.rb:89  
Apr 15 17:33:27 z3aries-n10 logstash: setup\_ilm at /usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-output-elasticsearch-10.0.1-java/lib/logstash/outputs/elasticsearch/ilm.rb:11  
Apr 15 17:33:27 z3aries-n10 logstash: setup\_after\_successful\_connection at /usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-output-elasticsearch-10.0.1-java/lib/logstash/outputs/elasticsearch/common.rb:51  
Apr 15 17:33:27 z3aries-n10 logstash: [2019-04-15T17:33:27,834][FATAL][logstash.runner] An unexpected error occurred! {:error=\>#\<LogStash::Outputs::ElasticSearch::HttpClient::Pool::BadResponseCodeError: LogStash::Outputs::ElasticSearch::HttpClient::Pool::BadResponseCodeError\>, :backtrace=\>["/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-output-elasticsearch-10.0.1-java/lib/logstash/outputs/elasticsearch/http\_client/manticore\_adapter.rb:80:in `perform_request'", "/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-output-elasticsearch-10.0.1-java/lib/logstash/outputs/elasticsearch/http_client/pool.rb:291:in`perform\_request\_to\_url'", "/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-output-elasticsearch-10.0.1-java/lib/logstash/outputs/elasticsearch/http\_client/pool.rb:278:in `block in perform_request'", "/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-output-elasticsearch-10.0.1-java/lib/logstash/outputs/elasticsearch/http_client/pool.rb:373:in`with\_connection'", "/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-output-elasticsearch-10.0.1-java/lib/logstash/outputs/elasticsearch/http\_client/pool.rb:277:in `perform_request'", "/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-output-elasticsearch-10.0.1-java/lib/logstash/outputs/elasticsearch/http_client/pool.rb:285:in`block in Pool'", "/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-output-elasticsearch-10.0.1-java/lib/logstash/outputs/elasticsearch/http\_client.rb:341:in `exists?'", "/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-output-elasticsearch-10.0.1-java/lib/logstash/outputs/elasticsearch/http_client.rb:359:in`rollover\_alias\_exists?'", "/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-output-elasticsearch-10.0.1-java/lib/logstash/outputs/elasticsearch/ilm.rb:89:in `maybe_create_rollover_alias'", "/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-output-elasticsearch-10.0.1-java/lib/logstash/outputs/elasticsearch/ilm.rb:11:in`setup\_ilm'", "/usr/share/logstash/vendor/bund  
Apr 15 17:33:27 z3aries-n10 logstash: le/jruby/2.5.0/gems/logstash-output-elasticsearch-10.0.1-java/lib/logstash/outputs/elasticsearch/common.rb:51:in `block in setup\_after\_successful\_connection'"]}  
Apr 15 17:33:27 z3aries-n10 logstash: [2019-04-15T17:33:27,891][ERROR][org.logstash.Logstash] java.lang.IllegalStateException: Logstash stopped processing because of an error: (SystemExit) exit  
Apr 15 17:33:28 z3aries-n10 systemd: logstash.service: main process exited, code=exited, status=1/FAILURE  
Apr 15 17:33:28 z3aries-n10 systemd: Unit logstash.service entered failed state.  
Apr 15 17:33:28 z3aries-n10 systemd: logstash.service failed.  
Apr 15 17:33:28 z3aries-n10 systemd: logstash.service holdoff time over, scheduling restart.

any idea what's wrong?

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [April 15, 2019, 9:55am UTC](https://discuss.elastic.co/t/after-upgrade-from-6-7-to-kibana-7-0-service-cannot-up/176868/2 "2019-04-15T09:55:38Z")

</div>

That log is from Logstash, not Kibana?

---

<div class="post-metadata">

**Author:** ![wcpoon](https://avatars.discourse-cdn.com/v4/letter/w/da6949/32.png) [@wcpoon](https://discuss.elastic.co/u/wcpoon)\
**Post date:** [April 15, 2019, 10:00am UTC](https://discuss.elastic.co/t/after-upgrade-from-6-7-to-kibana-7-0-service-cannot-up/176868/3 "2019-04-15T10:00:19Z")

</div>

Sorry.. I get the log from /var/log/messages, I saw the Kibana service keep restart.  
I thought is Kibana service issues.  
Any how, any idea what's wrong?

---

<div class="post-metadata">

**Author:** ![wcpoon](https://avatars.discourse-cdn.com/v4/letter/w/da6949/32.png) [@wcpoon](https://discuss.elastic.co/u/wcpoon)\
**Post date:** [April 15, 2019, 10:01am UTC](https://discuss.elastic.co/t/after-upgrade-from-6-7-to-kibana-7-0-service-cannot-up/176868/4 "2019-04-15T10:01:06Z")

</div>

this is another logs,

Apr 15 17:43:20 z3aries-n10 systemd: Starting Kibana...  
Apr 15 17:43:25 z3aries-n10 logstash: Sending Logstash logs to /var/log/logstash which is now configured via log4j2.properties  
Apr 15 17:43:26 z3aries-n10 logstash: [2019-04-15T17:43:26,502][INFO][logstash.runner] Starting Logstash {"logstash.version"=\>"7.0.0"}  
Apr 15 17:43:27 z3aries-n10 kibana: {"type":"log","@timestamp":"2019-04-15T09:43:27Z","tags":["plugin","warning"],"pid":12425,"path":"/usr/share/kibana/src/legacy/core\_plugins/ems\_util","message":"Skipping non-plugin directory at /usr/share/kibana/src/legacy/core\_plugins/ems\_util"}  
Apr 15 17:43:28 z3aries-n10 kibana: {"type":"log","@timestamp":"2019-04-15T09:43:28Z","tags":["fatal","root"],"pid":12425,"message":"{ ValidationError: child "elasticsearch" fails because ["url" is not allowed]\n at Object.exports.process (/usr/share/kibana/node\_modules/joi/lib/errors.js:196:19)\n at internals.Object.\_validateWithOptions (/usr/share/kibana/node\_modules/joi/lib/types/any/index.js:675:31)\n at module.exports.internals.Any.root.validate (/usr/share/kibana/node\_modules/joi/lib/index.js:146:23)\n at Config.\_commit (/usr/share/kibana/src/legacy/server/config/config.js:139:35)\n at Config.set (/usr/share/kibana/src/legacy/server/config/config.js:108:10)\n at Config.extendSchema (/usr/share/kibana/src/legacy/server/config/config.js:81:10)\n at extendConfigService (/usr/share/kibana/src/legacy/plugin\_discovery/plugin\_config/extend\_config\_service.js:45:10) name: 'ValidationError' }"}  
Apr 15 17:43:28 z3aries-n10 kibana: FATAL ValidationError: child "elasticsearch" fails because ["url" is not allowed]  
Apr 15 17:43:28 z3aries-n10 systemd: kibana.service: main process exited, code=exited, status=1/FAILURE  
Apr 15 17:43:28 z3aries-n10 systemd: Unit kibana.service entered failed state.  
Apr 15 17:43:28 z3aries-n10 systemd: kibana.service failed.  
^[Apr 15 17:43:29 z3aries-n10 systemd: kibana.service holdoff time over, scheduling restart.

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [April 15, 2019, 10:09am UTC](https://discuss.elastic.co/t/after-upgrade-from-6-7-to-kibana-7-0-service-cannot-up/176868/5 "2019-04-15T10:09:30Z")

</div>

> [@wcpoon](#):
>
> Apr 15 17:43:28 z3aries-n10 kibana: FATAL ValidationError: child "elasticsearch" fails because ["url" is not allowed]

Might be a problem with your config.  
Can you post it, making sure you format it with the `</>` button.

---

<div class="post-metadata">

**Author:** ![wcpoon](https://avatars.discourse-cdn.com/v4/letter/w/da6949/32.png) [@wcpoon](https://discuss.elastic.co/u/wcpoon)\
**Post date:** [April 15, 2019, 10:19am UTC](https://discuss.elastic.co/t/after-upgrade-from-6-7-to-kibana-7-0-service-cannot-up/176868/6 "2019-04-15T10:19:17Z")

</div>

elasticsearch.yml [master node]

```
path.data: /var/lib/elasticsearch
path.logs: /var/log/elasticsearch
bootstrap.memory_lock: true
cluster.name: elk.stack
node.name: aries-n01
network.host: 10.3.3.30
http.port: 9200
node.master: true
node.data: true
discovery.zen.ping.unicast.hosts: ["10.3.3.30", "10.3.3.31"]

```

elasticsearch.yml [data node]

```
path.data: /var/lib/elasticsearch
path.logs: /var/log/elasticsearch
bootstrap.memory_lock: true
cluster.name: elk.stack
node.name: aries-n02
network.host: 10.3.3.31
http.port: 9200
node.master: false
node.data: true
discovery.zen.ping.unicast.hosts: ["10.3.3.30", "10.3.3.31"]

```

kibana.yml [master node]

```
server.host: "10.3.3.30"
elasticsearch.url: "http://10.3.3.30:9200"

```

kibana.yml [data node]

```
server.host: "10.3.3.31"
elasticsearch.url: "http://10.3.3.31:9200"

```

logstash.yml [master node]

```
path.data: /var/lib/logstash
path.logs: /var/log/logstash

```

logstash.yml [data node]

```
path.data: /var/lib/logstash
path.logs: /var/log/logstash

```

But, above config in 6.7 without any issues. The issue happen after upgrade from 6.7 to 7.0

---

<div class="post-metadata">

**Author:** ![wcpoon](https://avatars.discourse-cdn.com/v4/letter/w/da6949/32.png) [@wcpoon](https://discuss.elastic.co/u/wcpoon)\
**Post date:** [April 16, 2019, 3:25am UTC](https://discuss.elastic.co/t/after-upgrade-from-6-7-to-kibana-7-0-service-cannot-up/176868/7 "2019-04-16T03:25:06Z")

</div>

Any one can assist on my upgrade issue?

---

<div class="post-metadata">

**Author:** ![Petr.Simik](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/petr.simik/32/38082_2.png) [@Petr.Simik](https://discuss.elastic.co/u/Petr.Simik)\
**Post date:** [April 16, 2019, 1:24pm UTC](https://discuss.elastic.co/t/after-upgrade-from-6-7-to-kibana-7-0-service-cannot-up/176868/8 "2019-04-16T13:24:26Z")

</div>

I have exactly the same issue, did you managed how to resolved it?  
I also upgraded from 6.7 to 7.0 all fine except start of Kibana  
kibana keeps restarting & reports to /var/log/messages

xxkibana01 kibana: FATAL ValidationError: child "elasticsearch" fails because ["url" is not allowed]

---

<div class="post-metadata">

**Author:** ![Petr.Simik](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/petr.simik/32/38082_2.png) [@Petr.Simik](https://discuss.elastic.co/u/Petr.Simik)\
**Post date:** [April 16, 2019, 1:39pm UTC](https://discuss.elastic.co/t/after-upgrade-from-6-7-to-kibana-7-0-service-cannot-up/176868/9 "2019-04-16T13:39:04Z")

</div>

I found the problem  
they changed  
/etc/kibana/kibana.yml

in version 6.xx  
elasticsearch.url: "[http://localhost:9200](http://localhost:9200)"

in version 7.xx  
elasticsearch.hosts: ["[http://localhost:9200](http://localhost:9200)"]

just rename url to host and my problem was resolved

---

<div class="post-metadata">

**Author:** ![tiagocosta](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tiagocosta/32/40045_2.png) [@tiagocosta](https://discuss.elastic.co/u/tiagocosta)\
**Post date:** [April 16, 2019, 3:53pm UTC](https://discuss.elastic.co/t/after-upgrade-from-6-7-to-kibana-7-0-service-cannot-up/176868/10 "2019-04-16T15:53:29Z")

</div>

Exactly, that is the explanation. Since kibana 7 we moved away from the option `elasticsearch.url` that is now `elasticsearch.hosts`. More info can be found here [https://www.elastic.co/guide/en/kibana/7.x/breaking-changes-7.0.html#\_literal\_elasticsearch\_url\_literal\_is\_no\_longer\_valid](https://www.elastic.co/guide/en/kibana/7.x/breaking-changes-7.0.html#_literal_elasticsearch_url_literal_is_no_longer_valid)

---

<div class="post-metadata">

**Author:** ![wcpoon](https://avatars.discourse-cdn.com/v4/letter/w/da6949/32.png) [@wcpoon](https://discuss.elastic.co/u/wcpoon)\
**Post date:** [April 23, 2019, 9:51am UTC](https://discuss.elastic.co/t/after-upgrade-from-6-7-to-kibana-7-0-service-cannot-up/176868/11 "2019-04-23T09:51:40Z")

</div>

Hi, after i changed from elasticsearch.url to elasticsearch.hosts, the services still cannot up.

in elastic search cluster log,  
`[2019-04-23T17:33:07,383][WARN][o.e.c.c.ClusterFormationFailureHelper] [aries-n01] master not discovered yet, this node has not previously joined a bootstrapped (v7+) cluster, and [cluster.initial_master_nodes] is empty on this node: have discovered []; discovery will continue using [10.3.3.31:9300] from hosts providers and [{aries-n01}{n-fNTnCQS_eTLm_W4P5Rag}vycMk_OJStmY8_sH7QqROQ}{10.3.3.30}{10.3.3.30:9300}{ml.machine_memory=8203431936, xpack.installed=true, ml.max_open_jobs=20}] from last-known cluster state; node term 0, last-accepted version 0 in term 0`

Guys, any idea what's wrong?

---

<div class="post-metadata">

**Author:** ![wcpoon](https://avatars.discourse-cdn.com/v4/letter/w/da6949/32.png) [@wcpoon](https://discuss.elastic.co/u/wcpoon)\
**Post date:** [April 23, 2019, 9:52am UTC](https://discuss.elastic.co/t/after-upgrade-from-6-7-to-kibana-7-0-service-cannot-up/176868/12 "2019-04-23T09:52:56Z")

</div>

message log,  
`Apr 23 17:42:17 aries-n01 logstash: [2019-04-23T17:42:17,963][INFO][logstash.runner] Starting Logstash {"logstash.version"=>"7.0.0"} Apr 23 17:42:19 aries-n01 kibana: {"type":"log","@timestamp":"2019-04-23T09:42:19Z","tags":["plugin","warning"],"pid":5299,"path":"/usr/share/kibana/src/legacy/core_plugins/ems_util","message":"Skipping non-plugin directory at /usr/share/kibana/src/legacy/core_plugins/ems_util"} Apr 23 17:42:21 aries-n01 kibana: {"type":"log","@timestamp":"2019-04-23T09:42:21Z","tags":["status","plugin:kibana@undefined","info"],"pid":5299,"state":"green","message":"Status changed from uninitialized to green - Ready","prevState":"uninitialized","prevMsg":"uninitialized"} Apr 23 17:42:21 aries-n01 kibana: {"type":"log","@timestamp":"2019-04-23T09:42:21Z","tags":["status","plugin:elasticsearch@undefined","info"],"pid":5299,"state":"yellow","message":"Status changed from uninitialized to yellow - Waiting for Elasticsearch","prevState":"uninitialized","prevMsg":"uninitialized"} Apr 23 17:42:21 aries-n01 kibana: {"type":"log","@timestamp":"2019-04-23T09:42:21Z","tags":["status","plugin:xpack_main@7.0.0","info"],"pid":5299,"state":"yellow","message":"Status changed from uninitialized to yellow - Waiting for Elasticsearch","prevState":"uninitialized","prevMsg":"uninitialized"} Apr 23 17:42:21 aries-n01 kibana: {"type":"log","@timestamp":"2019-04-23T09:42:21Z","tags":["status","plugin:graph@7.0.0","info"],"pid":5299,"state":"yellow","message":"Status changed from uninitialized to yellow - Waiting for Elasticsearch","prevState":"uninitialized","prevMsg":"uninitialized"} Apr 23 17:42:21 aries-n01 kibana: {"type":"log","@timestamp":"2019-04-23T09:42:21Z","tags":["status","plugin:monitoring@7.0.0","info"],"pid":5299,"state":"green","message":"Status changed from uninitialized to green - Ready","prevState":"uninitialized","prevMsg":"uninitialized"} Apr 23 17:42:21 aries-n01 kibana: {"type":"log","@timestamp":"2019-04-23T09:42:21Z","tags":["status","plugin:spaces@7.0.0","info"],"pid":5299,"state":"yellow","message":"Status changed from uninitialized to yellow - Waiting for Elasticsearch","prevState":"uninitialized","prevMsg":"uninitialized"} Apr 23 17:42:21 aries-n01 kibana: {"type":"log","@timestamp":"2019-04-23T09:42:21Z","tags":["security","warning"],"pid":5299,"message":"Generating a random key for xpack.security.encryptionKey. To prevent sessions from being invalidated on restart, please set xpack.security.encryptionKey in kibana.yml"} Apr 23 17:42:21 aries-n01 kibana: {"type":"log","@timestamp":"2019-04-23T09:42:21Z","tags":["security","warning"],"pid":5299,"message":"Session cookies will be transmitted over insecure connections. This is not recommended."} Apr 23 17:42:21 aries-n01 kibana: {"type":"log","@timestamp":"2019-04-23T09:42:21Z","tags":["status","plugin:security@7.0.0","info"],"pid":5299,"state":"yellow","message":"Status changed from uninitialized to yellow - Waiting for Elasticsearch","prevState":"uninitialized","prevMsg":"uninitialized"} Apr 23 17:42:21 aries-n01 kibana: {"type":"log","@timestamp":"2019-04-23T09:42:21Z","tags":["status","plugin:searchprofiler@7.0.0","info"],"pid":5299,"state":"yellow","message":"Status changed from uninitialized to yellow - Waiting for Elasticsearch","prevState":"uninitialized","prevMsg":"uninitialized"} Apr 23 17:42:21 aries-n01 kibana: {"type":"log","@timestamp":"2019-04-23T09:42:21Z","tags":["status","plugin:ml@7.0.0","info"],"pid":5299,"state":"yellow","message":"Status changed from uninitialized to yellow - Waiting for Elasticsearch","prevState":"uninitialized","prevMsg":"uninitialized"} Apr 23 17:42:21 aries-n01 kibana: {"type":"log","@timestamp":"2019-04-23T09:42:21Z","tags":["status","plugin:tilemap@7.0.0","info"],"pid":5299,"state":"yellow","message":"Status changed from uninitialized to yellow - Waiting for Elasticsearch","prevState":"uninitialized","prevMsg":"uninitialized"} Apr 23 17:42:21 aries-n01 kibana: {"type":"log","@timestamp":"2019-04-23T09:42:21Z","tags":["status","plugin:watcher@7.0.0","info"],"pid":5299,"state":"yellow","message":"Status changed from uninitialized to yellow - Waiting for Elasticsearch","prevState":"uninitialized","prevMsg":"uninitialized"} Apr 23 17:42:21 aries-n01 kibana: {"type":"log","@timestamp":"2019-04-23T09:42:21Z","tags":["status","plugin:grokdebugger@7.0.0","info"],"pid":5299,"state":"yellow","message":"Status changed from uninitialized to yellow - Waiting for Elasticsearch","prevState":"uninitialized","prevMsg":"uninitialized"} Apr 23 17:42:21 aries-n01 kibana: {"type":"log","@timestamp":"2019-04-23T09:42:21Z","tags":["status","plugin:dashboard_mode@7.0.0","info"],"pid":5299,"state":"green","message":"Status changed from uninitialized to green - Ready","prevState":"uninitialized","prevMsg":"uninitialized"} Apr 23 17:42:21 aries-n01 kibana: {"type":"log","@timestamp":"2019-04-23T09:42:21Z","tags":["status","plugin:logstash@7.0.0","info"],"pid":5299,"state":"yellow","message":"Status changed from uninitialized to yellow - Waiting for Elasticsearch","prevState":"uninitialized","prevMsg":"uninitialized"} Apr 23 17:42:21 aries-n01 kibana: {"type":"log","@timestamp":"2019-04-23T09:42:21Z","tags":["status","plugin:beats_management@7.0.0","info"],"pid":5299,"state":"yellow","message":"Status changed from uninitialized to yellow - Waiting for Elasticsearch","prevState":"uninitialized","prevMsg":"uninitialized"} Apr 23 17:42:21 aries-n01 kibana: {"type":"log","@timestamp":"2019-04-23T09:42:21Z","tags":["status","plugin:apm_oss@undefined","info"],"pid":5299,"state":"green","message":"Status changed from uninitialized to green - Ready","prevState":"uninitialized","prevMsg":"uninitialized"} Apr 23 17:42:21 aries-n01 kibana: {"type":"log","@timestamp":"2019-04-23T09:42:21Z","tags":["status","plugin:apm@7.0.0","info"],"pid":5299,"state":"green","message":"Status changed from uninitialized to green - Ready","prevState":"uninitialized","prevMsg":"uninitialized"} Apr 23 17:42:22 aries-n01 kibana: {"type":"log","@timestamp":"2019-04-23T09:42:22Z","tags":["reporting","warning"],"pid":5299,"message":"Generating a random key for xpack.reporting.encryptionKey. To prevent pending reports from failing on restart, please set xpack.reporting.encryptionKey in kibana.yml"} Apr 23 17:42:22 aries-n01 kibana: {"type":"log","@timestamp":"2019-04-23T09:42:22Z","tags":["status","plugin:reporting@7.0.0","error"],"pid":5299,"state":"red","message":"Status changed from uninitialized to red - [data] Elasticsearch cluster did not respond with license information.","prevState":"uninitialized","prevMsg":"uninitialized"}`

---

<div class="post-metadata">

**Author:** ![wcpoon](https://avatars.discourse-cdn.com/v4/letter/w/da6949/32.png) [@wcpoon](https://discuss.elastic.co/u/wcpoon)\
**Post date:** [April 23, 2019, 10:24am UTC](https://discuss.elastic.co/t/after-upgrade-from-6-7-to-kibana-7-0-service-cannot-up/176868/13 "2019-04-23T10:24:24Z")

</div>

Is it version 7.0 setup master and data node are different compare to version 6.7?

---

<div class="post-metadata">

**Author:** ![wcpoon](https://avatars.discourse-cdn.com/v4/letter/w/da6949/32.png) [@wcpoon](https://discuss.elastic.co/u/wcpoon)\
**Post date:** [April 24, 2019, 2:21am UTC](https://discuss.elastic.co/t/after-upgrade-from-6-7-to-kibana-7-0-service-cannot-up/176868/14 "2019-04-24T02:21:36Z")

</div>

Is there anyone can assist?

---

<div class="post-metadata">

**Author:** ![wcpoon](https://avatars.discourse-cdn.com/v4/letter/w/da6949/32.png) [@wcpoon](https://discuss.elastic.co/u/wcpoon)\
**Post date:** [April 25, 2019, 2:10am UTC](https://discuss.elastic.co/t/after-upgrade-from-6-7-to-kibana-7-0-service-cannot-up/176868/15 "2019-04-25T02:10:42Z")

</div>

I think no one want to bother me?

---

<div class="post-metadata">

**Author:** ![WinJayX](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/winjayx/32/45581_2.png) [@WinJayX](https://discuss.elastic.co/u/WinJayX)\
**Post date:** [May 6, 2019, 2:50am UTC](https://discuss.elastic.co/t/after-upgrade-from-6-7-to-kibana-7-0-service-cannot-up/176868/16 "2019-05-06T02:50:17Z")

</div>

Hi,You can replace the elasticsearch.url: "[http://localhost:9200](http://localhost:9200)" in your kibana configuration file with elasticsearch.hosts: ["[http://localhost:9200](http://localhost:9200)"]

---

<div class="post-metadata">

**Author:** ![WinJayX](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/winjayx/32/45581_2.png) [@WinJayX](https://discuss.elastic.co/u/WinJayX)\
**Post date:** [May 6, 2019, 2:51am UTC](https://discuss.elastic.co/t/after-upgrade-from-6-7-to-kibana-7-0-service-cannot-up/176868/17 "2019-05-06T02:51:13Z")

</div>

Hi,You can replace the elasticsearch.url: "[http://localhost:9200](http://localhost:9200/)" in your kibana configuration file with elasticsearch.hosts: ["[http://localhost:9200](http://localhost:9200/)"]

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [June 3, 2019, 2:51am UTC](https://discuss.elastic.co/t/after-upgrade-from-6-7-to-kibana-7-0-service-cannot-up/176868/18 "2019-06-03T02:51:18Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
