# After upgrade from 8.2.2 to 8.5.3 elasticsearch.bat works just fine but the elasticsearch-service.bat start fails

**URL:** <https://discuss.elastic.co/t/after-upgrade-from-8-2-2-to-8-5-3-elasticsearch-bat-works-just-fine-but-the-elasticsearch-service-bat-start-fails/322167>\
**Category:** Elasticsearch\
**Created:** [December 29, 2022, 4:02pm UTC](https://discuss.elastic.co/t/after-upgrade-from-8-2-2-to-8-5-3-elasticsearch-bat-works-just-fine-but-the-elasticsearch-service-bat-start-fails/322167 "2022-12-29T16:02:27Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![mbooh](https://avatars.discourse-cdn.com/v4/letter/m/e495f1/32.png) [@mbooh](https://discuss.elastic.co/u/mbooh)\
**Post date:** [December 29, 2022, 4:02pm UTC](https://discuss.elastic.co/t/after-upgrade-from-8-2-2-to-8-5-3-elasticsearch-bat-works-just-fine-but-the-elasticsearch-service-bat-start-fails/322167/1 "2022-12-29T16:02:27Z")

</div>

Hi!

After upgrade from 8.2.2 to 8.5.3 elasticsearch.bat works just fine but the elasticsearch-service.bat start fails with the following error log:

```auto
[2022-12-29 16:51:55] [debug] ( prunsrv.c:1994) [8136] Apache Commons Daemon procrun log initialized.
[2022-12-29 16:51:55] [info] ( prunsrv.c:2002) [8136] Apache Commons Daemon procrun (1.3.1.0 64-bit) started.
[2022-12-29 16:51:55] [info] ( prunsrv.c:1906) [8136] Running Service 'elasticsearch-service-x64'...
[2022-12-29 16:51:55] [debug] ( prunsrv.c:1677) [5280] Inside serviceMain()...
[2022-12-29 16:51:55] [debug] ( prunsrv.c:1123) [5280] reportServiceStatusE: dwCurrentState = 2 (SERVICE_START_PENDING), dwWin32ExitCode = 0, dwWaitHint = 3000 milliseconds, dwServiceSpecificExitCode = 0.
[2022-12-29 16:51:55] [info] ( prunsrv.c:1422) [5280] Starting service...
[2022-12-29 16:51:55] [debug] ( prunsrv.c:497 ) [5280] Checking Java options for environment variable requirements
[2022-12-29 16:51:55] [debug] ( prunsrv.c:501 ) [5280] Checking environment variable requirements for '-XX:+UseSerialGC'
[2022-12-29 16:51:55] [debug] ( prunsrv.c:501 ) [5280] Checking environment variable requirements for '-Des.path.home=C:\Program Files\Elastic\Elasticsearch\elasticsearch-8.5.3'
[2022-12-29 16:51:55] [debug] ( prunsrv.c:501 ) [5280] Checking environment variable requirements for '-Des.path.conf=D:\Elastic\ElasticSearch\Config'
[2022-12-29 16:51:55] [debug] ( prunsrv.c:501 ) [5280] Checking environment variable requirements for '-Des.distribution.type=zip'
[2022-12-29 16:51:55] [debug] ( prunsrv.c:501 ) [5280] Checking environment variable requirements for '-Dcli.name=windows-service-daemon'
[2022-12-29 16:51:55] [debug] ( prunsrv.c:501 ) [5280] Checking environment variable requirements for '-Dcli.libs=lib/tools/server-cli,lib/tools/windows-service-cli'
[2022-12-29 16:51:55] [debug] ( javajni.c:216 ) [5280] Explicit RuntimeLib specified 'C:\Program Files\Elastic\Elasticsearch\elasticsearch-8.5.3\jdk\bin\server\jvm.dll'
[2022-12-29 16:51:55] [debug] ( javajni.c:280 ) [5280] Adding Java bin path to the PATH to fix loading of awt.dll: 'C:\Program Files\Elastic\Elasticsearch\elasticsearch-8.5.3\jdk\bin'
[2022-12-29 16:51:55] [debug] ( javajni.c:286 ) [5280] Loading JVM DLL 'C:\Program Files\Elastic\Elasticsearch\elasticsearch-8.5.3\jdk\bin\server\jvm.dll'
[2022-12-29 16:51:55] [debug] ( javajni.c:414 ) [5280] Loaded JVM DLL 'C:\Program Files\Elastic\Elasticsearch\elasticsearch-8.5.3\jdk\bin\server\jvm.dll', home '(null)'.
[2022-12-29 16:51:55] [debug] ( javajni.c:419 ) [5280] JNI_GetCreatedJavaVMs...
[2022-12-29 16:51:55] [debug] ( javajni.c:817 ) [7008] JVM Option[0] -XX:+UseSerialGC
[2022-12-29 16:51:55] [debug] ( javajni.c:817 ) [7008] JVM Option[1] -Des.path.home=C:\Program Files\Elastic\Elasticsearch\elasticsearch-8.5.3
[2022-12-29 16:51:55] [debug] ( javajni.c:817 ) [7008] JVM Option[2] -Des.path.conf=D:\Elastic\ElasticSearch\Config
[2022-12-29 16:51:55] [debug] ( javajni.c:817 ) [7008] JVM Option[3] -Des.distribution.type=zip
[2022-12-29 16:51:55] [debug] ( javajni.c:817 ) [7008] JVM Option[4] -Dcli.name=windows-service-daemon
[2022-12-29 16:51:55] [debug] ( javajni.c:817 ) [7008] JVM Option[5] -Dcli.libs=lib/tools/server-cli,lib/tools/windows-service-cli
[2022-12-29 16:51:55] [debug] ( javajni.c:817 ) [7008] JVM Option[6] -Djava.class.path=C:\Program Files\Elastic\Elasticsearch\elasticsearch-8.5.3/lib/ecs-logging-core-1.2.0.jar;C:\Program Files\Elastic\Elasticsearch\elasticsearch-8.5.3/lib/elasticsearch-8.5.3.jar;C:\Program Files\Elastic\Elasticsearch\elasticsearch-8.5.3/lib/elasticsearch-cli-8.5.3.jar;C:\Program Files\Elastic\Elasticsearch\elasticsearch-8.5.3/lib/elasticsearch-core-8.5.3.jar;C:\Program Files\Elastic\Elasticsearch\elasticsearch-8.5.3/lib/elasticsearch-geo-8.5.3.jar;C:\Program Files\Elastic\Elasticsearch\elasticsearch-8.5.3/lib/elasticsearch-log4j-8.5.3.jar;C:\Program Files\Elastic\Elasticsearch\elasticsearch-8.5.3/lib/elasticsearch-logging-8.5.3.jar;C:\Program Files\Elastic\Elasticsearch\elasticsearch-8.5.3/lib/elasticsearch-lz4-8.5.3.jar;C:\Program Files\Elastic\Elasticsearch\elasticsearch-8.5.3/lib/elasticsearch-plugin-analysis-api-8.5.3.jar;C:\Program Files\Elastic\Elasticsearch\elasticsearch-8.5.3/lib/elasticsearch-plugin-api-8.5.3.jar;C:\Program Files\Elastic\Elasticsearch\elasticsearch-8.5.3/lib/elasticsearch-plugin-classloader-8.5.3.jar;C:\Program Files\Elastic\Elasticsearch\elasticsearch-8.5.3/lib/elasticsearch-secure-sm-8.5.3.jar;C:\Program Files\Elastic\Elasticsearch\elasticsearch-8.5.3/lib/elasticsearch-x-content-8.5.3.jar;C:\Program Files\Elastic\Elasticsearch\elasticsearch-8.5.3/lib/HdrHistogram-2.1.9.jar;C:\Program Files\Elastic\Elasticsearch\elasticsearch-8.5.3/lib/hppc-0.8.1.jar;C:\Program Files\Elastic\Elasticsearch\elasticsearch-8.5.3/lib/jna-5.10.0.jar;C:\Program Files\Elastic\Elasticsearch\elasticsearch-8.5.3/lib/jopt-simple-5.0.2.jar;C:\Program Files\Elastic\Elasticsearch\elasticsearch-8.5.3/lib/log4j-api-2.18.0.jar;C:\Program Files\Elastic\Elasticsearch\elasticsearch-8.5.3/lib/log4j2-ecs-layout-1.2.0.jar;C:\Program Files\Elastic\Elasticsearch\elasticsearch-8.5.3/lib/lucene-analysis-common-9.4.2.jar;C:\Program Files\Elastic\Elasticsearch\elasticsearch-8.5.3/lib/lucene-backward-codecs-9.4.2.jar;C:\Program Files\Elastic\Elasticsearch\elasticsearch-8.5.3/lib/lucene-core-9.4.2.jar;C:\Program Files\Elastic\Elasticsearch\elasticsearch-8.5.3/lib/lucene-grouping-9.4.2.jar;C:\Program Files\Elastic\Elasticsearch\elasticsearch-8.5.3/lib/lucene-highlighter-9.4.2.jar;C:\Program Files\Elastic\Elasticsearch\elasticsearch-8.5.3/lib/lucene-join-9.4.2.jar;C:\Program Files\Elastic\Elasticsearch\elasticsearch-8.5.3/lib/lucene-memory-9.4.2.jar;C:\Program Files\Elastic\Elasticsearch\elasticsearch-8.5.3/lib/lucene-misc-9.4.2.jar;C:\Program Files\Elastic\Elasticsearch\elasticsearch-8.5.3/lib/lucene-queries-9.4.2.jar;C:\Program Files\Elastic\Elasticsearch\elasticsearch-8.5.3/lib/lucene-queryparser-9.4.2.jar;C:\Program Files\Elastic\Elasticsearch\elasticsearch-8.5.3/lib/lucene-sandbox-9.4.2.jar;C:\Program Files\Elastic\Elasticsearch\elasticsearch-8.5.3/lib/lucene-suggest-9.4.2.jar;C:\Program Files\Elastic\Elasticsearch\elasticsearch-8.5.3/lib/lz4-java-1.8.0.jar;C:\Program Files\Elastic\Elasticsearch\elasticsearch-8.5.3/lib/t-digest-3.2.jar;C:\Program Files\Elastic\Elasticsearch\elasticsearch-8.5.3/lib/cli-launcher/cli-launcher-8.5.3.jar
[2022-12-29 16:51:55] [debug] ( javajni.c:817 ) [7008] JVM Option[7] exit
[2022-12-29 16:51:55] [debug] ( javajni.c:817 ) [7008] JVM Option[8] abort
[2022-12-29 16:51:56] [debug] ( javajni.c:817 ) [7008] JVM Option[9] -Xss1024k
[2022-12-29 16:51:56] [debug] ( javajni.c:1003) [7008] argv[0] = --quiet
[2022-12-29 16:51:56] [debug] ( javajni.c:1062) [7008] Java worker thread started for org/elasticsearch/launcher/CliToolLauncher:main
[2022-12-29 16:51:56] [debug] ( javajni.c:1068) [7008] JNI calling static void method org/elasticsearch/launcher/CliToolLauncher:main
[2022-12-29 16:51:56] [debug] ( javajni.c:566 ) [8076] Exit hook with exit code 64
[2022-12-29 16:51:56] [debug] ( prunsrv.c:1199) [8076] Start exit hook called...
[2022-12-29 16:51:56] [debug] ( prunsrv.c:1200) [8076] JVM exit code: 64.

```

I have installed the service but when trying to start it I get the same error message.  
Any ideas what I'm missing?

Thanks!

/Kristoffer

---

<div class="post-metadata">

**Author:** ![mbooh](https://avatars.discourse-cdn.com/v4/letter/m/e495f1/32.png) [@mbooh](https://discuss.elastic.co/u/mbooh)\
**Post date:** [January 4, 2023, 3:39pm UTC](https://discuss.elastic.co/t/after-upgrade-from-8-2-2-to-8-5-3-elasticsearch-bat-works-just-fine-but-the-elasticsearch-service-bat-start-fails/322167/2 "2023-01-04T15:39:25Z")

</div>

Hi, I still get this no matter how I try. Any ideas? Thanks!

/Kristoffer

---

<div class="post-metadata">

**Author:** ![mbooh](https://avatars.discourse-cdn.com/v4/letter/m/e495f1/32.png) [@mbooh](https://discuss.elastic.co/u/mbooh)\
**Post date:** [January 18, 2023, 4:59pm UTC](https://discuss.elastic.co/t/after-upgrade-from-8-2-2-to-8-5-3-elasticsearch-bat-works-just-fine-but-the-elasticsearch-service-bat-start-fails/322167/3 "2023-01-18T16:59:53Z")

</div>

Hi,  
Now I got it to work. I used:

```auto
 elasticsearch-service.bat remove 

```

to remove the existing one and then

```auto
 elasticsearch-service.bat install

```

and the service started.

/Kristoffer

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [February 15, 2023, 5:00pm UTC](https://discuss.elastic.co/t/after-upgrade-from-8-2-2-to-8-5-3-elasticsearch-bat-works-just-fine-but-the-elasticsearch-service-bat-start-fails/322167/4 "2023-02-15T17:00:07Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
