# After upgrade to 8.2.10 from 7.17, I can not login to Kibana

**URL:** https://discuss.elastic.co/t/after-upgrade-to-8-2-10-from-7-17-i-can-not-login-to-kibana/343739
**Category:** Kibana
**Created:** [September 25, 2023, 9:55am UTC](https://discuss.elastic.co/t/after-upgrade-to-8-2-10-from-7-17-i-can-not-login-to-kibana/343739 "2023-09-25T09:55:18Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![Mostafa\_Faridi](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mostafa_faridi/32/121792_2.png) [@Mostafa\_Faridi](https://discuss.elastic.co/u/Mostafa_Faridi)
#### Post date: [September 25, 2023, 9:55am UTC](https://discuss.elastic.co/t/after-upgrade-to-8-2-10-from-7-17-i-can-not-login-to-kibana/343739/1 "2023-09-25T09:55:18Z")

</div>

I had Elastic stack 7.10 and upgarde to 7.17 and after that upgrade it to latest, but after upgrade to latest when I type [http://1.2.3.4:5601](http://1.2.3.4:5601) , it can not login and I see this error

```auto
Kibana server is not ready yet.

```

and I see this errors too

```auto
Sep 25 13:23:44 u_log kibana[12762]: [2023-09-25T13:23:44.807+03:30][INFO][savedobjects-service] [.kibana_security_solution] CREATE_REINDEX_TEMP -> CREATE_REINDEX_TEMP. took: 64008ms.
Sep 25 13:23:44 u_log kibana[12762]: [2023-09-25T13:23:44.814+03:30][ERROR][savedobjects-service] [.kibana_task_manager] Action failed with 'security_exception
Sep 25 13:23:44 u_log kibana[12762]: Root causes:
Sep 25 13:23:44 u_log kibana[12762]: security_exception: action [indices:admin/mapping/put] is unauthorized for user [elastic] with effective roles [superuser] on restricted indices [.kibana_task_manager_7.17.
0_001], this action is granted by the index privileges [manage,all]'. Retrying attempt 11 in 64 seconds.
Sep 25 13:23:44 u_log kibana[12762]: [2023-09-25T13:23:44.815+03:30][INFO][savedobjects-service] [.kibana_task_manager] UPDATE_SOURCE_MAPPINGS_PROPERTIES -> UPDATE_SOURCE_MAPPINGS_PROPERTIES. took: 64003ms.
Sep 25 13:23:44 u_log kibana[12762]: [2023-09-25T13:23:44.818+03:30][ERROR][savedobjects-service] [.kibana] Action failed with 'security_exception
Sep 25 13:23:44 u_log kibana[12762]: Root causes:
Sep 25 13:23:44 u_log kibana[12762]: security_exception: action [indices:admin/block/add] is unauthorized for user [elastic] with effective roles [superuser] on restricted indices [.kibana_7.17.0_001], this ac
tion is granted by the index privileges [manage,all]'. Retrying attempt 11 in 64 seconds.
Sep 25 13:23:44 u_log kibana[12762]: [2023-09-25T13:23:44.819+03:30][INFO][savedobjects-service] [.kibana] SET_SOURCE_WRITE_BLOCK -> SET_SOURCE_WRITE_BLOCK. took: 64003ms.

```

I search around and I see I have to set permisions but I can nto acces to UI of Kibana and I can not config it

---

<div class="post-metadata">

### Author: ![Priscilla\_Parodi](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/priscilla_parodi/32/43047_2.png) [@Priscilla\_Parodi](https://discuss.elastic.co/u/Priscilla_Parodi)
#### Post date: [October 1, 2023, 11:55pm UTC](https://discuss.elastic.co/t/after-upgrade-to-8-2-10-from-7-17-i-can-not-login-to-kibana/343739/2 "2023-10-01T23:55:05Z")

</div>

Hello @Mostafa_Faridi ,

When you curl elasticsearch with basic auth (your elastic username and password) do you get the default response from Elasticsearch?

If not, [reset your built in users](https://www.elastic.co/guide/en/elasticsearch/reference/8.10/reset-password.html?) and try again.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [October 29, 2023, 11:55pm UTC](https://discuss.elastic.co/t/after-upgrade-to-8-2-10-from-7-17-i-can-not-login-to-kibana/343739/3 "2023-10-29T23:55:21Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
