# After upgrading ES version, new node cannot join to the cluster

**URL:** <https://discuss.elastic.co/t/after-upgrading-es-version-new-node-cannot-join-to-the-cluster/295520>\
**Category:** Elasticsearch\
**Created:** [January 26, 2022, 11:03pm UTC](https://discuss.elastic.co/t/after-upgrading-es-version-new-node-cannot-join-to-the-cluster/295520 "2022-01-26T23:03:45Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![judy\_gao](https://avatars.discourse-cdn.com/v4/letter/j/7ab992/32.png) [@judy\_gao](https://discuss.elastic.co/u/judy_gao)\
**Post date:** [January 26, 2022, 11:03pm UTC](https://discuss.elastic.co/t/after-upgrading-es-version-new-node-cannot-join-to-the-cluster/295520/1 "2022-01-26T23:03:45Z")

</div>

After upgrading one node to ES 7.16.3, the new node cannot join the cluster, error from log :

```auto
[2022-01-26T22:33:34,365][DEBUG][o.e.d.PeerFinder] [ip-10-68-41-201.ec2.internal] address [[::1]:9304], node [null], requesting [false] connection failed
org.elasticsearch.transport.ConnectTransportException: [][[::1]:9304] connect_exception
        at org.elasticsearch.transport.TcpTransport$ChannelsConnectedListener.onFailure(TcpTransport.java:1047) ~[elasticsearch-7.16.3.jar:7.16.3]
        at org.elasticsearch.action.ActionListener.lambda$toBiConsumer$0(ActionListener.java:279) ~[elasticsearch-7.16.3.jar:7.16.3]
        at org.elasticsearch.core.CompletableContext.lambda$addListener$0(CompletableContext.java:31) ~[elasticsearch-core-7.16.3.jar:7.16.3]
        at java.util.concurrent.CompletableFuture.uniWhenComplete(CompletableFuture.java:863) ~[?:?]
        at java.util.concurrent.CompletableFuture$UniWhenComplete.tryFire(CompletableFuture.java:841) ~[?:?]
        at java.util.concurrent.CompletableFuture.postComplete(CompletableFuture.java:510) ~[?:?]
        at java.util.concurrent.CompletableFuture.completeExceptionally(CompletableFuture.java:2162) ~[?:?]
        at org.elasticsearch.core.CompletableContext.completeExceptionally(CompletableContext.java:46) ~[elasticsearch-core-7.16.3.jar:7.16.3]
        at org.elasticsearch.transport.netty4.Netty4TcpChannel.lambda$addListener$0(Netty4TcpChannel.java:58) ~[?:?]

```

Enabled DEBUG level log by adding "logger.org.Elasticsearch.discovery: DEBUG" , and didn't see any other info except those "connection refused" exception.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [February 23, 2022, 11:04pm UTC](https://discuss.elastic.co/t/after-upgrading-es-version-new-node-cannot-join-to-the-cluster/295520/2 "2022-02-23T23:04:04Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
