# After upgrading to 7.17.3 or 8.1.3 from 7.16.3 I get cannot get crawler to start with logs

**URL:** https://discuss.elastic.co/t/after-upgrading-to-7-17-3-or-8-1-3-from-7-16-3-i-get-cannot-get-crawler-to-start-with-logs/303332
**Category:** Beats
**Tags:** docker, filebeat
**Created:** [April 26, 2022, 9:41pm UTC](https://discuss.elastic.co/t/after-upgrading-to-7-17-3-or-8-1-3-from-7-16-3-i-get-cannot-get-crawler-to-start-with-logs/303332 "2022-04-26T21:41:49Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![Tony\_Powell](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tony_powell/32/104808_2.png) [@Tony\_Powell](https://discuss.elastic.co/u/Tony_Powell)
#### Post date: [April 26, 2022, 9:41pm UTC](https://discuss.elastic.co/t/after-upgrading-to-7-17-3-or-8-1-3-from-7-16-3-i-get-cannot-get-crawler-to-start-with-logs/303332/1 "2022-04-26T21:41:49Z")

</div>

in my helm values file I have the following and I was going to comment out the second log to see if it makes a difference

processors:  
# [Add Kubernetes metadata | Filebeat Reference [7.7] | Elastic](https://www.elastic.co/guide/en/beats/filebeat/7.7/add-kubernetes-metadata.html)  
- add\_kubernetes\_metadata:  
in\_cluster: true  
host: ${NODE\_NAME}  
matchers:  
- logs\_path:  
logs\_path: "/var/log/containers/"  
resource\_type: "container"  
- logs\_path:  
logs\_path: "/var/lib/docker/containers/"  
resource\_type: "container"  
but when it tries to start the pod I get the following:  
Exiting: Failed to start crawler: starting input failed: error while initializing input: fail to unpack the kubernetes configuration: invalid logs\_path defined for resource\_type: container │  
│ , valid value is `/var/log/containers/` accessing 'filebeat.inputs.0.processors.0.add\_kubernetes\_metadata' (source:'filebeat.yml')

---

<div class="post-metadata">

### Author: ![Andrea\_Spacca](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/andrea_spacca/32/76976_2.png) [@Andrea\_Spacca](https://discuss.elastic.co/u/Andrea_Spacca)
#### Post date: [April 27, 2022, 12:52am UTC](https://discuss.elastic.co/t/after-upgrading-to-7-17-3-or-8-1-3-from-7-16-3-i-get-cannot-get-crawler-to-start-with-logs/303332/2 "2022-04-27T00:52:39Z")

</div>

Hello @Tony_Powell , welcome to the Elastic community

I have to kindly ask you to post you the content of your configuration and the error message as `preformatted text`, since it has hard to understand if there is any formatting value (like the error message let me presume) without proper formatting

Thanks!

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [May 25, 2022, 2:53am UTC](https://discuss.elastic.co/t/after-upgrading-to-7-17-3-or-8-1-3-from-7-16-3-i-get-cannot-get-crawler-to-start-with-logs/303332/3 "2022-05-25T02:53:33Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
