# Alerting error: Can't get text on a START\_OBJECT

**URL:** https://discuss.elastic.co/t/alerting-error-cant-get-text-on-a-start-object/306781
**Category:** Kibana
**Tags:** elastic-stack-alerting
**Created:** [June 9, 2022, 10:06am UTC](https://discuss.elastic.co/t/alerting-error-cant-get-text-on-a-start-object/306781 "2022-06-09T10:06:16Z")
**Posts on this page:** 6
**Page:** 1

<div class="post-metadata">

### Author: ![Sandeep\_Raju](https://avatars.discourse-cdn.com/v4/letter/s/8797f3/32.png) [@Sandeep\_Raju](https://discuss.elastic.co/u/Sandeep_Raju)
#### Post date: [June 9, 2022, 10:06am UTC](https://discuss.elastic.co/t/alerting-error-cant-get-text-on-a-start-object/306781/1 "2022-06-09T10:06:16Z")

</div>

Hi all,

I'm trying to create an alert for a query so that it sends an email when that query condition is met.

When i try to create monitor & action, when i click on create -it throws an error-:  
`[illegal_state_exception] Can't get text on a START_OBJECT at 1:899`

I am not getting where the error is originating from and how to rectify it.  
Any clues?

---

<div class="post-metadata">

### Author: ![gmmorris](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/gmmorris/32/72624_2.png) [@gmmorris](https://discuss.elastic.co/u/gmmorris)
#### Post date: [June 9, 2022, 10:10am UTC](https://discuss.elastic.co/t/alerting-error-cant-get-text-on-a-start-object/306781/2 "2022-06-09T10:10:19Z")

</div>

Hi Sandeep,  
Can you post the query you're trying to use?  
Could you also clarify which rule type you're using?  
Perhaps a screenshot would help?

---

<div class="post-metadata">

### Author: ![Sandeep\_Raju](https://avatars.discourse-cdn.com/v4/letter/s/8797f3/32.png) [@Sandeep\_Raju](https://discuss.elastic.co/u/Sandeep_Raju)
#### Post date: [June 9, 2022, 10:26am UTC](https://discuss.elastic.co/t/alerting-error-cant-get-text-on-a-start-object/306781/3 "2022-06-09T10:26:42Z")

</div>

Hi @gmmorris ,

Below screenshots of my query :

 ![Screenshot 2022-06-09 at 3.47.29 PM](https://us1.discourse-cdn.com/elastic/original/3X/5/2/52a8036c7e684fab565eb53d212057e28c23f288.png)  
 ![Screenshot 2022-06-09 at 3.52.18 PM](https://us1.discourse-cdn.com/elastic/original/3X/5/4/5468207cca6ca8c716e2721943b6e11bc6f49db2.png)

So basically I was trying to query: to get avergage of total\_quantity...  
I'm getting the result when i do sample run.

But when i try to create monitor , it gives the error:  
`[illegal_state_exception] Can't get text on a START_OBJECT at 1:899`

---

<div class="post-metadata">

### Author: ![gmmorris](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/gmmorris/32/72624_2.png) [@gmmorris](https://discuss.elastic.co/u/gmmorris)
#### Post date: [June 9, 2022, 11:25am UTC](https://discuss.elastic.co/t/alerting-error-cant-get-text-on-a-start-object/306781/4 "2022-06-09T11:25:03Z")

</div>

Ah, I wasn't sure what you meant by _monitor_, but now I understand why.

Looking at the configuration above I believe you're not in fact using Elastic's Alerting framework, but rather Amazon's OpenSearch.  
This is not the Elastic distribution of Kibana, but rather an Amazon specific product ([see the differences here](https://www.elastic.co/aws-elasticsearch-service)). We, unfortunately, cannot offer support for Amazon's distribution (sadly I'm not familiar enough with their product to do so), so you may have better luck asking in their forums.

It's also worth noting that we do have an alerting feature as part of our distribution as well, which we are happy to offer support for: [https://www.elastic.co/what-is/kibana-alerting](https://www.elastic.co/what-is/kibana-alerting)

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [June 9, 2022, 11:25am UTC](https://discuss.elastic.co/t/alerting-error-cant-get-text-on-a-start-object/306781/5 "2022-06-09T11:25:04Z")

</div>

OpenSearch/OpenDistro are AWS run products and differ from the original Elasticsearch and Kibana products that Elastic builds and maintains. You may need to contact them directly for further assistance.

(This is an automated response from your friendly Elastic bot. Please report this post if you have any suggestions or concerns :elasticheart: )

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [July 7, 2022, 11:25am UTC](https://discuss.elastic.co/t/alerting-error-cant-get-text-on-a-start-object/306781/6 "2022-07-07T11:25:12Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
