# \[Alerting\] My alerts are broken after upgrading Elastic Cloud to 7.10.2

**URL:** <https://discuss.elastic.co/t/alerting-my-alerts-are-broken-after-upgrading-elastic-cloud-to-7-10-2/263898>\
**Category:** Kibana\
**Tags:** elastic-stack-security, elastic-stack-alerting\
**Created:** [February 10, 2021, 4:17pm UTC](https://discuss.elastic.co/t/alerting-my-alerts-are-broken-after-upgrading-elastic-cloud-to-7-10-2/263898 "2021-02-10T16:17:45Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![nickbabkin](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/nickbabkin/32/57493_2.png) [@nickbabkin](https://discuss.elastic.co/u/nickbabkin)\
**Post date:** [February 10, 2021, 4:17pm UTC](https://discuss.elastic.co/t/alerting-my-alerts-are-broken-after-upgrading-elastic-cloud-to-7-10-2/263898/1 "2021-02-10T16:17:45Z")

</div>

Hi!  
After upgrading ES cluster and Kibana to 7.10.2, I noticed that some of my alerts have started to throw error and hence refuse to work due to these error:

_An error occurred when decrypting the alert._  
_Unable to decrypt attribute "apiKey"_

I also get the same error every time I create a new alert.

My assumption is that it can happen when _xpack.encryptedSavedObjects_ parameter is not set in kibana (or a different key than was used before is set hence rendering decryption impossible). However, I don't have any control over this parameter in Elastic Cloud and I never changed/deleted it by myself.

Requesting community / dev help with this. Maybe there's a way to recreate alerts index and encrypt it with the current key? I tried to delete/create API keys, disable and reenable alerts - none of this helped. Also, how can I ensure same issue doesn't appear next time when I upgrade?

Screenshots attached.

Thanks!

[Screenshot 2021-02-10 at 5.16.18 PM|510x200](https://discuss.elastic.co/uploads/short-url/4J2wno9qKEywoiIAadZ3qnOVoT0.png)  
[Screenshot 2021-02-10 at 5.15.58 PM|690x453](https://discuss.elastic.co/uploads/short-url/lwScjI0J4Depa3Bc2UqQ9gHQH4j.png)

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [February 10, 2021, 9:18pm UTC](https://discuss.elastic.co/t/alerting-my-alerts-are-broken-after-upgrading-elastic-cloud-to-7-10-2/263898/2 "2021-02-10T21:18:23Z")

</div>

Have you reached out to the Support team about this one?

---

<div class="post-metadata">

**Author:** ![nickbabkin](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/nickbabkin/32/57493_2.png) [@nickbabkin](https://discuss.elastic.co/u/nickbabkin)\
**Post date:** [February 11, 2021, 6:27am UTC](https://discuss.elastic.co/t/alerting-my-alerts-are-broken-after-upgrading-elastic-cloud-to-7-10-2/263898/3 "2021-02-11T06:27:42Z")

</div>

Hi!  
Not yet, mostly due to the fact that I'm usually getting help from the community way faster than from the support 🙂

---

<div class="post-metadata">

**Author:** ![stephenb](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/stephenb/32/40856_2.png) [@stephenb](https://discuss.elastic.co/u/stephenb)\
**Post date:** [February 11, 2021, 6:38am UTC](https://discuss.elastic.co/t/alerting-my-alerts-are-broken-after-upgrading-elastic-cloud-to-7-10-2/263898/4 "2021-02-11T06:38:41Z")

</div>

@nickbabkin

I had a potentially similar issues I was told but did not do detailed analysis there is a potential race condition bug that causes that issue especially perhaps when Kibana under load.

Try disabling all those alerts, then open an alert, make a trivial change add a space, take out a space and save it and re-enable.

See if that works not a great suggestion but try one let us know... I would still persue support

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [March 11, 2021, 6:38am UTC](https://discuss.elastic.co/t/alerting-my-alerts-are-broken-after-upgrading-elastic-cloud-to-7-10-2/263898/5 "2021-03-11T06:38:54Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
