# Ошибка "all shards failed - Task cancelled before it started: channel closed"

**URL:** <https://discuss.elastic.co/t/all-shards-failed-task-cancelled-before-it-started-channel-closed/242199>\
**Category:** Вопросы на русском языке\
**Created:** [July 22, 2020, 1:16pm UTC](https://discuss.elastic.co/t/all-shards-failed-task-cancelled-before-it-started-channel-closed/242199 "2020-07-22T13:16:30Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![Sergei\_Frolov](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/sergei_frolov/32/47922_2.png) [@Sergei\_Frolov](https://discuss.elastic.co/u/Sergei_Frolov)\
**Post date:** [July 22, 2020, 1:16pm UTC](https://discuss.elastic.co/t/all-shards-failed-task-cancelled-before-it-started-channel-closed/242199/1 "2020-07-22T13:16:30Z")

</div>

Добрый день!

В логах наблюдаю ошибку временами:

```
[2020-07-22T16:00:15,317][WARN][r.suppressed] [wss-es-data5a.blabla] path: /indexname/_search, params: {pretty=true, index=indexname}
org.elasticsearch.action.search.SearchPhaseExecutionException: all shards failed
...
Caused by: org.elasticsearch.ElasticsearchException$1: Task cancelled before it started: channel closed
	at org.elasticsearch.ElasticsearchException.guessRootCauses(ElasticsearchException.java:644) ~[elasticsearch-7.7.1.jar:7.7.1]
	at org.elasticsearch.action.search.AbstractSearchAsyncAction.executeNextPhase(AbstractSearchAsyncAction.java:307) [elasticsearch-7.7.1.jar:7.7.1]
	... 49 more
Caused by: java.lang.IllegalStateException: Task cancelled before it started: channel closed
...

```

при этом кластер зеленый, ресурсы не сильно утилизируются

также наблюдаю:

`[2020-07-22T16:00:15,500][WARN][o.e.x.s.a.AuthorizationService] [wss-es-data5a.blabla.ru] denying access as action [internal:admin/tasks/ban] is not an index or cluster action`

возможно это как то связано с тем, что шарды отстреливаются?

версия 7.7.1

в логах go-приложения, которое работает с эластиком, в это время:

`2020/07/22 16:06:50 get user address stories failed elastic get: elastic: Error 400 (Bad Request): all shards failed [type=search_phase_execution_exception]`

---

<div class="post-metadata">

**Author:** ![Igor\_Motov](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/igor_motov/32/45193_2.png) [@Igor\_Motov](https://discuss.elastic.co/u/Igor_Motov)\
**Post date:** [July 22, 2020, 4:20pm UTC](https://discuss.elastic.co/t/all-shards-failed-task-cancelled-before-it-started-channel-closed/242199/2 "2020-07-22T16:20:46Z")

</div>

Первая ошибка - это значит клиент закрыл соединение или оно оборвалось по какой-то другой причине. Это нормально, если на клиенте стоит таймаут, и запросы занимают долгое время.

Вторая ошибка - это баг, исправленный в 7.7.2 [https://github.com/elastic/elasticsearch/pull/55404](https://github.com/elastic/elasticsearch/pull/55404)

В последнем случае - надо смотреть на всю ошибку, по этой информации ничего сказать не могу.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [August 19, 2020, 4:20pm UTC](https://discuss.elastic.co/t/all-shards-failed-task-cancelled-before-it-started-channel-closed/242199/3 "2020-08-19T16:20:47Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
