# All Stack monitoring alert rules with error

**URL:** <https://discuss.elastic.co/t/all-stack-monitoring-alert-rules-with-error/281870>\
**Category:** Kibana\
**Tags:** elastic-stack-monitoring\
**Created:** [August 18, 2021, 7:13pm UTC](https://discuss.elastic.co/t/all-stack-monitoring-alert-rules-with-error/281870 "2021-08-18T19:13:06Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![gbeltramelli](https://avatars.discourse-cdn.com/v4/letter/g/838e76/32.png) [@gbeltramelli](https://discuss.elastic.co/u/gbeltramelli)\
**Post date:** [August 18, 2021, 7:13pm UTC](https://discuss.elastic.co/t/all-stack-monitoring-alert-rules-with-error/281870/1 "2021-08-18T19:13:06Z")

</div>

Hello, I am new to elastic and sorry for my english!i have a problem, we are just implementing an ELK stack and all the default alerts of the stack monitoring are in Error with the following message

An error occurred when running the rule.  
illegal\_argument\_exception, caused by: ""

we are using version 7.13.4 with two kibanas, two logstash and three elasticsearch.

---

<div class="post-metadata">

**Author:** ![monfera](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/monfera/32/26467_2.png) [@monfera](https://discuss.elastic.co/u/monfera)\
**Post date:** [August 20, 2021, 1:44pm UTC](https://discuss.elastic.co/t/all-stack-monitoring-alert-rules-with-error/281870/2 "2021-08-20T13:44:00Z")

</div>

Based on info in this ticket, it may be a duplicate of [Built in alerts fail to run](https://discuss.elastic.co/t/built-in-alerts-fail-to-run/281207) which I just responded on

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [September 17, 2021, 1:44pm UTC](https://discuss.elastic.co/t/all-stack-monitoring-alert-rules-with-error/281870/3 "2021-09-17T13:44:45Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
