# Allocation fails on newly added nodes

**URL:** https://discuss.elastic.co/t/allocation-fails-on-newly-added-nodes/318120
**Category:** Elasticsearch
**Created:** [November 3, 2022, 4:06pm UTC](https://discuss.elastic.co/t/allocation-fails-on-newly-added-nodes/318120 "2022-11-03T16:06:01Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![sbk-elk](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/sbk-elk/32/73414_2.png) [@sbk-elk](https://discuss.elastic.co/u/sbk-elk)
#### Post date: [November 3, 2022, 4:06pm UTC](https://discuss.elastic.co/t/allocation-fails-on-newly-added-nodes/318120/1 "2022-11-03T16:06:01Z")

</div>

Hello Guys,

Anyone know why the below error occurs when shard allocation happens. We added a few nodes to the existing cluster and this started happening as soon as we enabled the allocations.

```auto
[indices:data/write/bulk[s][r]]]; nested: ElasticsearchSecurityException[action [indices:data/write/bulk[s][r]] requires authentication]; ], allocation_status[no_attempt]], expected_shard_size[856524144]

```

---

<div class="post-metadata">

### Author: ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)
#### Post date: [November 4, 2022, 1:27am UTC](https://discuss.elastic.co/t/allocation-fails-on-newly-added-nodes/318120/2 "2022-11-04T01:27:38Z")

</div>

We aren't all guys 🙂

Can you please share more of the log? It'd be good to see what is in the master node's log at this time too.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [December 2, 2022, 1:28am UTC](https://discuss.elastic.co/t/allocation-fails-on-newly-added-nodes/318120/3 "2022-12-02T01:28:19Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
