# "An internal server error occurred" when looking at Uptime monitors

**URL:** <https://discuss.elastic.co/t/an-internal-server-error-occurred-when-looking-at-uptime-monitors/285411>\
**Category:** Synthetics\
**Created:** [September 28, 2021, 9:29pm UTC](https://discuss.elastic.co/t/an-internal-server-error-occurred-when-looking-at-uptime-monitors/285411 "2021-09-28T21:29:53Z")\
**Posts on this page:** 7\
**Page:** 1

<div class="post-metadata">

**Author:** ![Tadija](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tadija/32/94785_2.png) [@Tadija](https://discuss.elastic.co/u/Tadija)\
**Post date:** [September 28, 2021, 9:29pm UTC](https://discuss.elastic.co/t/an-internal-server-error-occurred-when-looking-at-uptime-monitors/285411/1 "2021-09-28T21:29:53Z")

</div>

I have the latest version of elastic cloud deployment (v7.15.0).

I have 3 instances of heartbeat v7.15.0 running on 3 separate machines pinging same websites and all are sending to same index. Their `heartbeat.yml` files are identical.

I'm receiving data from heartbeat and can discover and can create visualizations/dashboards with that data. But when I go to **Observability** \> **Uptime** \> **Monitors** I'm greeted with "An internal server error occurred" message!

I tried

- Stopping all HB instances
- Deleting the Index
- Confirming that the Uptime page shows warning about Index being empty
- Starting only one HB instance

But the Uptime page stills shows the error.

 ![image](https://us1.discourse-cdn.com/elastic/original/3X/9/5/95eef148a1dba5ac95f73fbb60dcf8e7e01cd3c9.png)

---

<div class="post-metadata">

**Author:** ![Andrew\_Cholakian1](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/andrew_cholakian1/32/3612_2.png) [@Andrew\_Cholakian1](https://discuss.elastic.co/u/Andrew_Cholakian1)\
**Post date:** [September 28, 2021, 10:07pm UTC](https://discuss.elastic.co/t/an-internal-server-error-occurred-when-looking-at-uptime-monitors/285411/2 "2021-09-28T22:07:13Z")

</div>

We're currently working on a way to prevent this from happening, but for now you can correct it by following the instructions [here](https://www.elastic.co/guide/en/observability/7.x/troubleshoot-uptime-mapping-issues.html).

Apologies for the inconvenience!

---

<div class="post-metadata">

**Author:** ![Tadija](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tadija/32/94785_2.png) [@Tadija](https://discuss.elastic.co/u/Tadija)\
**Post date:** [September 29, 2021, 7:00am UTC](https://discuss.elastic.co/t/an-internal-server-error-occurred-when-looking-at-uptime-monitors/285411/3 "2021-09-29T07:00:11Z")

</div>

Hi Andrew, thank you for the reply.

Unfortunately, the proposed correction did not help.

I did all the steps (ran heartbeat setup and everything) but I'm still getting the error message.

I guess I'll wait for the next version (I'm currently on v7.15.0)

Is there a place where I can track the progress of this?

---

<div class="post-metadata">

**Author:** ![shahzad31](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/shahzad31/32/51637_2.png) [@shahzad31](https://discuss.elastic.co/u/shahzad31)\
**Post date:** [September 29, 2021, 11:45am UTC](https://discuss.elastic.co/t/an-internal-server-error-occurred-when-looking-at-uptime-monitors/285411/4 "2021-09-29T11:45:04Z")

</div>

@Tadija can you please try setting this session variable when you open uptime app  
you will have to open browser dev tools

`sessionStorage.setItem('uptime_debug', true)`

after this hit refresh and you will see the queries uptime uses in the kibana log.

copy/paste few of those queries and try running those in the kibana dev tools.

and see if it returns any data.

Regards

---

<div class="post-metadata">

**Author:** ![Andrew\_Cholakian1](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/andrew_cholakian1/32/3612_2.png) [@Andrew\_Cholakian1](https://discuss.elastic.co/u/Andrew_Cholakian1)\
**Post date:** [September 29, 2021, 1:01pm UTC](https://discuss.elastic.co/t/an-internal-server-error-occurred-when-looking-at-uptime-monitors/285411/5 "2021-09-29T13:01:42Z")

</div>

@Tadija to be clear, we haven't started work on the [fix](https://github.com/elastic/beats/issues/27874). I would like to see it in 7.16.0, but that may not happen.

This issue should be fixable by following those steps. If it didn't work the likely cause was that you did not shut down all heartbeats before deleting indices and aliases. If one heartbeat is running it will mess up the mappings again.

---

<div class="post-metadata">

**Author:** ![Tadija](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tadija/32/94785_2.png) [@Tadija](https://discuss.elastic.co/u/Tadija)\
**Post date:** [October 1, 2021, 11:27am UTC](https://discuss.elastic.co/t/an-internal-server-error-occurred-when-looking-at-uptime-monitors/285411/6 "2021-10-01T11:27:12Z")

</div>

@shahzad31 I've set the uptime\_debug=true via chrome dev tools, but I'm not sure where can I see uptime queries.

 ![image](https://us1.discourse-cdn.com/elastic/original/3X/1/d/1d293da1025c840143abc904efc53ae48f581163.png)

@Andrew_Cholakian1 is there a way for me to set the `require_alias=true` setting mentioned here: [[libbeat] ILM writes should use `require_alias=true` · Issue #27874 · elastic/beats · GitHub](https://github.com/elastic/beats/issues/27874) ?

Also, I've removed the solution mark since proposed steps did not fix the issue. I would be happy with some workaround. I followed the linked steps a couple of times, unfortunately the y do not help.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [October 25, 2021, 11:28am UTC](https://discuss.elastic.co/t/an-internal-server-error-occurred-when-looking-at-uptime-monitors/285411/7 "2021-10-25T11:28:07Z")

</div>

This topic was automatically closed 24 days after the last reply. New replies are no longer allowed.
