# An internal server error occurred

**URL:** <https://discuss.elastic.co/t/an-internal-server-error-occurred/163525>\
**Category:** Kibana\
**Created:** [January 9, 2019, 12:08pm UTC](https://discuss.elastic.co/t/an-internal-server-error-occurred/163525 "2019-01-09T12:08:06Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![harsh25](https://avatars.discourse-cdn.com/v4/letter/h/71c47a/32.png) [@harsh25](https://discuss.elastic.co/u/harsh25)\
**Post date:** [January 9, 2019, 12:08pm UTC](https://discuss.elastic.co/t/an-internal-server-error-occurred/163525/1 "2019-01-09T12:08:06Z")

</div>

Hi There,  
We are getting internal error occurred for Kibana.  
We are using elasticsearch-5.6.2  
kibana-5.6.2-linux-x86\_64

It running fine on test environment and we are getting issue on UAT environment. Not sure what exactly causing this issue.

PFB the Kibana error Logs  
{"type":"error","@timestamp":"2019-01-09T10:45:06Z","tags":,"pid":106076,"level":"error","message":"Cannot provide statusCode or message with boom error","error":{"message":"Cannot provide statusCode or message with boom error","name":"Error","stack":"Error: Cannot provide statusCode or message with boom error\n at Object.exports.assert (/app/pkgs/kibana/kibana-5.6.2-linux-x86\_64/node\_modules/hoek/lib/index.js:736:11)\n at Object.exports.wrap (/app/pkgs/kibana/kibana-5.6.2-linux-x86\_64/node\_modules/boom/lib/index.js:96:10)\n at convertEsError (/app/pkgs/kibana/kibana-5.6.2-linux-x86\_64/src/server/index\_patterns/service/lib/errors.js:67:25)\n at /app/pkgs/kibana/kibana-5.6.2-linux-x86\_64/src/server/index\_patterns/service/lib/es\_api.js:63:40\n at throw (native)\n at step (/app/pkgs/kibana/kibana-5.6.2-linux-x86\_64/src/server/index\_patterns/service/lib/es\_api.js:74:191)\n at /app/pkgs/kibana/kibana-5.6.2-linux-x86\_64/src/server/index\_patterns/service/lib/es\_api.js:74:402"},"url":{"protocol":null,"slashes":null,"auth":null,"host":null,"port":null,"hostname":null,"hash":null,"search":"?pattern=logstash-_&meta\_fields=%5B%22\_source%22%2C%22\_id%22%2C%22\_type%22%2C%22\_index%22%2C%22\_score%22%5D","query":{"pattern":"logstash-_","meta\_fields":"["\_source","\_id","\_type","\_index","\_score"]"},"pathname":"/api/index\_patterns/\_fields\_for\_wildcard","path":"/api/index\_patterns/\_fields\_for\_wildcard?pattern=logstash-_&meta\_fields=%5B%22\_source%22%2C%22\_id%22%2C%22\_type%22%2C%22\_index%22%2C%22\_score%22%5D","href":"/api/index\_patterns/\_fields\_for\_wildcard?pattern=logstash-_&meta\_fields=%5B%22\_source%22%2C%22\_id%22%2C%22\_type%22%2C%22\_index%22%2C%22\_score%22%5D"}}

---

<div class="post-metadata">

**Author:** ![Aaron\_Caldwell](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/aaron_caldwell/32/45755_2.png) [@Aaron\_Caldwell](https://discuss.elastic.co/u/Aaron_Caldwell)\
**Post date:** [January 9, 2019, 5:17pm UTC](https://discuss.elastic.co/t/an-internal-server-error-occurred/163525/2 "2019-01-09T17:17:01Z")

</div>

Hello Harsh,

It looks like this could be solved by upgrading to 5.6.3. I found this thread which identifies this same issue on your current version (5.6.2): [https://github.com/elastic/kibana/issues/14021](https://github.com/elastic/kibana/issues/14021)

Thanks,  
Aaron

---

<div class="post-metadata">

**Author:** ![harsh25](https://avatars.discourse-cdn.com/v4/letter/h/71c47a/32.png) [@harsh25](https://discuss.elastic.co/u/harsh25)\
**Post date:** [January 10, 2019, 8:46am UTC](https://discuss.elastic.co/t/an-internal-server-error-occurred/163525/3 "2019-01-10T08:46:37Z")

</div>

Hi Aaron,  
Thanks for your reply. But as I said earlier, its working fine on the test environment with same version.  
I have compared the configs and haven't found any difference on both environment.

Is any other thing I can check from my end?

---

<div class="post-metadata">

**Author:** ![harsh25](https://avatars.discourse-cdn.com/v4/letter/h/71c47a/32.png) [@harsh25](https://discuss.elastic.co/u/harsh25)\
**Post date:** [January 10, 2019, 10:47am UTC](https://discuss.elastic.co/t/an-internal-server-error-occurred/163525/4 "2019-01-10T10:47:05Z")

</div>

Quick update, I found the issue. The x-pack plugin was not installed for Kibana. It was present for elastic.  
Post installation the Internal server error gone.  
[https://www.elastic.co/guide/en/kibana/5.6/installing-xpack-kb.html](https://www.elastic.co/guide/en/kibana/5.6/installing-xpack-kb.html)

Thanks.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [February 7, 2019, 10:47am UTC](https://discuss.elastic.co/t/an-internal-server-error-occurred/163525/5 "2019-02-07T10:47:10Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
