# An unexpected error occurred! {:error=\>#\<ArgumentError: Setting "" hasn't been registered\>

**URL:** https://discuss.elastic.co/t/an-unexpected-error-occurred-error-argumenterror-setting-hasnt-been-registered/143324
**Category:** Logstash
**Created:** [August 7, 2018, 12:35pm UTC](https://discuss.elastic.co/t/an-unexpected-error-occurred-error-argumenterror-setting-hasnt-been-registered/143324 "2018-08-07T12:35:35Z")
**Posts on this page:** 5
**Page:** 1

<div class="post-metadata">

### Author: ![Arpit\_Gulati](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/arpit_gulati/32/48349_2.png) [@Arpit\_Gulati](https://discuss.elastic.co/u/Arpit_Gulati)
#### Post date: [August 7, 2018, 12:35pm UTC](https://discuss.elastic.co/t/an-unexpected-error-occurred-error-argumenterror-setting-hasnt-been-registered/143324/1 "2018-08-07T12:35:35Z")

</div>

I update the logstash verion from 2.4.0 to 5.4.0 using a tar file but when I start the logstash using ./bin/logstash -f conf.d/logstash.conf command . I got an error  
[FATAL][logstash.runner] An unexpected error occurred! {:error=\>#\<ArgumentError: Setting "" hasn't been registered\>, :backtrace=\>["/home/mpweb/work/install/ELK/logstash/logstash-5.4.0/logstash-core/lib/logstash/settings.rb:29:in `get_setting'", "/home/mpweb/work/install/ELK/logstash/logstash-5.4.0/logstash-core/lib/logstash/settings.rb:61:in`set\_value'", "/home/mpweb/work/install/ELK/logstash/logstash-5.4.0/logstash-core/lib/logstash/settings.rb:80:in `merge'", "org/jruby/RubyHash.java:1342:in`each'", "/home/mpweb/work/install/ELK/logstash/logstash-5.4.0/logstash-core/lib/logstash/settings.rb:80:in `merge'", "/home/mpweb/work/install/ELK/logstash/logstash-5.4.0/logstash-core/lib/logstash/settings.rb:129:in`validate\_all'", "/home/mpweb/work/install/ELK/logstash/logstash-5.4.0/logstash-core/lib/logstash/runner.rb:217:in `execute'", "/home/mpweb/work/install/ELK/logstash/logstash-5.4.0/vendor/bundle/jruby/1.9/gems/clamp-0.6.5/lib/clamp/command.rb:67:in`run'", "/home/mpweb/work/install/ELK/logstash/logstash-5.4.0/logstash-core/lib/logstash/runner.rb:185:in `run'", "/home/mpweb/work/install/ELK/logstash/logstash-5.4.0/vendor/bundle/jruby/1.9/gems/clamp-0.6.5/lib/clamp/command.rb:132:in`run'", "/home/mpweb/work/install/ELK/logstash/logstash-5.4.0/lib/bootstrap/environment.rb:71:in `(root)'"]}

Plese help me out....

---

<div class="post-metadata">

### Author: ![yaauie](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/yaauie/32/23363_2.png) [@yaauie](https://discuss.elastic.co/u/yaauie)
#### Post date: [August 8, 2018, 12:27am UTC](https://discuss.elastic.co/t/an-unexpected-error-occurred-error-argumenterror-setting-hasnt-been-registered/143324/2 "2018-08-08T00:27:56Z")

</div>

Eep. It looks like there's something funky going on with your `config/logstash.yml`; can you paste what you've got?

5.4.0 is still pretty far back; if you can't upgrade to Logstash 6, you'll likely have better luck running the latest possible 5.x (which is currently [5.6.10](https://www.elastic.co/downloads/past-releases/logstash-5-6-10))

---

<div class="post-metadata">

### Author: ![Arpit\_Gulati](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/arpit_gulati/32/48349_2.png) [@Arpit\_Gulati](https://discuss.elastic.co/u/Arpit_Gulati)
#### Post date: [August 8, 2018, 5:35am UTC](https://discuss.elastic.co/t/an-unexpected-error-occurred-error-argumenterror-setting-hasnt-been-registered/143324/3 "2018-08-08T05:35:42Z")

</div>

Problem Solved and Thanks for your Reply...

---

<div class="post-metadata">

### Author: ![Arpit\_Gulati](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/arpit_gulati/32/48349_2.png) [@Arpit\_Gulati](https://discuss.elastic.co/u/Arpit_Gulati)
#### Post date: [August 8, 2018, 5:37am UTC](https://discuss.elastic.co/t/an-unexpected-error-occurred-error-argumenterror-setting-hasnt-been-registered/143324/4 "2018-08-08T05:37:04Z")

</div>

Actually problem is with logstash.yml. I closed all parameters that I opened in logstash.yml. After I start it start working.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [September 5, 2018, 5:37am UTC](https://discuss.elastic.co/t/an-unexpected-error-occurred-error-argumenterror-setting-hasnt-been-registered/143324/5 "2018-09-05T05:37:15Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
