# Anonymous acces for Kibana through X-Pack

**URL:** <https://discuss.elastic.co/t/anonymous-acces-for-kibana-through-x-pack/95930>\
**Category:** Kibana\
**Created:** [August 4, 2017, 4:53pm UTC](https://discuss.elastic.co/t/anonymous-acces-for-kibana-through-x-pack/95930 "2017-08-04T16:53:57Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![Grevius](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/grevius/32/20698_2.png) [@Grevius](https://discuss.elastic.co/u/Grevius)\
**Post date:** [August 4, 2017, 4:53pm UTC](https://discuss.elastic.co/t/anonymous-acces-for-kibana-through-x-pack/95930/1 "2017-08-04T16:53:57Z")

</div>

Hello 🙂

I've changed my config according to [https://www.elastic.co/guide/en/x-pack/current/anonymous-access.html](https://www.elastic.co/guide/en/x-pack/current/anonymous-access.html) (plus kibana\_user role) and the user appeared in Kibana user management, but I don't know how I can access Kibana anonymously now. Accessing ES through REST is working anonymously.  
Is there any way to get it working with Kibana?

Thanks  
Grevius

---

<div class="post-metadata">

**Author:** ![Stacey\_Gammon](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/stacey_gammon/32/14025_2.png) [@Stacey\_Gammon](https://discuss.elastic.co/u/Stacey_Gammon)\
**Post date:** [August 8, 2017, 2:41pm UTC](https://discuss.elastic.co/t/anonymous-acces-for-kibana-through-x-pack/95930/2 "2017-08-08T14:41:37Z")

</div>

If you don't want the login screen to show up for anyone using Kibana, you can disable security in kibana.yml: `xpack.security.enabled: false`

This should work so that all users accessing Kibana will default to the anonymous user you set up.

---

<div class="post-metadata">

**Author:** ![Grevius](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/grevius/32/20698_2.png) [@Grevius](https://discuss.elastic.co/u/Grevius)\
**Post date:** [August 9, 2017, 8:53pm UTC](https://discuss.elastic.co/t/anonymous-acces-for-kibana-through-x-pack/95930/3 "2017-08-09T20:53:23Z")

</div>

Thanks for your answer. Apparently Kibana doesn't start if I set this option. Here's the log:

```
Aug 09 22:47:47 hostname systemd[1]: Started Kibana.
Aug 09 22:47:53 hostname kibana[30429]: {"type":"log","@timestamp":"2017-08-09T20:47:53Z","tags":["fatal"],"pid":30429,"level":"fatal","message":"EACCES: permission denied, open '/usr/share/kibana/optimize/bundles/graph.entry.js'","error":{"message":"EACCES: permission denied, open '/usr/share/kibana/optimize/bundles/graph.entry.js'","name":"Error","stack":"Error: EACCES: permission denied, open '/usr/share/kibana/optimize/bundles/graph.entry.js'\n at Error (native)","code":"EACCES"}}
Aug 09 22:47:53 hostname kibana[30429]: FATAL { Error: EACCES: permission denied, open '/usr/share/kibana/optimize/bundles/graph.entry.js'
Aug 09 22:47:53 hostname kibana[30429]: at Error (native)
Aug 09 22:47:53 hostname kibana[30429]: cause:
Aug 09 22:47:53 hostname kibana[30429]: { Error: EACCES: permission denied, open '/usr/share/kibana/optimize/bundles/graph.entry.js'
Aug 09 22:47:53 hostname kibana[30429]: at Error (native)
Aug 09 22:47:53 hostname kibana[30429]: errno: -13,
Aug 09 22:47:53 hostname kibana[30429]: code: 'EACCES',
Aug 09 22:47:53 hostname kibana[30429]: syscall: 'open',
Aug 09 22:47:53 hostname kibana[30429]: path: '/usr/share/kibana/optimize/bundles/graph.entry.js' },
Aug 09 22:47:53 hostname kibana[30429]: isOperational: true,
Aug 09 22:47:53 hostname kibana[30429]: errno: -13,
Aug 09 22:47:53 hostname kibana[30429]: code: 'EACCES',
Aug 09 22:47:53 hostname kibana[30429]: syscall: 'open',
Aug 09 22:47:53 hostname kibana[30429]: path: '/usr/share/kibana/optimize/bundles/graph.entry.js' }
Aug 09 22:47:53 hostname systemd[1]: kibana.service: Main process exited, code=exited, status=1/FAILURE
Aug 09 22:47:53 hostname systemd[1]: kibana.service: Unit entered failed state.
Aug 09 22:47:53 hostname systemd[1]: kibana.service: Failed with result 'exit-code'.
Aug 09 22:47:53 hostname systemd[1]: kibana.service: Service hold-off time over, scheduling restart.
Aug 09 22:47:53 hostname systemd[1]: Stopped Kibana.

```

When I revert the change Kibana starts fine... 🤨

**EDIT:**  
It turns out that this is a current bug: [https://github.com/elastic/kibana/issues/8818](https://github.com/elastic/kibana/issues/8818)

---

<div class="post-metadata">

**Author:** ![Grevius](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/grevius/32/20698_2.png) [@Grevius](https://discuss.elastic.co/u/Grevius)\
**Post date:** [August 16, 2017, 10:09pm UTC](https://discuss.elastic.co/t/anonymous-acces-for-kibana-through-x-pack/95930/4 "2017-08-16T22:09:32Z")

</div>

I've took this [workaround](https://github.com/elastic/kibana/issues/8845) and now I have the following problem:

 ![image](https://us1.discourse-cdn.com/elastic/original/3X/4/a/4a4f95abdb48aadfdbe7d3304355c94c2e83c43a.png)

Which roles or permissions does the anonymous user need? And it seems that it is now impossible to login into any other account. Is that the case?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [September 13, 2017, 10:09pm UTC](https://discuss.elastic.co/t/anonymous-acces-for-kibana-through-x-pack/95930/5 "2017-09-13T22:09:36Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
