# Anonymous user cannot log in

**URL:** <https://discuss.elastic.co/t/anonymous-user-cannot-log-in/365632>\
**Category:** Kibana\
**Tags:** elastic-stack-security\
**Created:** [August 27, 2024, 3:35pm UTC](https://discuss.elastic.co/t/anonymous-user-cannot-log-in/365632 "2024-08-27T15:35:40Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![rachelyang](https://avatars.discourse-cdn.com/v4/letter/r/51bf81/32.png) [@rachelyang](https://discuss.elastic.co/u/rachelyang)\
**Post date:** [August 27, 2024, 3:35pm UTC](https://discuss.elastic.co/t/anonymous-user-cannot-log-in/365632/1 "2024-08-27T15:35:41Z")

</div>

Hi Team,  
I added an anonymous user "development", but it cannot log in due to security error.

```auto
[security_exception Root causes: security_exception: unable to authenticate user [development] for REST request [/_security/_authenticate]]: unable to authenticate user [development] for REST request [/_security/_authenticate]

```

```auto
Error: [security_exception
	Root causes:
		security_exception: unable to authenticate user [development] for REST request [/_security/_authenticate]]: unable to authenticate user [development] for REST request [/_security/_authenticate]
    at login_form_LoginForm.loginWithSelector (https://kibana.newweb.com/8aa0b59da12c/bundles/plugin/security/1.0.0/security.chunk.6.js:3:29606)

```

Here is configuration in elasticsearch.yml:

```auto
xpack.security.authc:
  anonymous:
    username: development
    roles: Development
    authz_exception: true

```

And configuration in kibana.yml file

```auto
xpack.security.authc.providers:
  basic.basic1:
    order: 0
  anonymous.anonymous1:
    order: 1
    credentials:
      username: "development"
      password: "development"

```

What can I check?  
Thank you.

---

<div class="post-metadata">

**Author:** ![rachelyang](https://avatars.discourse-cdn.com/v4/letter/r/51bf81/32.png) [@rachelyang](https://discuss.elastic.co/u/rachelyang)\
**Post date:** [August 27, 2024, 7:32pm UTC](https://discuss.elastic.co/t/anonymous-user-cannot-log-in/365632/2 "2024-08-27T19:32:50Z")

</div>

I removed configuration in elasticsearch.yml, then it was fixed.
