# Ansible ECE install

**URL:** <https://discuss.elastic.co/t/ansible-ece-install/248349>\
**Category:** Elastic Cloud Enterprise (ECE)\
**Created:** [September 11, 2020, 2:47pm UTC](https://discuss.elastic.co/t/ansible-ece-install/248349 "2020-09-11T14:47:43Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![andrew.luke](https://avatars.discourse-cdn.com/v4/letter/a/2bfe46/32.png) [@andrew.luke](https://discuss.elastic.co/u/andrew.luke)\
**Post date:** [September 11, 2020, 2:47pm UTC](https://discuss.elastic.co/t/ansible-ece-install/248349/1 "2020-09-11T14:47:43Z")

</div>

I'm trying to use the Anisble install role following this:

> **[GitHub - elastic/ansible-elastic-cloud-enterprise: Ansible playbooks for...](https://github.com/elastic/ansible-elastic-cloud-enterprise)**
>
> Ansible playbooks for Elastic Cloud Enterprise (ECE) - GitHub - elastic/ansible-elastic-cloud-enterprise: Ansible playbooks for Elastic Cloud Enterprise (ECE)

and this:

> **[Automating the install of Elastic Cloud Enterprise on AWS with Ansible](https://www.elastic.co/blog/automating-the-install-of-elastic-cloud-enterprise-on-aws-with-ansible)**
>
> The title pretty much sums this up! This step-by-step blog deploys a small three-zone Elastic Cloud Enterprise environment using Elastic's Ansible role.

I've made up an inventory file for a small 1AZ hot/warm deployment. My plan is to setup up to a full 3AZ, but I'm having trouble getting this small version working. I installed the role via ansible-galaxy as in the blog post. Every time I run the playbook I set up to call the "ansible-elastic-cloud-enterprise" role it throws a syntax error in one of the elastic produced yml files as follows:

> ERROR! no action detected in task. This often indicates a misspelled module name, or incorrect module path.
> 
> The error appears to have been in '/etc/ansible/roles/ansible-elastic-cloud-enterprise/tasks/direct-install/main.yml': line 5, column 3, but may  
> be elsewhere in the file depending on the exact syntax problem.
> 
> The offending line appears to be:
> 
> - name: Reboot the machine with all defaults  
> ^ here

The error repeats its self several times in the output. I tried using the --skip-tags base, destructive to reduce the amount of tasks and I get the same error. I know its not getting to the part where it attempts a connection to the hosts in the inventory since I had an error in there and was getting the same error message. I fixed the error in my inventory and ran a simple playbook I wrote aginst it that connects to each ECE host, creates a file, and writes host variables from the inventory file to the newly created file. That runs just fine. I don't know why the direct-install/main.ym is throwing a syntax error. Any ideas? I'm calling it in my playbook like so:

```
---
- hosts: primary
  gather_facts: true
  roles:
    - ansible-elastic-cloud-enterprise
  vars:
    ece_primary: true

```

That's just an example of just the primary. I also have hot/warm/master hosts after that. Ideas?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [September 25, 2020, 2:47pm UTC](https://discuss.elastic.co/t/ansible-ece-install/248349/2 "2020-09-25T14:47:49Z")

</div>

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.
