Apache fields are disable


When I want to see all fields of my index in Discovery, my apache's fields are disable (I can see them only if I uncheck "hide missing fields").
In visualization, I can choose these fields but no data appears.

I added apache.yml and enabled it but It still doesn't work.

Someone have an idea ?


If you query the index directly, do you see data in these apache fields?


Your fields are hidden in discover because they don't have any value for the data in that timeperiod in discover.

Can you check if there is data for your index in elasticsearch and apply that timeperiod in discover?

There is no data and fields are hidden:

Here is an example:

I changed the time to pick the time for which we had data. You can see data and fields are not hidden:


I've other values & even if I add these hidden fields, there is nothing.
I'm sure there are values in my apache because I used them with another software (hp performance center & hp analysis) & I see apache workers busy and idle

I changed apache.yml to put :

- module: apache
  enabled: true
  period: 30s
    - status

Now I've only 2 fields :


But I still don't have :


This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.