# APM Agente - WAS 8.5.5.11 + Java 8 Error: JVMJ9VM135W /proc/sys/kernel/core\_pattern setting

**URL:** <https://discuss.elastic.co/t/apm-agente-was-8-5-5-11-java-8-error-jvmj9vm135w-proc-sys-kernel-core-pattern-setting/251499>\
**Category:** APM\
**Tags:** java\
**Created:** [October 8, 2020, 7:02pm UTC](https://discuss.elastic.co/t/apm-agente-was-8-5-5-11-java-8-error-jvmj9vm135w-proc-sys-kernel-core-pattern-setting/251499 "2020-10-08T19:02:18Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![amateur](https://avatars.discourse-cdn.com/v4/letter/a/77aa72/32.png) [@amateur](https://discuss.elastic.co/u/amateur)\
**Post date:** [October 8, 2020, 7:02pm UTC](https://discuss.elastic.co/t/apm-agente-was-8-5-5-11-java-8-error-jvmj9vm135w-proc-sys-kernel-core-pattern-setting/251499/1 "2020-10-08T19:02:18Z")

</div>

Please your help, when I start the WAS Node it does not raise and appears this error.

WAS 8.5.5.11  
Java SDK 8.0.6.15  
APM Agent: 1.18.1  
Centos 6.9-32bits

Thank you very much.

\*\*\*\*\*\*\*\*\*\*\*\*\* End Display Current Environment \*\*\*\*\*\*\*\*\*\*\*\*\*  
JVMJ9VM135W /proc/sys/kernel/core\_pattern setting "|/usr/libexec/abrt-hook-ccpp %s %c %p %u %g %t e" specifies that core dumps are to be piped to an external program. The JVM may be unable to locate core dumps and rename them.  
\*\*\*\*\*\*\*\*\*\*\*\* Start Display Current Environment \*\*\*\*\*\*\*\*\*\*\*\*  
Log file started at: [10/8/20 14:07:30:253 PDT]  
\*\*\*\*\*\*\*\*\*\*\*\*\* End Display Current Environment \*\*\*\*\*\*\*\*\*\*\*\*\*  
JVMJ9VM135W /proc/sys/kernel/core\_pattern setting "|/usr/libexec/abrt-hook-ccpp %s %c %p %u %g %t e" specifies that core dumps are to be piped to an external program. The JVM may be unable to locate core dumps and rename them.  
Error: Could not find or load main class   
JVMJ9VM135W /proc/sys/kernel/core\_pattern setting "|/usr/libexec/abrt-hook-ccpp %s %c %p %u %g %t e" specifies that core dumps are to be piped to an external program. The JVM may be unable to locate core dumps and rename them.  
Error: Could not find or load main class   
JVMJ9VM135W /proc/sys/kernel/core\_pattern setting "|/usr/libexec/abrt-hook-ccpp %s %c %p %u %g %t e" specifies that core dumps are to be piped to an external program. The JVM may be unable to locate core dumps and rename them.  
Error: Could not find or load main class   
JVMJ9VM135W /proc/sys/kernel/core\_pattern setting "|/usr/libexec/abrt-hook-ccpp %s %c %p %u %g %t e" specifies that core dumps are to be piped to an external program. The JVM may be unable to locate core dumps and rename them.  
Error: Could not find or load main class \

Other log File on WAS Server:

2020-10-08 16:50:33,789 [main] INFO co.elastic.apm.agent.util.JmxUtils - Found JVM-specific OperatingSystemMXBean interface: com.ibm.lang.management.OperatingSystemMXBean  
2020-10-08 16:50:33,852 [main] WARN co.elastic.apm.agent.metrics.builtin.CGroupMetrics - No /proc/self/cgroup file line matched the tested patterns. Cgroup metrics will not be reported.  
2020-10-08 16:50:35,335 [main] INFO co.elastic.apm.agent.configuration.StartupInfo - Starting Elastic APM 1.18.1 as - on Java 1.8.0\_261 Runtime version: 8.0.6.15 - pxi3280sr6fp15ifix-20200820\_01(SR6 FP15+IJ26443) VM version: 2.9 (IBM Corporation) Linux 2.6.32-754.33.1.el6.i686  
2020-10-08 16:50:35,363 [main] WARN co.elastic.apm.agent.configuration.StartupInfo - To enable all features and decrease startup time, please configure application\_packages  
2020-10-08 16:50:51,574 [main] INFO co.elastic.apm.agent.impl.ElasticApmTracer - Tracer switched to RUNNING state

We changed from OS RHEL 7.9 64bits, and it follows the same errors.

2020-10-08 23: 16: 42,509 [main] INFO co.elastic.apm.agent.util.JmxUtils - Found JVM-specific OperatingSystemMXBean interface: com.ibm.lang.management.OperatingSystemMXBean  
2020-10-08 23: 16: 42,544 [main] INFO co.elastic.apm.agent.configuration.StartupInfo - Starting Elastic APM 1.18.1 as - on Java 1.8.0\_261 Runtime version: 8.0.6.15 - pxa6480sr6fp15ifix-20200820\_01 ( SR6 FP15 + IJ26443) VM version: 2.9 (IBM Corporation) Linux 3.10.0-1160.2.1.el7.x86\_64  
2020-10-08 23: 16: 42,544 [main] WARN co.elastic.apm.agent.configuration.StartupInfo - To enable all features and decrease startup time, please configure application\_packages  
2020-10-08 23: 16: 43,789 [main] INFO co.elastic.apm.agent.impl.ElasticApmTracer - Tracer switched to RUNNING state  
2020-10-08 23: 16: 43,812 [elastic-apm-init-instrumentation-shutdown-hook] INFO co.elastic.apm.agent.impl.ElasticApmTracer - Tracer switched to STOPPED state  
2020-10-08 23: 16: 43,889 elastic-apm-remote-config-poller ERROR No Log4j 2 configuration file found. Using default configuration (logging only errors to the console), or user programmatically provided configurations. Set system property 'log4j2.debug' to show Log4j 2 internal initialization logging. See [https://logging.apache.org/log4j/2.x/manual/configuration.html](https://logging.apache.org/log4j/2.x/manual/configuration.html) for instructions on how to configure Log4j 2

---

<div class="post-metadata">

**Author:** ![amateur](https://avatars.discourse-cdn.com/v4/letter/a/77aa72/32.png) [@amateur](https://discuss.elastic.co/u/amateur)\
**Post date:** [October 9, 2020, 6:40pm UTC](https://discuss.elastic.co/t/apm-agente-was-8-5-5-11-java-8-error-jvmj9vm135w-proc-sys-kernel-core-pattern-setting/251499/2 "2020-10-09T18:40:18Z")

</div>

after disabling some options in the OS, only this error appears:

Error: Could not find or load main class   
ERROR IndyBootstrap null  
java.nio.channels.ClosedByInterruptException  
at java.nio.channels.spi.AbstractInterruptibleChannel.end(AbstractInterruptibleChannel.java:220)  
at sun.nio.ch.FileChannelImpl.size(FileChannelImpl.java:327)  
at com.sun.nio.zipfs.ZipFileSystem.findEND(ZipFileSystem.java:975)  
at com.sun.nio.zipfs.ZipFileSystem.initCEN(ZipFileSystem.java:1042)  
at com.sun.nio.zipfs.ZipFileSystem.(ZipFileSystem.java:142)  
at com.sun.nio.zipfs.ZipFileSystemProvider.newFileSystem(ZipFileSystemProvider.java:129)  
at java.nio.file.FileSystems.newFileSystem(FileSystems.java:337)  
at java.nio.file.FileSystems.newFileSystem(FileSystems.java:287)  
at co.elastic.apm.agent.util.PackageScanner.getClassNames(PackageScanner.java:66)  
at co.elastic.apm.agent.bci.IndyBootstrap.getClassNamesFromBundledPlugin(IndyBootstrap.java:303)  
at co.elastic.apm.agent.bci.IndyBootstrap.bootstrap(IndyBootstrap.java:278)  
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)  
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:90)  
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:55)  
at java.lang.reflect.Method.invoke(Method.java:508)  
at java.lang.IndyBootstrapDispatcher.bootstrap(IndyBootstrapDispatcher.java:31)  
at java.lang.invoke.VarargsCollectorHandle.invokeWithArguments(VarargsCollectorHandle.java:109)  
at java.lang.invoke.MethodHandle.invokeBsm(MethodHandle.java:904)  
at java.lang.invoke.MethodHandle.resolveInvokeDynamic(MethodHandle.java:949)  
at sun.net.www.protocol.http.HttpURLConnection.getOutputStream(HttpURLConnection.java:1311)  
at co.elastic.apm.agent.configuration.ApmServerConfigurationSource.tryFetchConfig(ApmServerConfigurationSource.java:185)  
at co.elastic.apm.agent.configuration.ApmServerConfigurationSource.access$100(ApmServerConfigurationSource.java:53)  
at co.elastic.apm.agent.configuration.ApmServerConfigurationSource$2.withConnection(ApmServerConfigurationSource.java:166)  
at co.elastic.apm.agent.configuration.ApmServerConfigurationSource$2.withConnection(ApmServerConfigurationSource.java:163)  
at co.elastic.apm.agent.report.ApmServerClient.execute(ApmServerClient.java:254)  
at co.elastic.apm.agent.configuration.ApmServerConfigurationSource.fetchConfig(ApmServerConfigurationSource.java:163)  
at co.elastic.apm.agent.configuration.ApmServerConfigurationSource.pollConfig(ApmServerConfigurationSource.java:131)  
at co.elastic.apm.agent.configuration.ApmServerConfigurationSource.access$000(ApmServerConfigurationSource.java:53)  
at co.elastic.apm.agent.configuration.ApmServerConfigurationSource$1.run(ApmServerConfigurationSource.java:117)  
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1160)  
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:635)  
at java.lang.Thread.run(Thread.java:822)

---

<div class="post-metadata">

**Author:** ![amateur](https://avatars.discourse-cdn.com/v4/letter/a/77aa72/32.png) [@amateur](https://discuss.elastic.co/u/amateur)\
**Post date:** [October 9, 2020, 7:51pm UTC](https://discuss.elastic.co/t/apm-agente-was-8-5-5-11-java-8-error-jvmj9vm135w-proc-sys-kernel-core-pattern-setting/251499/3 "2020-10-09T19:51:34Z")

</div>

2020-10-09 15:35:12,042 [main] INFO co.elastic.apm.agent.util.JmxUtils - Found JVM-specific OperatingSystemMXBean interface: com.ibm.lang.management.OperatingSystemMXBean  
2020-10-09 15:35:12,101 [main] INFO co.elastic.apm.agent.configuration.StartupInfo - Starting Elastic APM 1.18.1 as - on Java 1.8.0\_261 Runtime version: 8.0.6.15 - pxa6480sr6fp15ifix-20200820\_01(SR6 FP15+IJ26443) VM version: 2.9 (IBM Corporation) Linux 3.10.0-1160.2.1.el7.x86\_64  
2020-10-09 15:35:12,102 [main] WARN co.elastic.apm.agent.configuration.StartupInfo - To enable all features and decrease startup time, please configure application\_packages  
2020-10-09 15:35:14,514 [main] INFO co.elastic.apm.agent.impl.ElasticApmTracer - Tracer switched to RUNNING state  
2020-10-09 15:35:14,530 [elastic-apm-init-instrumentation-shutdown-hook] INFO co.elastic.apm.agent.impl.ElasticApmTracer - Tracer switched to STOPPED state  
2020-10-09 15:35:14,531 [elastic-apm-init-instrumentation-shutdown-hook] INFO co.elastic.apm.agent.report.ApmServerReporter - dropped events because of full queue: 0  
2020-10-09 15:35:14,533 [elastic-apm-init-instrumentation-shutdown-hook] INFO co.elastic.apm.agent.report.IntakeV2ReportingEventHandler - Reported events: 0  
2020-10-09 15:35:14,534 [elastic-apm-init-instrumentation-shutdown-hook] INFO co.elastic.apm.agent.report.IntakeV2ReportingEventHandler - Dropped events: 0  
2020-10-09 15:35:14,685 elastic-apm-remote-config-poller ERROR No Log4j 2 configuration file found. Using default configuration (logging only errors to the console), or user programmatically provided configurations. Set system property 'log4j2.debug' to show Log4j 2 internal initialization logging. See [https://logging.apache.org/log4j/2.x/manual/configuration.html](https://logging.apache.org/log4j/2.x/manual/configuration.html) for instructions on how to configure Log4j

---

<div class="post-metadata">

**Author:** ![Sylvain\_Juge](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/sylvain_juge/32/55521_2.png) [@Sylvain\_Juge](https://discuss.elastic.co/u/Sylvain_Juge)\
**Post date:** [October 26, 2020, 8:52pm UTC](https://discuss.elastic.co/t/apm-agente-was-8-5-5-11-java-8-error-jvmj9vm135w-proc-sys-kernel-core-pattern-setting/251499/4 "2020-10-26T20:52:27Z")

</div>

> [@amateur](#):
>
> Error: Could not find or load main class  
> ERROR IndyBootstrap null  
> java.nio.channels.ClosedByInterruptException  
> at java.nio.channels.spi.AbstractInterruptibleChannel.end(AbstractInterruptibleChannel.java:220)  
> at sun.nio.ch.FileChannelImpl.size(FileChannelImpl.java:327)

Hi @amateur,

To me this seems a similar error to [APM Agent does not start](https://discuss.elastic.co/t/apm-agent-does-not-start/252054), can you confirm it's the same ? double-checking configuration might help in this case.

As for the last log message, does it means you have managed to install the agent ? can you see transactions captured when you execute a few requests to the server ?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [November 16, 2020, 4:52pm UTC](https://discuss.elastic.co/t/apm-agente-was-8-5-5-11-java-8-error-jvmj9vm135w-proc-sys-kernel-core-pattern-setting/251499/5 "2020-11-16T16:52:38Z")

</div>

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.
