# APM Dependencies tab is empty, but data present in Service map tab

**URL:** https://discuss.elastic.co/t/apm-dependencies-tab-is-empty-but-data-present-in-service-map-tab/311233
**Category:** APM
**Tags:** server, php
**Created:** [August 2, 2022, 4:47pm UTC](https://discuss.elastic.co/t/apm-dependencies-tab-is-empty-but-data-present-in-service-map-tab/311233 "2022-08-02T16:47:37Z")
**Posts on this page:** 8
**Page:** 1

<div class="post-metadata">

### Author: ![Offout](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/offout/32/109152_2.png) [@Offout](https://discuss.elastic.co/u/Offout)
#### Post date: [August 2, 2022, 4:47pm UTC](https://discuss.elastic.co/t/apm-dependencies-tab-is-empty-but-data-present-in-service-map-tab/311233/1 "2022-08-02T16:47:37Z")

</div>

**Kibana version** :  
8.2.3

**Elasticsearch version** :  
8.2.3

**APM Server version** :  
8.2.3

**APM Agent language and version** :  
PHP 1.5.2

**Browser version** :  
Chrome 103, CLI

**Original install method (e.g. download page, yum, deb, from source, etc.) and version**:  
Download page

**Fresh install or upgraded from other version?**  
Fresh install

**Description of the problem including expected versus actual behavior. Please include screenshots (if relevant)**:

We are currently testing self-hosted APM server with PHP agent, and Service map is correct for all services (tab at main page) and for any individual service, but dependencies tab is completly empty in all services (depencencies tab at main page) and in every individual service.

Transactions are recordered from web requests and from CLI commands (cron, supervisord).

 ![service-map](https://us1.discourse-cdn.com/elastic/original/3X/8/9/896e7540bcd2ee702bc8f9c98dd3384015f17057.jpeg)  
 ![dependencies](https://us1.discourse-cdn.com/elastic/original/3X/0/0/0081d835fc45dca0c6c5302389b608f649a11cec.jpeg)

**Steps to reproduce** :

1. Run self-hosted APM server, PHP apps with APM agent
2. Go to Service map tab
3. Go to Dependencies tab

---

<div class="post-metadata">

### Author: ![lahsivjar](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/lahsivjar/32/101451_2.png) [@lahsivjar](https://discuss.elastic.co/u/lahsivjar)
#### Post date: [August 3, 2022, 4:39am UTC](https://discuss.elastic.co/t/apm-dependencies-tab-is-empty-but-data-present-in-service-map-tab/311233/2 "2022-08-03T04:39:48Z")

</div>

@Offout The dependencies tab is populated based on aggregated metrics (the service graph uses a different logic).

What is the result of `metricset.name: "service_destination" AND span.destination.service.resource: *` KQL for `metrics-*` index pattern?

Do you see any error in your APM-Server logs?

---

<div class="post-metadata">

### Author: ![Offout](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/offout/32/109152_2.png) [@Offout](https://discuss.elastic.co/u/Offout)
#### Post date: [August 3, 2022, 1:37pm UTC](https://discuss.elastic.co/t/apm-dependencies-tab-is-empty-but-data-present-in-service-map-tab/311233/3 "2022-08-03T13:37:16Z")

</div>

Thank you for your reply!  
Search results `metricset.name: "service_destination" AND span.destination.service.resource: *` is empty.  
As I can see metricset.name has only one value.  
span.destination Is not present in "Avaliable fields"  
I will share server logs a bit later

 ![image](https://us1.discourse-cdn.com/elastic/original/3X/1/1/117670fab96cb2a80d2102c3edea4a3cca25fc32.png)  
 ![image](https://us1.discourse-cdn.com/elastic/original/3X/a/8/a897297bc4e899db35083fea133b08205fbb40fc.png)

---

<div class="post-metadata">

### Author: ![lahsivjar](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/lahsivjar/32/101451_2.png) [@lahsivjar](https://discuss.elastic.co/u/lahsivjar)
#### Post date: [August 8, 2022, 3:33am UTC](https://discuss.elastic.co/t/apm-dependencies-tab-is-empty-but-data-present-in-service-map-tab/311233/4 "2022-08-08T03:33:17Z")

</div>

> Search results `metricset.name: "service_destination" AND span.destination.service.resource: *` is empty.

This aligns with our observation of missing data in the APM dependencies tab. At this point, we can assume this to not be a UI issue and look into the APM Server log to find what is happening with the service destination aggregator.

---

<div class="post-metadata">

### Author: ![Offout](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/offout/32/109152_2.png) [@Offout](https://discuss.elastic.co/u/Offout)
#### Post date: [August 9, 2022, 3:19pm UTC](https://discuss.elastic.co/t/apm-dependencies-tab-is-empty-but-data-present-in-service-map-tab/311233/5 "2022-08-09T15:19:37Z")

</div>

Only errors I have found in logs are:

```auto
Invalid host param set: http:// ***.link:9200 http://***.link:9200, Error: parse "http:// ***:9200 http://*** :9200": invalid character " " in host name

```

```auto
failed to index event (strict_dynamic_mapping_exception): mapping set to strict, dynamic introduction of [error] within [_doc] is not allowed

```

We are going to fix this two.

---

<div class="post-metadata">

### Author: ![lahsivjar](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/lahsivjar/32/101451_2.png) [@lahsivjar](https://discuss.elastic.co/u/lahsivjar)
#### Post date: [August 10, 2022, 2:20am UTC](https://discuss.elastic.co/t/apm-dependencies-tab-is-empty-but-data-present-in-service-map-tab/311233/6 "2022-08-10T02:20:12Z")

</div>

> [@Offout](#):
>
> ```auto
> failed to index event (strict_dynamic_mapping_exception): mapping set to strict, dynamic introduction of [error] within [_doc] is not allowed
> 
> ```

Failure to index events might be the root cause since the internal indexes have strict mapping and the dependencies tab is based on service destination aggregation metrics produced by APM-Server. Let me know if fixing this error resolves issues with the dependencies tab.

---

<div class="post-metadata">

### Author: ![badhoprus](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/badhoprus/32/110094_2.png) [@badhoprus](https://discuss.elastic.co/u/badhoprus)
#### Post date: [August 26, 2022, 4:32am UTC](https://discuss.elastic.co/t/apm-dependencies-tab-is-empty-but-data-present-in-service-map-tab/311233/7 "2022-08-26T04:32:12Z")

</div>

> [@lahsivjar](#):
>
> ot be a UI issue and look into the APM Server log to find what is happening with the service destination aggregator.

I have the same problem on my 8.3.3 Cloud installation. I recently update to 8.4.0 but it doesn`t help.

` span.destination.service.resource: *` isn`t empy, but `metricset.name: "service\_destination"` empty.  
I can see dependency it Trace -\> Span Details:

 ![image](https://us1.discourse-cdn.com/elastic/original/3X/7/f/7f2466f1686f4697f5cc09620e7e996f7e568e8c.jpeg)  
And also on a service map, but dependency tab is empty.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [September 16, 2022, 12:32am UTC](https://discuss.elastic.co/t/apm-dependencies-tab-is-empty-but-data-present-in-service-map-tab/311233/8 "2022-09-16T00:32:58Z")

</div>

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.
