# APM error: forbidden request: endpoint is disabled

**URL:** <https://discuss.elastic.co/t/apm-error-forbidden-request-endpoint-is-disabled/205399>\
**Category:** APM\
**Tags:** java, server\
**Created:** [October 28, 2019, 3:50am UTC](https://discuss.elastic.co/t/apm-error-forbidden-request-endpoint-is-disabled/205399 "2019-10-28T03:50:41Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![Sirius](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/sirius/32/47012_2.png) [@Sirius](https://discuss.elastic.co/u/Sirius)\
**Post date:** [October 28, 2019, 3:50am UTC](https://discuss.elastic.co/t/apm-error-forbidden-request-endpoint-is-disabled/205399/1 "2019-10-28T03:50:42Z")

</div>

Hello,

Can anyone help please on this APM error, below I am sharing the technical information and steps ...

**Kibana version** :7.3.2

**Elasticsearch version** :7.3.2

**APM Server version** : 7.4

**APM Agent language and version** : elastic-apm-agent-1.10.0.jar

**Steps to reproduce** :

1. Start APM server

Output:

> **Summary**
>
> ...  
> 2019-10-27T20:13:44.747-0700 INFO [pipelines] pipeline/register.go:53 Pipeline already registered: apm  
> 2019-10-27T20:13:44.748-0700 INFO [pipelines] pipeline/register.go:53 Pipeline already registered: apm\_user\_agent  
> 2019-10-27T20:13:44.748-0700 INFO [pipelines] pipeline/register.go:53 Pipeline already registered: apm\_user\_geo  
> 2019-10-27T20:13:44.748-0700 INFO [pipelines] pipeline/register.go:56 Registered Ingest Pipelines successfully.  
> 2019-10-27T20:13:44.748-0700 INFO pipeline/output.go:105 Connection to backoff(elasticsearch([https://es](https://es)\*\*\*\*\*\*.com:9200)) established  
> 2019-10-27T20:13:53.666-0700 INFO pipeline/output.go:95 Connecting to backoff(publish(elasticsearch([https://es](https://es)\*\*\*\*\*\*.com:9200)))  
> 2019-10-27T20:13:53.667-0700 INFO elasticsearch/client.go:743 Attempting to connect to Elasticsearch version 7.3.2  
> 2019-10-27T20:13:53.741-0700 INFO pipeline/output.go:105 Connection to backoff(publish(elasticsearch([https://es](https://es)\*\*\*\*\*\*.com:9200))) established

1. Execute java agent from a Linux remote server :  
java -javaagent:elastic-apm-agent-1.10.0.jar   
-Delastic.apm.service\_name=test   
-Delastic.apm.server\_urls=http://10. **.**.\*\*\*:8200/   
-Delastic.apm.application\_packages=ca.com.elastic

Output:  
2019-10-27 20:18:20.405 [main] INFO co.elastic.apm.agent.configuration.StartupInfo - Starting Elastic APM 1.10.0 as test on Java 1.8.0\_222 (Oracle Corporation) Linux 3.10.0-1062.1.2.el7.x86\_64  
2019-10-27 20:18:20.437 [apm-server-healthcheck] INFO co.elastic.apm.agent.report.ApmServerHealthChecker - Elastic APM server is available: { "build\_date": "2019-09-27T06:58:27Z", "build\_sha": "971d864356e4438bf4a799a1fa052cfd0ce680b4", "version": "7.4.0"}  
Usage: java [-options] class [args...]

Output from APM server:  
2019-10-27T20:18:20.433-0700 INFO [request] middleware/log\_middleware.go:76 request ok {"request\_id": "15a7483d-686b-4621-a17a-26655808f098", "method": "GET", "URL": "/", "content\_length": 0, "remote\_address": "10. **.** \*.\*\*\*", "user-agent": "elasticapm-java/1.10.0", "response\_code": 200}  
**2019-10-27T20:18:20.433-0700 ERROR [request] middleware/log\_middleware.go:74 forbidden request {"request\_id": "447dcc2f-e80b-4fcc-a0fe-2a72a80c621f", "method": "POST", "URL": "/config/v1/agents", "content\_length": 419, "remote\_address": "10.**.\*\*\*.\ ***", "user-agent": "elasticapm-java/1.10.0", "response\_code": 403, "error": "forbidden request: endpoint is disabled"}**

apm-server.yml

> **Summary**
>
> ################### APM Server Configuration #########################  
> apm-server:  
> host: "10. **.**.\*\*\*:8200"
> 
> rum:  
> enabled: true  
> event\_rate:  
> limit: 300  
> lru\_size: 1000
> 
> ```
> #-- General RUM settings
> allow_origins : ['*']
> library_pattern: "node_modules|bower_components|~"
> exclude_from_grouping: "^/webpack"
> source_mapping:
> elasticsearch:      
> cache:
> expiration: 5m
> index_pattern: "apm-*-sourcemap*"
> 
> ```
> 
> #-------------------------- Elasticsearch output ------------------------------  
> output.elasticsearch:  
> hosts: ["es\*\*\*\*\*\*.com:9200"]  
> enabled: true  
> protocol: "https"  
> username: "myuser"  
> password: "mypasswd"  
> ssl.enabled: true  
> ssl.certificate\_authorities: ["../ca.crt"]  
> ssl.certificate: "../cert.crt"  
> ssl.key: "../eskey.key"  
> #============================== X-pack Monitoring ===============================  
> monitoring.enabled: true

Thanks & Regards,  
Jorge

---

<div class="post-metadata">

**Author:** ![Eyal\_Koren](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/eyal_koren/32/36830_2.png) [@Eyal\_Koren](https://discuss.elastic.co/u/Eyal_Koren)\
**Post date:** [October 28, 2019, 4:47am UTC](https://discuss.elastic.co/t/apm-error-forbidden-request-endpoint-is-disabled/205399/2 "2019-10-28T04:47:00Z")

</div>

Hi and welcome to the forum!  
This error is related to the new [agent configuration feature](https://www.elastic.co/guide/en/kibana/master/agent-configuration.html). If you want to use that, you need to [configure the Kibana endpoint](https://www.elastic.co/guide/en/apm/server/master/setup-kibana-endpoint.html), otherwise you can ignore.  
I hope this helps.

---

<div class="post-metadata">

**Author:** ![Sirius](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/sirius/32/47012_2.png) [@Sirius](https://discuss.elastic.co/u/Sirius)\
**Post date:** [October 28, 2019, 5:56pm UTC](https://discuss.elastic.co/t/apm-error-forbidden-request-endpoint-is-disabled/205399/3 "2019-10-28T17:56:12Z")

</div>

Thanks for your feedback Eyal. It resolved the issue mentioned, now I am experiencing a new one after enabling Kibana "An internal server error occurred", fot this, I've opened new topic.

> [@APM An internal server error occurred](https://discuss.elastic.co/t/apm-an-internal-server-error-occurred/205526):
>
> Hello, Can please advise on below error between APM and java agent ... Kibana version :7.3.2 Elasticsearch version :7.3.2 APM Server version : 7.4 APM Agent language and version : elastic-apm-agent-1.10.0.jar I am running java agent like: java -javaagent:/export/home/gdlsajor/apm/elastic-apm-agent-1.10.0.jar -Delastic.apm.service\_name=test -Delastic.apm.server\_urls=http://10...\*\*\*:8200/ -Delastic.apm.application\_packages=ca.com.elastic Output: 2019-10-28 10:29:06.657 [main] INFO c…

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [November 18, 2019, 1:56pm UTC](https://discuss.elastic.co/t/apm-error-forbidden-request-endpoint-is-disabled/205399/4 "2019-11-18T13:56:58Z")

</div>

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.
