# APM Errors showing as "N/A" when using Java agent log\_sending=true (errors coming from logs)

**URL:** <https://discuss.elastic.co/t/apm-errors-showing-as-n-a-when-using-java-agent-log-sending-true-errors-coming-from-logs/384232>\
**Category:** APM\
**Tags:** docker, java\
**Created:** [December 23, 2025, 3:27pm UTC](https://discuss.elastic.co/t/apm-errors-showing-as-n-a-when-using-java-agent-log-sending-true-errors-coming-from-logs/384232 "2025-12-23T15:27:39Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![nicolasbalao](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/nicolasbalao/32/146470_2.png) [@nicolasbalao](https://discuss.elastic.co/u/nicolasbalao)\
**Post date:** [December 23, 2025, 3:27pm UTC](https://discuss.elastic.co/t/apm-errors-showing-as-n-a-when-using-java-agent-log-sending-true-errors-coming-from-logs/384232/1 "2025-12-23T15:27:39Z")

</div>

### Versions

- **Kibana version:** 9.2.2
- **Elasticsearch version:** 9.2.2
- **APM Server version:** 9.2.2 (via Fleet integration)
- **APM Agent language and version:** Java agent 1.55.2
- **Browser version:** Chrome (latest)

* * *

### Installation

- **Original install method:** Docker + Fleet / Elastic Agent
- **Fresh install or upgraded:** Fresh install

* * *

### Setup specifics

- Fleet with **custom policies** to enable the APM integration

- Java APM agent configured with:

* * *

### Description of the problem

In **Kibana → APM → Errors** , I see multiple error entries where the **error title is displayed as `N/A`**.

#### Expected behavior

- Errors should display a meaningful message (exception name / message)
- No duplicated errors between APM-captured exceptions and log-based errors

#### Actual behavior

- Errors coming from logs appear in APM with:

- These errors are listed alongside “real” APM errors, creating **duplicates and noise**

* * *

### Investigation details

After investigating the documents causing the `N/A` entries:

- All problematic errors come from **logs** , not from APM exception capture

- They have:

- They are generated by application logs such as:

- These log entries are:

This results in:

- `N/A` being displayed in the APM Errors UI

- Duplicate error entries:

* * *

### Summary of issues

- `N/A` errors are caused by **log-based errors without exception fields**
- Log entries with `event.dataset = file | console` are interpreted as APM errors
- Missing `exception.*` fields cause the UI to display `N/A`
- This creates **duplicates and noisy error lists**
- `error.id` is `null` for these entries

* * *

### Questions

1. Is this expected behavior when using `log_sending=true` with the Java APM agent?

2. Is there a recommended way to:

3. Is there a configuration or pipeline adjustment to avoid these duplicates?

* * *

### Logs / Errors

- Browser console: no relevant UI errors
- Elasticsearch documents show `error.id = null` for affected entries

---

<div class="post-metadata">

**Author:** ![Jack\_Shirazi](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jack_shirazi/32/91641_2.png) [@Jack\_Shirazi](https://discuss.elastic.co/u/Jack_Shirazi)\
**Post date:** [January 5, 2026, 12:07pm UTC](https://discuss.elastic.co/t/apm-errors-showing-as-n-a-when-using-java-agent-log-sending-true-errors-coming-from-logs/384232/2 "2026-01-05T12:07:16Z")

</div>

[log\_sending](https://www.elastic.co/docs/reference/apm/agents/java/config-logging#config-log-sending) is an experimental feature and this looks to be confusing the UI. I believe there will be a UI fix in a future version, in the meantime turning off [log\_sending](https://www.elastic.co/docs/reference/apm/agents/java/config-logging#config-log-sending) and using one of the many other ways to send logs may be a better option for you
