# APM fields doesn't exist in kibana APM observability and empty values in errors and metrics

**URL:** <https://discuss.elastic.co/t/apm-fields-doesnt-exist-in-kibana-apm-observability-and-empty-values-in-errors-and-metrics/289711>\
**Category:** APM\
**Tags:** server, php\
**Created:** [November 19, 2021, 4:37pm UTC](https://discuss.elastic.co/t/apm-fields-doesnt-exist-in-kibana-apm-observability-and-empty-values-in-errors-and-metrics/289711 "2021-11-19T16:37:36Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![Sergio\_Ferreyra](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/sergio_ferreyra/32/93646_2.png) [@Sergio\_Ferreyra](https://discuss.elastic.co/u/Sergio_Ferreyra)\
**Post date:** [November 19, 2021, 4:37pm UTC](https://discuss.elastic.co/t/apm-fields-doesnt-exist-in-kibana-apm-observability-and-empty-values-in-errors-and-metrics/289711/1 "2021-11-19T16:37:36Z")

</div>

Hi team, I am newbie using apm, using apm-server and apm-agent php,  
apm-server 7.12  
apm-aget-php v1.3

The problem here is there are some fields that don't exist in the index, for example: **http.response.status\_code** and when I tried to view errors in the APM dashboard there is no data

 ![image](https://us1.discourse-cdn.com/elastic/original/3X/e/d/ed6a0b67395d11cc8035d6aa53623fc3a1c86ebe.png)

And this for metrics

 ![image](https://us1.discourse-cdn.com/elastic/original/3X/b/4/b4d17418388a3975072dd114d28f300515b973ee.png)

I am trying to reproduce errors in the application to test but looks like there are fields missing  
For example:

![image](https://us1.discourse-cdn.com/elastic/original/3X/2/b/2b41ad876dc1e3c300e4a8d89bc5705476bbbeab.png)  
I am getting errors 5xx.  
But looks like I am missing a lot of data. If I check the Transaction details I see this.

 ![image](https://us1.discourse-cdn.com/elastic/original/3X/3/c/3c05dc4bce2c887f3e02a97db40bf2cacd7c334c.png)

This is the configuration that I have for apm-server and apm-agent-php

**apm-server.yaml**

```auto
  apmConfig:
    apm-server.yml: |
      apm-server:
        host: "0.0.0.0:8200"
        apm-server.rum.enabled: true
        apm-server.rum.allow_origins: ['*']
      queue: {}
      output.elasticsearch:
        username: '${ELASTICSEARCH_USERNAME}'
        password: '${ELASTICSEARCH_PASSWORD}'
        protocol: https
        hosts: ["elastic-client-${ENVIRONMENT}.${ENVIRONMENT}.example.com:443"]

```

and for

apm-agent-php (php.ini)

```auto
    [elastic]
    extension=elastic_apm.so
    elastic_apm.bootstrap_php_part_file = /apm-agent-php-1.3.1/src/bootstrap_php_part.php
    elastic_apm.server_url = http://apm-server.kube-system.svc.cluster.local:8200
    elastic_apm.service_name = "Litespeed Service"

```

My question here is, there are some missing configurations here? I think is default but not sure and I can't find examples of configurations in the documentation, I am using Kubernetes, so the apm-server is a pod and the apm-php-agent was added in our application Dockerfile using the official helm-chart.

Regards!

Regards!

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [December 10, 2021, 12:38pm UTC](https://discuss.elastic.co/t/apm-fields-doesnt-exist-in-kibana-apm-observability-and-empty-values-in-errors-and-metrics/289711/2 "2021-12-10T12:38:26Z")

</div>

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.
