# Apm-server not start Cannot index event publisher.Event{Content:beat.Event

**URL:** <https://discuss.elastic.co/t/apm-server-not-start-cannot-index-event-publisher-event-content-beat-event/191778>\
**Category:** APM\
**Created:** [July 23, 2019, 9:37am UTC](https://discuss.elastic.co/t/apm-server-not-start-cannot-index-event-publisher-event-content-beat-event/191778 "2019-07-23T09:37:12Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![resa](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/resa/32/50716_2.png) [@resa](https://discuss.elastic.co/u/resa)\
**Post date:** [July 23, 2019, 9:37am UTC](https://discuss.elastic.co/t/apm-server-not-start-cannot-index-event-publisher-event-content-beat-event/191778/1 "2019-07-23T09:37:12Z")

</div>

I got error when try to run apm-server -e:

2019-07-23T05:29:47.931-0400 WARN elasticsearch/client.go:527 Cannot index event publisher.Event{Content:beat.Event{Timestamp:time.Time{wall:0xbf45d2c2b44ab9a1, ext:69828979, loc:(_time.Location)(0x2720b60)}, Meta:common.MapStr(nil), Fields:common.MapStr{"ecs":common.MapStr{"version":"1.0.0"}, "observer":common.MapStr{"ephemeral\_id":"c048b732-f3d4-427a-847b-9bb2dc4c871e", "hostname":"[DESKTOP-PAA4QB6.xx.com](http://DESKTOP-PAA4QB6.xx.com)", "id":"233c7faa-70d0-411f-bc21-21817aa3c9d6", "listening":"127.0.0.1:8200", "type":"apm-server", "version":"7.2.0", "version\_major":7}, "processor":common.MapStr{"event":"onboarding", "name":"onboarding"}}, Private:interface {}(nil), TimeSeries:false}, Flags:0x1} (status=404): {"type":"index\_not\_found\_exception","reason":"no such index [apm-7.2.0-onboarding-2019.07.23] and [action.auto\_create\_index] ([.monitoring_,.watches,.triggered\_watches,.watcher-history\*,.ml\*]) doesn't match","index\_uuid":"_na_","index":"apm-7.2.0-onboarding-2019.07.23"}

and service failed to start 🙂  
● apm-server.service - Elastic APM Server  
Loaded: loaded (/usr/lib/systemd/system/apm-server.service; enabled; vendor preset: disabled)  
Active: failed (Result: start-limit) since Tue 2019-07-23 05:36:38 EDT; 1s ago  
Docs: [https://www.elastic.co/solutions/apm](https://www.elastic.co/solutions/apm)  
Process: 3662 ExecStart=/usr/share/apm-server/bin/apm-server $BEAT\_LOG\_OPTS $BEAT\_CONFIG\_OPTS $BEAT\_PATH\_OPTS (code=exited, status=1/FAILURE)  
Main PID: 3662 (code=exited, status=1/FAILURE)

Jul 23 05:36:38 [DESKTOP-PAA4QB6.xx.com](http://DESKTOP-PAA4QB6.xx.com) systemd[1]: Unit apm-server.service entered failed state.  
Jul 23 05:36:38 [DESKTOP-PAA4QB6.xx.com](http://DESKTOP-PAA4QB6.xx.com) systemd[1]: apm-server.service failed.  
Jul 23 05:36:38 [DESKTOP-PAA4QB6.xx.com](http://DESKTOP-PAA4QB6.xx.com) systemd[1]: apm-server.service holdoff time over, scheduling restart.  
Jul 23 05:36:38 [DESKTOP-PAA4QB6.xx.com](http://DESKTOP-PAA4QB6.xx.com) systemd[1]: Stopped Elastic APM Server.  
Jul 23 05:36:38 [DESKTOP-PAA4QB6.xx.com](http://DESKTOP-PAA4QB6.xx.com) systemd[1]: start request repeated too quickly for apm-server.service  
Jul 23 05:36:38 [DESKTOP-PAA4QB6.xx.com](http://DESKTOP-PAA4QB6.xx.com) systemd[1]: Failed to start Elastic APM Server.  
Jul 23 05:36:38 [DESKTOP-PAA4QB6.xx.com](http://DESKTOP-PAA4QB6.xx.com) systemd[1]: Unit apm-server.service entered failed state.  
Jul 23 05:36:38 [DESKTOP-PAA4QB6.xx.com](http://DESKTOP-PAA4QB6.xx.com) systemd[1]: apm-server.service failed.

---

<div class="post-metadata">

**Author:** ![simitt](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/simitt/32/106406_2.png) [@simitt](https://discuss.elastic.co/u/simitt)\
**Post date:** [July 23, 2019, 10:51am UTC](https://discuss.elastic.co/t/apm-server-not-start-cannot-index-event-publisher-event-content-beat-event/191778/2 "2019-07-23T10:51:04Z")

</div>

Please ensure that [auto creating indices](https://www.elastic.co/guide/en/elasticsearch/reference/current/docs-index_.html#index-creation) ins turned on for all `apm*` indices in the configured Elasticsearch cluster.

---

<div class="post-metadata">

**Author:** ![resa](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/resa/32/50716_2.png) [@resa](https://discuss.elastic.co/u/resa)\
**Post date:** [July 23, 2019, 3:29pm UTC](https://discuss.elastic.co/t/apm-server-not-start-cannot-index-event-publisher-event-content-beat-event/191778/4 "2019-07-23T15:29:47Z")

</div>

oh greate @simitt it's work after add on elasticsearch.yml thank you

---

<div class="post-metadata">

**Author:** ![simitt](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/simitt/32/106406_2.png) [@simitt](https://discuss.elastic.co/u/simitt)\
**Post date:** [July 23, 2019, 4:10pm UTC](https://discuss.elastic.co/t/apm-server-not-start-cannot-index-event-publisher-event-content-beat-event/191778/5 "2019-07-23T16:10:13Z")

</div>


