# APM server producing errors (mapper\_parsing\_exception) when traces are sent through jaeger-agent

**URL:** <https://discuss.elastic.co/t/apm-server-producing-errors-mapper-parsing-exception-when-traces-are-sent-through-jaeger-agent/248457>\
**Category:** APM\
**Tags:** docker, server\
**Created:** [September 13, 2020, 8:20pm UTC](https://discuss.elastic.co/t/apm-server-producing-errors-mapper-parsing-exception-when-traces-are-sent-through-jaeger-agent/248457 "2020-09-13T20:20:41Z")\
**Posts on this page:** 1\
**Showing post:** 2

<div class="post-metadata">

**Author:** ![axw](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/axw/32/28197_2.png) [@axw](https://discuss.elastic.co/u/axw)\
**Post date:** [September 14, 2020, 1:56am UTC](https://discuss.elastic.co/t/apm-server-producing-errors-mapper-parsing-exception-when-traces-are-sent-through-jaeger-agent/248457/2 "2020-09-14T01:56:58Z")

</div>

Welcome to the forum @Amirtheahmed!

Do you have multiple services instrumented? That sort of error would occur when the instrumentation provides two different data types for the same attribute.

If this is the case, then I think the simplest short-term solution would be to split services into multiple indices, to avoid these kinds of mapping conflicts:

> [@Storing APM data in custom/specific indices](https://discuss.elastic.co/t/storing-apm-data-in-custom-specific-indices/246381):
>
> If you'd like to split your APM indices by the service, you can use the advice from [this topic](https://discuss.elastic.co/t/how-to-create-index-for-each-service/242821). You can change the index name by setting either [output.elasticsearch.index](https://www.elastic.co/guide/en/apm/server/current/elasticsearch-output.html#index-option-es) or [output.elasticsearch.indices](https://www.elastic.co/guide/en/apm/server/current/elasticsearch-output.html#indices-option-es). These configuration variables take an index name "format string", which can reference fields the events. For your use-case, you can include %{[service.name]} in the format string to create an index per service. e.g. output.elasticsearch: hosts: ["http://localhost:9200"] indices: - inde…

---

_[View the full topic](https://discuss.elastic.co/t/apm-server-producing-errors-mapper-parsing-exception-when-traces-are-sent-through-jaeger-agent/248457)._
