# APM server RUM endpoints disabled and CORS cross origin

**URL:** <https://discuss.elastic.co/t/apm-server-rum-endpoints-disabled-and-cors-cross-origin/167958>\
**Category:** APM\
**Created:** [February 12, 2019, 5:53am UTC](https://discuss.elastic.co/t/apm-server-rum-endpoints-disabled-and-cors-cross-origin/167958 "2019-02-12T05:53:41Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![Kishore\_Raj\_vj](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kishore_raj_vj/32/44324_2.png) [@Kishore\_Raj\_vj](https://discuss.elastic.co/u/Kishore_Raj_vj)\
**Post date:** [February 12, 2019, 5:53am UTC](https://discuss.elastic.co/t/apm-server-rum-endpoints-disabled-and-cors-cross-origin/167958/1 "2019-02-12T05:53:41Z")

</div>

Hai, I am using APM Server Version 6.5.4 and I am using JS agent. I am getting

\<2019-02-12T10:44:11.619+0530 ERROR [request] beater/common\_handlers.go:467 error handling request {"response\_code": 403, "error": "forbidden request: endpoint is disabled"}  
/\>

\<Access to XMLHttpRequest at '[http://localhost:8200/intake/v2/rum/events](http://localhost:8200/intake/v2/rum/events)' from origin '[http://localhost:4200](http://localhost:4200)' has been blocked by CORS policy: Response to preflight request doesn't pass access control check: No 'Access-Control-Allow-Origin' header is present on the requested resource./\>

 ![Screenshot%20from%202019-02-12%2010-32-22](https://us1.discourse-cdn.com/elastic/original/3X/d/c/dc877a5043c3b0b21c1c22a91ea37511c3637762.jpeg)

I have also enabled RUM Endpoint and allow\_origins to ['\*'] in apm-server.yml but still the error occurs. Can u help me out in solving this.

---

<div class="post-metadata">

**Author:** ![axw](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/axw/32/28197_2.png) [@axw](https://discuss.elastic.co/u/axw)\
**Post date:** [February 12, 2019, 6:20am UTC](https://discuss.elastic.co/t/apm-server-rum-endpoints-disabled-and-cors-cross-origin/167958/2 "2019-02-12T06:20:35Z")

</div>

Please read through [https://www.elastic.co/guide/en/apm/agent/js-base/current/distributed-tracing-guide.html#distributed-tracing-guide](https://www.elastic.co/guide/en/apm/agent/js-base/current/distributed-tracing-guide.html#distributed-tracing-guide). You will need to modify your application to respond to CORS preflight requests as described under [Server Configuration](https://www.elastic.co/guide/en/apm/agent/js-base/current/distributed-tracing-guide.html#server-configuration).

---

<div class="post-metadata">

**Author:** ![Kishore\_Raj\_vj](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kishore_raj_vj/32/44324_2.png) [@Kishore\_Raj\_vj](https://discuss.elastic.co/u/Kishore_Raj_vj)\
**Post date:** [February 12, 2019, 9:19am UTC](https://discuss.elastic.co/t/apm-server-rum-endpoints-disabled-and-cors-cross-origin/167958/3 "2019-02-12T09:19:26Z")

</div>

Thank You. Issues solved.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [March 5, 2019, 5:30am UTC](https://discuss.elastic.co/t/apm-server-rum-endpoints-disabled-and-cors-cross-origin/167958/4 "2019-03-05T05:30:08Z")

</div>

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.
