# APM Service keep on failing in ELK server

**URL:** <https://discuss.elastic.co/t/apm-service-keep-on-failing-in-elk-server/354862>\
**Category:** APM\
**Tags:** server\
**Created:** [March 6, 2024, 4:44pm UTC](https://discuss.elastic.co/t/apm-service-keep-on-failing-in-elk-server/354862 "2024-03-06T16:44:36Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![SUNA](https://avatars.discourse-cdn.com/v4/letter/s/f05b48/32.png) [@SUNA](https://discuss.elastic.co/u/SUNA)\
**Post date:** [March 6, 2024, 4:44pm UTC](https://discuss.elastic.co/t/apm-service-keep-on-failing-in-elk-server/354862/1 "2024-03-06T16:44:36Z")

</div>

Hi Team,

Despite resolving the queue full issue on the ELK server, the APM service continues to fail intermittently. Our ELK server, hosted on a DigitalOcean droplet, is responsible for monitoring logs from the AWS environment.

Initially, the problem surfaced with a queue fill error due to the file system reaching its capacity. This led to Kibana console unavailability. To mitigate this, I manually cleared some indices on the ELK server and further managed them via the console.

Subsequently, I restarted both the ELK and APM services to ensure proper functionality. However, the APM service persists in failing after a short period of operation. Additionally, I noticed that APM logs were not updating prior to this incident.

Upon inspecting the Elasticsearch logs, we observed the following:

```auto
[2024-03-06T22:08:27,023][INFO][o.e.x.s.a.AuthenticationService] [node-1] Authentication of [apm_system] was terminated by realm [reserved] - failed to authenticate user [apm_system]

```

Your prompt attention to this matter is greatly appreciated. Please let me know if you require any further details

Kinldy suggest the way to debug and fix

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [April 3, 2024, 4:44pm UTC](https://discuss.elastic.co/t/apm-service-keep-on-failing-in-elk-server/354862/2 "2024-04-03T16:44:51Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
