# Apm service-map Internal Server Error (500)

**URL:** <https://discuss.elastic.co/t/apm-service-map-internal-server-error-500/242818>\
**Category:** APM\
**Tags:** ui\
**Created:** [July 28, 2020, 12:53am UTC](https://discuss.elastic.co/t/apm-service-map-internal-server-error-500/242818 "2020-07-28T00:53:34Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![wajika](https://avatars.discourse-cdn.com/v4/letter/w/977dab/32.png) [@wajika](https://discuss.elastic.co/u/wajika)\
**Post date:** [July 28, 2020, 12:53am UTC](https://discuss.elastic.co/t/apm-service-map-internal-server-error-500/242818/1 "2020-07-28T00:53:34Z")

</div>

This service has data.

 ![image](https://us1.discourse-cdn.com/elastic/original/3X/b/9/b9b89919443a74804973ab17617ee091593ea9bc.png)

When I click "Service Map", a 500 error appears, I don’t know what data is missing.

> ```
> {
> "type":"log",
> "@timestamp":"2020-07-28T00:46:14Z",
> "tags":[
> "error",
> "http"],
> "pid":7,
> "message":"{ Error: [resource_not_found_exception] No known job with id 'apm'\n at respond (/usr/share/kibana/node_modules/elasticsearch/src/lib/transport.js:349:15)\n at checkRespForFailure (/usr/share/kibana/node_modules/elasticsearch/src/lib/transport.js:306:7)\n at HttpConnector.<anonymous> (/usr/share/kibana/node_modules/elasticsearch/src/lib/connectors/http.js:173:7)\n at IncomingMessage.wrapper (/usr/share/kibana/node_modules/elasticsearch/node_modules/lodash/lodash.js:4929:19)\n at IncomingMessage.emit (events.js:203:15)\n at endReadableNT (_stream_readable.js:1145:12)\n at process._tickCallback (internal/process/next_tick.js:63:19)\n status: 404,\n displayName: 'NotFound',\n message:\n '[resource_not_found_exception] No known job with id \\'apm\\'',\n path: '/_ml/anomaly_detectors/apm',\n query: {},\n body:\n { error:\n { root_cause: [Array],\n type: 'resource_not_found_exception',\n reason: 'No known job with id \\'apm\\'' },\n status: 404 },\n statusCode: 404,\n response:\n '{\"error\":{\"root_cause\":[{\"type\":\"resource_not_found_exception\",\"reason\":\"No known job with id \\'apm\\'\"}],\"type\":\"resource_not_found_exception\",\"reason\":\"No known job with id \\'apm\\'\"},\"status\":404}',\n toString: [Function],\n toJSON: [Function] }"
> }
> {
> "type":"error",
> "@timestamp":"2020-07-28T00:46:14Z",
> "tags":[
> ],
> "pid":7,
> "level":"error",
> "error":{
> "message":"Internal Server Error",
> "name":"Error",
> "stack":"Error: Internal Server Error\n at HapiResponseAdapter.toInternalError (/usr/share/kibana/src/core/server/http/router/response_adapter.js:69:19)\n at Router.handle (/usr/share/kibana/src/core/server/http/router/router.js:163:34)\n at process._tickCallback (internal/process/next_tick.js:68:7)"
> },
> "url":{
> "protocol":null,
> "slashes":null,
> "auth":null,
> "host":null,
> "port":null,
> "hostname":null,
> "hash":null,
> "search":"?start=2020-07-27T00%3A42%3A50.900Z&end=2020-07-28T00%3A42%3A50.900Z&serviceName=Lonsid_GeneralService_Web_Host",
> "query":{
> "start":"2020-07-27T00:42:50.900Z",
> "end":"2020-07-28T00:42:50.900Z",
> "serviceName":"Lonsid_GeneralService_Web_Host"
> },
> "pathname":"/api/apm/service-map",
> "path":"/api/apm/service-map?start=2020-07-27T00%3A42%3A50.900Z&end=2020-07-28T00%3A42%3A50.900Z&serviceName=Lonsid_GeneralService_Web_Host",
> "href":"/api/apm/service-map?start=2020-07-27T00%3A42%3A50.900Z&end=2020-07-28T00%3A42%3A50.900Z&serviceName=Lonsid_GeneralService_Web_Host"
> },
> "message":"Internal Server Error"
> }
> {
> "type":"response",
> "@timestamp":"2020-07-28T00:46:14Z",
> "tags":[
> "access:apm"],
> "pid":7,
> "method":"get",
> "statusCode":500,
> "req":{
> "url":"/api/apm/service-map?start=2020-07-27T00%3A42%3A50.900Z&end=2020-07-28T00%3A42%3A50.900Z&serviceName=Lonsid_GeneralService_Web_Host",
> "method":"get",
> "headers":{
> "host":"192.168.10.145:5601",
> "user-agent":"Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/85.0.4148.0 Safari/537.36",
> "accept":"*/*",
> "accept-encoding":"gzip, deflate",
> "accept-language":"zh-CN,zh;q=0.9",
> "connection":"close",
> "content-type":"application/json",
> "kbn-version":"7.8.0",
> "referer":"http://192.168.10.145:5601/app/apm"
> },
> "remoteAddress":"192.168.4.111",
> "userAgent":"192.168.4.111",
> "referer":"http://192.168.10.145:5601/app/apm"
> },
> "res":{
> "statusCode":500,
> "responseTime":88,
> "contentLength":9
> },
> "message":"GET /api/apm/service-map?start=2020-07-27T00%3A42%3A50.900Z&end=2020-07-28T00%3A42%3A50.900Z&serviceName=Lonsid_GeneralService_Web_Host 500 88ms - 9.0B"
> }
> 
> ```

---

<div class="post-metadata">

**Author:** ![smith](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/smith/32/53043_2.png) [@smith](https://discuss.elastic.co/u/smith)\
**Post date:** [July 28, 2020, 3:45am UTC](https://discuss.elastic.co/t/apm-service-map-internal-server-error-500/242818/2 "2020-07-28T03:45:35Z")

</div>

This issue is fixed in 7.8.1: [https://www.elastic.co/guide/en/kibana/current/release-notes-7.8.1.html#bug-v7.8.1](https://www.elastic.co/guide/en/kibana/current/release-notes-7.8.1.html#bug-v7.8.1)

In 7.8.0, as a workaround, you can enable a machine learning job on at least one service in APM.

What you're seeing looks like that error, but let me know if upgrading or the workaround don't work and I'll take another look.

---

<div class="post-metadata">

**Author:** ![wajika](https://avatars.discourse-cdn.com/v4/letter/w/977dab/32.png) [@wajika](https://discuss.elastic.co/u/wajika)\
**Post date:** [July 28, 2020, 4:02am UTC](https://discuss.elastic.co/t/apm-service-map-internal-server-error-500/242818/3 "2020-07-28T04:02:40Z")

</div>

Ok i try first

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [August 18, 2020, 12:02am UTC](https://discuss.elastic.co/t/apm-service-map-internal-server-error-500/242818/4 "2020-08-18T00:02:44Z")

</div>

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.
